FLAC plugin not used

D-Link specific stuff goes here
Post Reply
ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

FLAC plugin not used

Post by ogre_x » Thu Sep 28, 2006 6:34 am

Hi,

I've been evaluating the linux version (4.1) of the server hoping that it would fit my needs (show photos, play movies and music). One key feature was the possibility to transcode FLAC to WAV.

Now I've tried both the Linux and XP version of the server and none of them uses the plugin - causing the D-Link to just skip the FLAC songs.

I would like more possibilities to set whether to use the plugin or not for different types of clients, but most of all I want the plugin to work with the DSM-320.

Anyone successfully got the plugin working when serving FLAC content to a DSM-320 (eu version)?

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Thu Sep 28, 2006 9:48 am

think we need to change the server here to supress the flac URL for the D-Link

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Post by ogre_x » Thu Sep 28, 2006 10:25 am

Does that mean that the plugin isn't triggered for the d-link today, but that it will be when you update the server? In that case I'm eagerly waiting for the next version...

Or do you mean by suppressing the URL that the D-link never will be able to use the plugin?

As an additional feature request I would like to be able to trigger the plugin when using the web-based gui as well, e.g. by using a special user-agent header in the browser or by forcing it to always on for a certain IP-address on the LAN.

But getting the plugin to work with the dsm-320 is most important for me!

cpane
Posts: 2
Joined: Mon Sep 18, 2006 8:53 pm

DSM320 support (Please :-) )

Post by cpane » Thu Sep 28, 2006 1:27 pm

I too use a DSM320 (Actualy I use the DSM320RD which is the DSM320 w/ DVD Player).

I am evalualting twonky as an alternative to Tversity. I currently have my entire library in FLAC format stored on a linux server in my basement. A major advantage you guys have over some of your competition is your cross platform support (Tversity only does Windows). So having Twonky support FLAC is HUGE for me becuase it means I only need 1 computer (My linux RAID server) up serving files. Currently I have the smb share my FLAC library to a Windows box running Tversity (And some others I am evaluating).

Anyway - Just wanted to chime in to say that FLAC for DSM320 his HUGE for me too. So far, I love what I have seen with your product, keep up the great work !

Thanks

-Chris

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Fri Sep 29, 2006 8:12 am

there will be soon 4.2 beta 1 available which *should* fix that problem....

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Post by ogre_x » Fri Sep 29, 2006 9:58 am

I would be happy to beta test that version on both Windows and Linux.

/F

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Fri Sep 29, 2006 6:17 pm

should be out Monday evening

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Post by ogre_x » Thu Oct 05, 2006 7:45 pm

Any news on the 4.2 beta?

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Post by ogre_x » Thu Oct 12, 2006 8:15 pm

Now I've tried the 4.2 beta1 - same problem - FLAC files are still skipped by the DSM-320. Are the CGI-fixes implemented in the 4.2beta1?

The plugin log is totally blank, so the plugin isn't being called. Tested on both Windows and Linux version of 4.2beta1.

/Fredrik

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Fri Oct 13, 2006 5:30 am

have you installed the flac plugin as well ?

we have tested this with 4.2beta1 and FLAC plays fine with our DSM-320 :?

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Yes

Post by ogre_x » Fri Oct 13, 2006 7:36 am

Here's what I have:

DSM-320 1.07eu (latest eu firmware)
Linux server running CentOS derivate
Win XP Pro SP2

On the linux machine I downloaded the 4.2beta1 from the site, and also the FLAC plugin for 4.1. Did a clean install of the server, unzipped the FLAC plugin and tried to play a .flac-file.

On the Windows machine I did a clean install and unzipped the 4.1 FLAC plugin into the cgi-bin directory.

What next?

/Fredrik

doubrown
Posts: 18
Joined: Sun Oct 22, 2006 1:12 am

Post by doubrown » Sun Oct 22, 2006 1:14 am

I'd like to try the beta as well.

doubrown
Posts: 18
Joined: Sun Oct 22, 2006 1:12 am

Post by doubrown » Fri Nov 17, 2006 11:42 pm

Is a fix available yet?

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Post by ogre_x » Mon Nov 20, 2006 9:59 pm

doubrown wrote:Is a fix available yet?
Not that I know of. 4.2beta3 still doesn't work.

doubrown
Posts: 18
Joined: Sun Oct 22, 2006 1:12 am

Post by doubrown » Tue Dec 19, 2006 10:08 pm

Any update as to when the FLAC issue might be resolved?

stefvienna
Posts: 7
Joined: Mon Mar 12, 2007 5:06 pm

Flac-Plugin for Maxtor NAS?

Post by stefvienna » Wed Apr 04, 2007 11:49 am

Hi Christian,

is there any chance we will see the flac-plugin appear in the maxtor-nas-version of TwonkyMedia?
I use this combination to feed my dsm320 and would love to store my CDs in flac-format ... or is the cpu in the maxtor shared storage too week to handle the transcoding?

Cheers, Stefan!

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

FLAC transcoding working now?

Post by ogre_x » Thu Apr 12, 2007 10:03 am

I accidently noticed that the flac-plugin for linux is newer than the one I had when testing 4.1. I installed the new flac plugin in in 4.2.1 for Linux, and now the plugin actually is used! I see a file in the cache that is of type wav and I managed to play exactly one whole song using the mediabrowser. The rest of the songs stop after a few seconds of play, so it seems a little unstable. I play the stream in Internet Explorer with the mediaplayer plugin over an ssh-tunnel, so maybe it could be network congestion problems. I will try this at home as well.

Also if i choose to play a playlist (m3u file containing the files) nothing is played.

I will not be able to test if the flac plugin works with the d-link until I get home tonight.

Does anyone know if the plugin always is called if it's present in the cgi-bin directory, or only for clients that need it? How does twonky decide when it's needed if that is the case?

animaal
Posts: 2
Joined: Thu May 31, 2007 10:48 pm

Post by animaal » Fri Jun 01, 2007 1:24 pm

Hi, I might have some useful info for people trying to make the FLAC plugin work...

I installed the plugin on my DLink DNS-323, and it seemed to partially work - my media player device was dicplaying the list of FLAC songs as ".WAV", which seemed to imply that the plugin was at least partially fuctional.However, when I tried to play any such track, it was skipped.

I looked at the plugin's source code, and found the problem in cgi-flac.c. There's a line of code (line 212) near the end, "sleep(2000);". For a Linux box, that will cause the plugn to pause for 2000 seconds, turning the FLAC process into a zombie. I simply changee "2000" to "2", rebuilt the plugin, and everything works fine now.

I think this is a bug that would affect all Linux distributions, but it did at least help me on my DLink DNS-323.

Cheers,
Martin.

P.S. - I have a problem with RSS support. All RSS feeds seem to reference the original FLAC file rather than a converted WAV file. Has anybody found a way around this?

Post Reply