Page 1 of 1

Twonky6 with D-Link DNS-323

Posted: Sun Jul 25, 2010 12:50 pm
by hagen_fenris
just a little question for all the D-Link-users.
Has someone tried to install TwonkyMediaserver version 6 on den D-Link DNS 323?

Im still using 4.4.18 and would like to update to the newest build.
But version 5 didn`t run on my NAS.

Hopefully Twonky 6 does.

Grettings from Germany.

Re: Twonky6 with D-Link DNS-323

Posted: Wed Aug 04, 2010 8:33 pm
by docmbs
I have Twonky 6.0.1 successfully (I think) running on my DNS-323 now, once I corrected the amber/pink light issue.

Re: Twonky6 with D-Link DNS-323

Posted: Mon Aug 09, 2010 3:15 am
by nettech
I am looking at upgrading my Twonky software from 4.4.48 to 6.0.1. Since NAS's are no longer supported information is difficult to find. I already have the telnet setup on my DNS so that should not be an issue. Which download did you use for the version 6 Twonky on the DNS-323? What is the Amber/Pink light issue and how did you fix it? Were you able to use the installer (if it still comes with one) or did you install it manually?


Re: Twonky6 with D-Link DNS-323

Posted: Thu Aug 12, 2010 3:06 am
by docmbs
The pink/amber light issue occurs upon startup of the DNS-323 after installing Twonky 6. I believe the memory in the root filesystem file in the NAS is used up and that prevents the NAS from fully booting and it will not be accessible from the network [see]. To prevent it you need to edit the file [see].

1. Download the DNS-323 Twonky NAS installation package at ...

2. Enable Telnet access on the NAS (already done in your case.

3. Run the DNS-323 Twonky NAS installer. Important - during installation uncheck the option box that will start the twonky server. If you forget to uncheck it, the server will start initiallizing after installation and you will get the pink/amber light issue.

4. Open the file in volume 1 of the NAS and change the contents to:
route add -net netmask dev egiga0

ln -s /mnt/HD_a2/.TwonkyMediaServer /home/root

cd /mnt/HD_a2/twonky
/mnt/HD_a2/twonky/twonkymedia -appdata /mnt/HD_a2/twonkydata &

Save the file. If I remember correctly, the only change to the code is the addition of the -appdata line.

5. Log on to telnet and start Twonky Server (with command /mnt/HD_a2/

6. If you experience the pink/amber light issue already or forget to uncheck the start server box during the installation, it gets a little tricky. Using a PC (could not get it to work with my mac) there is a brief period during the boot/startup of the DNS-323 where you can access the NAS over your network before the twonky server starts to load. At this point the drive lights will still be clue. Quickly access the NAS and change the filename of in Volume 1 to something else ( or whatever), which will prevent twonky from loading and buy you some time to make other changes. Then open that file and make the above changes to it. Save the file and name it back to Restart the DNS and it should work again. Remember, if you wait until the drive lights are pink to try accessing the NAS, it will not be visible on your network so you need to act fast while the lights are still blue during the boot for all of this to work.

Hope this longwinded post helps.

Re: Twonky6 with D-Link DNS-323

Posted: Thu Oct 21, 2010 12:52 am
by rookie8155
I just tried to install Twonky 6.x today on my dsn-323. I forgot to uncheck start server option. So it finished successfully and restarted server. No pink light but I can not access drive anymore. I can user webbrower only to access it. How can I resolve this issue now. If I format my drive, will it fix the issue? I already restored dsn-323 to factory default.

Re: Twonky6 with D-Link DNS-323

Posted: Fri Oct 22, 2010 1:17 pm
by rookie8155
docmbs's instructions work very well. Thanks.