Page 1 of 1

Twonkymedia installation disappeared after NAS reboot

Posted: Mon Mar 10, 2008 5:55 pm
by ronaldverhoeven
I've tried installing Twonkymedia 4.4.4 on my buffalo linkstation live. Fortunately I succeeded, and everything worked like it should. Streaming video to the PS3 goes smoothly and perfect. :P But then, I turn on my NAS after having it shut down for the night, Twonkymedia doesn't exist on my NAS anymore. The PS3 doesn't recognize the mediaserver and http://MY-INTERNAL-FIXED-NAS-IP:9000 results in an error meaning the page doesn't exist (anymore)!!. :x

After this I've installed twonky again, but after shutting off the NAS and turning it on again, twonky is gone. I've done the whole thing 3 times now, and the problem is the same everytime.

My question is: Am I the only one with this problem, or is there a way to keep twonky installed even after shutting down and turning on the NAS again? :roll:

Please help because I like Twonkymedia, but installing over and over again ain't exactly fun, and sure doesn't seem like the way its meant to be. :?

grtz Ronald

Re: Twonkymedia installation disappeared after NAS reboot

Posted: Mon Mar 17, 2008 2:07 pm
by Benneton

I had the same problem. When I ugraded my 4.3 to 4.4.* after a reboot of the NAS (Terastation) I got version 4.3 back.
I then removoed manually 4.3 and all references off my NAS, installed 4.4.* amd after reboot Twonky was gone.
I communicated with Twonky about it and they suggested that the problem was that my index of tracks was in some kind of loop.
I finally solved the problem by upgrading my NAS software to the latest version, installed 4.4.* and no problems anymore.

Re: Twonkymedia installation disappeared after NAS reboot

Posted: Tue Mar 25, 2008 3:20 pm
by ronaldverhoeven
Thnx Benneton, I'm going to try that tip of yours. I'm now looking for a newer Firmware (but it has to support telnet communication) for my NAS-drive.

Re: Twonkymedia installation disappeared after NAS reboot

Posted: Thu Mar 27, 2008 5:25 pm
by Benneton

Try tis site for info on firmware with root access this site:

Or the linkstation wiki. or net
Just do a search and you will find it.

Good luck!


Re: Twonkymedia installation disappeared after NAS reboot

Posted: Mon Sep 01, 2008 9:33 pm
by wermarc

I had the same problem after installing 4.4.6: I had 4.4.6 working on my nas until I did a reboot of my nas server. After reboot I was back to 4.4.3.

It seems that the installer uses a different directory to install the files on the nas device (share/twonkyvision for 4.4.3 - share/twonky for 4.4.6). The installer/uninstaller does not remove or update the startup scripts from /etc/rc.d/rc3.d - after reboot you will either start the old version, or no server at all if the files from the old version are no longer available.

Here is what I did to solve this problem:

1. uninstall the server using the supplied installer (only check 'Uninstall old server' in the installation dialog)
2. telnet to the terastation
3. remove any startup script for the twonky server:
cd /etc/rc.d/rc3.d
rm S99twonkyvision

cd /etc/init.d
rm twonkyvision
rm twonky

4. remove any remaining directories from any twonky installation:

cd /mnt/array1/share (this my be different for you ... check where the 'share' direcory has been created of your drive)
rm -R twonky
rm -R twonkyvision

5. exit the telnet session
6. reinstall the latest version using the supplied installer

after this, twonky worked again for me, after nas reboot, the correct version of twonky is started ...

Had some trouble finding all this, so I post my solution hoping it helps some other people with the same problem.



Re: Twonkymedia installation disappeared after NAS reboot

Posted: Sun Oct 05, 2008 3:13 pm
by paw123
Thanks guys for all this help. Here a few additional things I want to add:

I was upgrading from 4.1 to 4.4.9 and off course ran into the problems described here. The above solution fixes this issue beautifully.

I am running a Terastaton, 4 ROKU clients, and 2 Syabas based machines for movie streaming.

Here is what happened to me after the restart issue was fixed: I got random crashes all over the place - after seeing the server once it was not accessible anymore - seemed like it was stuck in a loop. This is reported in other threads - although updating the firmware (on the Terastation) did nothing for me. (I went from 1.12 to 2.16 - 2.18 did NOT work for me).

After a few hours of reinstalling and swearing I took the approach where I disconnected everything from the network... And bam! - the server worked stable.
It seemes like the ROKU's were the issue for me. I guess they were still looking for the old server and had some variables cached. I unplugged the ROKU's from the power, hooked them back up and voila! Everything is working smoooooth and perfect!

Hence - before you go hardcore simply unplug/reset your clients!

Thank you Twonky - still love that server! Please fix the installer though on the next release!