Twonky on Buffalo Linkstation Mini

Post Reply
highpriest
Posts: 2
Joined: Tue Jul 22, 2008 11:14 pm
AV Hardware: Buffalo Linkstation Mini

Twonky on Buffalo Linkstation Mini

Post by highpriest » Tue Jul 22, 2008 11:27 pm

Hi all,

I have installed on my Buffalo Linkstation Mini the Twonky media server. I used the package for the Linkstation Pro, which I was told is the same in principle. Prior to the install I got hold of the root password.

The install went through OK and the server got installed. I have also bought the license immediately. The web interface worked fine too - so I configured it a little further. I was also able to access the server from my PS3 and stream movies - no problem.

The only issue I have is that when I restart the Linkstation Twonky is not booting and the old media server which came with the box starts up. Anyone could advise how I can make Twonky start all the time and get rid of permanently of the pre-installed crap?

Thanks a lot for any advice

Regards

P

tinyclanger
Posts: 2
Joined: Mon Apr 07, 2008 9:44 pm
AV Hardware: Kiss 1600, Kiss sofware, Twonky, Panasonic TX-32LXD700

Re: Twonky on Buffalo Linkstation Mini

Post by tinyclanger » Wed Jul 23, 2008 11:02 pm

I had a similar problem with my LS Live, but solved it after reading and following the instructions here :- http://buffalo.nas-central.org/forums/v ... 999&hilit=

Specifically this bit :-
"You may want to run Twonky at startup to save the manual process of typing “/etc/init.d/twonky start” from a telnet window. To do this enter (from the telnet window);

Code:
cp /etc/init.d/rcS /etc/init.d/rcS_old

This makes a copy of the rcS file before we modify/screw it up. Then enter(exactly as typed);

Code:
echo "exec_sh twonky" >> /etc/init.d/rcS"

Basically ( I think, I'm not that hot on Linux commands) that the echo "exec_sh twonky" command puts twonky into the startup sequence for the Linkstation, so it starts every time it boots.

Post Reply