Samsung BD-C6900 - Subtitles / Problem with Firmware v1019

Post Reply
User avatar
amunoz_tico
Posts: 67
Joined: Sat Jan 19, 2008 1:23 am
AV Hardware: Samsung UN46C7000 & BD-C6900 ¬ Sony PS3 & BPD-S370 ¬ Pioneer VSX-820-K ¬ Bose Acoustimass 15 ¬ Wii ¬ DLink DNS-323 & DIR-655 ¬ Monster HDP2400
Location: Costa Rica

Samsung BD-C6900 - Subtitles / Problem with Firmware v1019

Post by amunoz_tico » Fri Mar 04, 2011 7:27 pm

Hi Everyone!

When I updated to TwonkyServer version 6.0.31-RC6 (http://www.twonkyforum.com/viewtopic.ph ... 277#p33998), my Samsung BD-C6900 Blu-Ray could play the subtitles finally.

However, this week I decided to update the firmware of the Blu-Ray to v1019.0. BAD IDEA !!! Now I can't enable the subtitles :twisted:

1) Does anyone know how downgrade the firmware of the Blu-Ray player?

2) Does anyone have the same problem?


NOTE = My Blu-Ray is an US model.


Regards!
Samsung UN46C7000, BD-C6900 & BD-D5500 ¬ Sony PS3 ¬ Pioneer VSX-820-K ¬ Bose Acoustimass 15 ¬ Wii ¬ DLink DNS-323 & DIR-655 ¬ Monster HDP2400

User avatar
amunoz_tico
Posts: 67
Joined: Sat Jan 19, 2008 1:23 am
AV Hardware: Samsung UN46C7000 & BD-C6900 ¬ Sony PS3 & BPD-S370 ¬ Pioneer VSX-820-K ¬ Bose Acoustimass 15 ¬ Wii ¬ DLink DNS-323 & DIR-655 ¬ Monster HDP2400
Location: Costa Rica

Re: Samsung BD-C6900 - Subtitles / Problem with Firmware v10

Post by amunoz_tico » Mon Mar 14, 2011 4:23 am

Hi Team!

As I did in other topic, I want to share the following information from "Samsung PC Share Manager", because it allowed me to enable the subtitles. Also, I already tried with other Media Server (Serv iio) and it could enabled the subtitles.

I hope this information can be useful for you.

Code: Select all

<name>SourceProtocolInfo</name>
http-get:*:video/mpeg:
DLNA.ORG_PN=MPEG_PS_NTSC;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:video/vnd.dlna.mpeg-tts:
DLNA.ORG_PN=MPEG_TS_SD_KO;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:video/vnd.dlna.mpeg-tts:
DLNA.ORG_PN=MPEG_TS_SD_KO_T;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:video/vnd.dlna.mpeg-tts:
DLNA.ORG_PN=MPEG_TS_SD_KO_ISO;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:video/vnd.dlna.mpeg-tts:
DLNA.ORG_PN=MPEG_TS_HD_KO_T;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:video/vnd.dlna.mpeg-tts:
DLNA.ORG_PN=MPEG_TS_HD_KO_ISO;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:audio/L16;rate=44100;channels=1:
DLNA.ORG_PN=LPCM;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:audio/L16;rate=44100;channels=2:
DLNA.ORG_PN=LPCM;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:audio/L16;rate=48000;channels=1:
DLNA.ORG_PN=LPCM;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:audio/L16;rate=48000;channels=2:
DLNA.ORG_PN=LPCM;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:audio/mpeg:DLNA.ORG_PN=MP3;
DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000,
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM;
DLNA.ORG_OP=01;DLNA.ORG_FLAGS=00D00000000000000000000000000000,
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_MED;
DLNA.ORG_OP=01;DLNA.ORG_FLAGS=00D00000000000000000000000000000,
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_LRG;
DLNA.ORG_OP=01;DLNA.ORG_FLAGS=00D00000000000000000000000000000
Samsung UN46C7000, BD-C6900 & BD-D5500 ¬ Sony PS3 ¬ Pioneer VSX-820-K ¬ Bose Acoustimass 15 ¬ Wii ¬ DLink DNS-323 & DIR-655 ¬ Monster HDP2400

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: Samsung BD-C6900 - Subtitles / Problem with Firmware v10

Post by Twonky_Rick » Tue Mar 22, 2011 8:17 pm

Thanks for providing this! I've forwarded this info to the guys who fixed subtitles last time. Crossing fingers...

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/

User avatar
amunoz_tico
Posts: 67
Joined: Sat Jan 19, 2008 1:23 am
AV Hardware: Samsung UN46C7000 & BD-C6900 ¬ Sony PS3 & BPD-S370 ¬ Pioneer VSX-820-K ¬ Bose Acoustimass 15 ¬ Wii ¬ DLink DNS-323 & DIR-655 ¬ Monster HDP2400
Location: Costa Rica

Re: Samsung BD-C6900 - Subtitles / Problem with Firmware v10

Post by amunoz_tico » Tue Apr 26, 2011 7:36 pm

TMM_Product_Manager wrote:Thanks for providing this! I've forwarded this info to the guys who fixed subtitles last time. Crossing fingers...

- Rick

Hi Rick... Any update?
Samsung UN46C7000, BD-C6900 & BD-D5500 ¬ Sony PS3 ¬ Pioneer VSX-820-K ¬ Bose Acoustimass 15 ¬ Wii ¬ DLink DNS-323 & DIR-655 ¬ Monster HDP2400

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: Samsung BD-C6900 - Subtitles / Problem with Firmware v10

Post by Twonky_Rick » Tue Apr 26, 2011 11:07 pm

I did not hear back from them. Normally the only way they can fix this type of thing is to have the device and the guys who fix this are in Berlin, so they probably can't even buy the device.

It would be easier to get this fixed if this is also happening with Samsung TVs running the newest firmware. Is anyone having problems with that?

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/

Post Reply