Page 1 of 1

Twonky not displayed on Noxon

Posted: Sat Sep 29, 2007 6:35 pm
by Lamborn
hi there,

I've installed the "TwonkyMusic Version 3.0/Terratec Noxon Edition" on an Ubuntu Platform. After starting the Server my Noxon (FW: is dispayed on the TwonkyMusic Status WebSite but the server is is not displayed in the main menu of the Noxon!?!? Does it make sense?

I tryed with restarting the noxon and restating the server but it wouldn't work. I also enabled the UPnP-Option on my Firewall and again: nothing.

Any ideas?


Posted: Sun Sep 30, 2007 3:23 pm
by Lamborn
Hi there,
something happend:
suddenly (and I don't know why) I saw my Twonky in the main menu and I was able to play some music :D . And while I was listening I switched to the main menu and the Twonkyserver wasn't displayed anymore?!?!?
Anyone with ideas?


Posted: Tue Oct 02, 2007 4:41 pm
by Lamborn
Hi to myself :wink:
I tried to get a little deaper. I started TCPDUMP on the server PC and there where multicast packets send by the server and also send by Noxon. That's the reason why I can see the Noxon in the status site of the TwonkyServer.
I also started Whireshark on my notebook. It's like the Noxon connected via WLAN, so I expected to see the same multicast packets (shared medium). But there where only multicasts from the Noxon and no communication from the server.
Is there an error in reasoning? Where are the multicasts from the server?


I've got it

Posted: Thu Oct 04, 2007 6:07 pm
by Lamborn
I solved the problem :D
There was a active IGMP filter set on my Zyxel Router. I had to connect to my router via telnet to disable de rule.


Posted: Thu Nov 29, 2007 6:26 am
by schumi_x

I have probably the same problem, that TwonkyMedia sometimes is available in the main menu of my iRadio and sometimes not.

I can play music from my Faviorites (that were put there when TwonkyMedia was available) without any problems,.
So connection to the Twonky Server must be available and the Twonky Server streams the music correctly, but in the main menu there is still no TwonkyMedia available.

Then for any reasons (I have not yet found out how to reproduce this) TwonkyMedia is available again in the main menu of the iRadio.
I have tried both static IP and DHCP mode, but no difference.

Has anyone an idea what might go wrong here?
Is this an issue caused by Twonky or by the firmware of iRadio? Or both?

Thanks in advance


Posted: Fri Dec 07, 2007 4:44 pm
by Wortelsoft
Same problem her,

I had to disable igmpsnooping in my router (Speedtouch 780) to fix it
(Speedtouch Support)

The CLI commands (telnet) to do this in the Speedtouch 780:

eth bridge igmpsnooping config state disabled

Posted: Sun Dec 09, 2007 12:01 pm
by vossdie
Hi Wortelsoft

can you explain me on how to this on Windows XP...I have no experience with telnet...but the only occasional appearance of the media server drives me I am prepared to the unknown :-)



Posted: Mon Jan 21, 2008 7:55 pm
by halali
See this explanation of the problem: