Page 1 of 1

Current PS3 firmware/TwonkyMedia version combo doesn't work?

Posted: Sat Nov 13, 2010 6:28 pm
by Daddl
I can't see or play my media files on the ps3. It worked some time ago, but - as described below - after my media server was offline for a few months (due to me moving house, etc.) I'm unable to get it back to working again with the console. The media server is recognized, but what I see instead of the video/photo/music subfolders are messages like 'there are no images' and 'there are no videos' for photos and videos, and 'unsupported data' for music. I don't care so much for the music or videos, I watch/listen to those mainly on the pc - but the images would be great for doing slideshows in the living room.

I'm running a QNAP 219P NAS which I use mainly for backup purposes and as my local media server (running TwonkyMedia version 5.1.6). I can access all media perfectly through the webinterface (from my Fedora 14 machine) and they are properly recognized by TwonkyMedia. Following the advice in several threads found in these forums I
- rebuild the database after copying/deleting/renaming files
- restarted the server
- checked the registered mac in the media server (which btw. shows up twice - once in small letters and a second time in capitals)
- removed all (to my knowledge) problematic chars from the file names (and rebuild the database afterwards)

Still, since I took the NAS back online, upgrading it to the latest firmware version (with TwonkyMedia 5.1.6) and also updating the PS3 firmware to version 3.50, I can't access my media files anymore on the PS3. Now during that time I also consolidated my media library from various storage places to the NAS, and for the first time added videos to my library. So I'm not sure whether the problem lies with one or more media files (music is a mix of mp3, ogg and wma, videos are mostly XVid .avi files, some .wmv-files, some .mpegs, images are all plain .jpg files). Before I had only jpgs for images and mostly mp3s for music.

So is my problem really caused by the PS3 choking on unknown media files (even if I never actually play them or even want to access a completely different media type), and which media formats might that be? Why are unknown media files not simply ignored? Are there other causes, is it a specific problem with the PS3 firmware 3.50?

Re: Current PS3 firmware/TwonkyMedia version combo doesn't work?

Posted: Wed Nov 17, 2010 7:52 am
by Daddl
Ok, got it running:

First I renamed all my media files to remove ANY chars from the filenames that might potentially cause problems (not a bad things anyways as I use them on my phones, different pc OS, and on the PS3). Then I seperated them into seperate folder structures depending on their media type (mp3, ogg, wma, wmv, avi, mpg,...). Then I pointed the media server only at the mp3, the jpg and the video folders (avi & mpg) and rescanned the media library and rebuild the database.

Thank god for perl or I'd still be copying & renaming files. Not sure wether it was the file names or the format, but it works now.