6.0.33 on QNAP NAS - Playlists Not Recognised on Reboot

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
Corsair
Posts: 8
Joined: Mon Jul 11, 2011 2:38 am
AV Hardware: QNAP NAS TS-219 (Firmware v3.3.9 Build 0120), running Twonky Server 6.0.33

Xbox 360

Samsung LA46C650L1F TV

6.0.33 on QNAP NAS - Playlists Not Recognised on Reboot

Post by Corsair » Fri Sep 16, 2011 10:00 am

Hey all,

I am running TwonkyServer 6.0.33 on my TS-219 QNAP NAS.

I have recently noticed something interesting behaviour with TwonkyServer which I hadn't noticed before.

Basically - I have a number of playlist files (all *.pls files). My main music share folder is called /Qmultimedia/Music and all the playlist files are store there (so - it can be considered the root share for music).

After creating the playlist files I noticed that I needed to do a "Rebuild Database" for them to show up under the "Playlists" option of Twonky Vision (or my Samsung TV).

With them now showing up I thought all was good. Not so.

After turning off my NAS for the night I turned it back on to realise that TwonkyServer had not recognised all my playlist files. In fact - it had recognised all but one.

To fix this - I needed to manually do a database rebuild again.

After doing so - I ran another test. I turned off the NAS. Waited 30 minutes. Turned it back on again - and now TwonkyServer didn't recognise a few of my playlist files.

After doing a manual database rebuild - they were all recognised again and appearing under the "Playlist" section.

It almost seems that its random chance whether or not it recognises the playlist files and how many it does recognise when it does.

This is somewhat frustrating to do a manual database rebuild every single time.

Has this issue been recognised and, if so, is it fixed in the more recent version of Twonky Server?

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: 6.0.33 on QNAP NAS - Playlists Not Recognised on Reboot

Post by Briain » Fri Sep 16, 2011 12:29 pm

Hi

I found this with m3u playlists in Twonky 6.0.34 (Qnap Marvell, Qnap Intel and Windows versions) and I reported it as a bug (PV reference MM-5186). I always set Twonky rescan period to zero, so I tried it with rescan set to -1 and also to 10000 (roughly weekly) and either of those settings provided a resolution.

As it's on the official issue list, it will be fixed in a future version, but the above will likely get you round the problem for now.

Bri

Corsair
Posts: 8
Joined: Mon Jul 11, 2011 2:38 am
AV Hardware: QNAP NAS TS-219 (Firmware v3.3.9 Build 0120), running Twonky Server 6.0.33

Xbox 360

Samsung LA46C650L1F TV

Re: 6.0.33 on QNAP NAS - Playlists Not Recognised on Reboot

Post by Corsair » Fri Sep 16, 2011 5:11 pm

Briain wrote:Hi

I found this with m3u playlists in Twonky 6.0.34 (Qnap Marvell, Qnap Intel and Windows versions) and I reported it as a bug (PV reference MM-5186). I always set Twonky rescan period to zero, so I tried it with rescan set to -1 and also to 10000 (roughly weekly) and either of those settings provided a resolution.

As it's on the official issue list, it will be fixed in a future version, but the above will likely get you round the problem for now.

Bri
Cheers mate. I guess that means that they are aware of the issue.

I have my rescan set to 5 at the moment. Will try with a higher value (not too sure about using -1). How on earth did you figure out 10000 would work though? Would a lower number work?

Post Reply