Connection to server breaks every 30 minutes

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
Coldblooded
Posts: 3
Joined: Wed Oct 12, 2011 9:56 am
AV Hardware: LG PZ750S
TwonkyServer 6.0.37 on Windows 7 64

Connection to server breaks every 30 minutes

Post by Coldblooded » Wed Oct 12, 2011 10:26 am

Hi,

I have Twonky Server installed on my home PC on Windows 7 64. Server version is 6.0.37. Both TV (LG 60PZ750S) and PC are connected to router Zyxel NBG460N EE (wired). I use internal player of TV to watch movies.
The problem is that every 30 minutes (approximately) TV lose connection to Twonky server with message "Device is plugged off, please check settings and try again". After that Twonky server is dissapeared from DNLA servers list on TV and appeared again after restarting TV network. There is no sign of any crash or error of twonky on PC. It may looks like problem in TV - but there is no such problem with other mediaservers I've tried - Plex and HomeMediaServer.

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: Connection to server breaks every 30 minutes

Post by Twonky_Rick » Wed Oct 12, 2011 4:31 pm

I have not heard of anyone having this problem before. Is there a chance that your PC is going to sleep or standby?

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/

Coldblooded
Posts: 3
Joined: Wed Oct 12, 2011 9:56 am
AV Hardware: LG PZ750S
TwonkyServer 6.0.37 on Windows 7 64

Re: Connection to server breaks every 30 minutes

Post by Coldblooded » Wed Oct 12, 2011 5:19 pm

No, power scheme is "maximum performance", sleep mode and hibernation is turned off.

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: Connection to server breaks every 30 minutes

Post by Twonky_Rick » Wed Oct 12, 2011 8:59 pm

Looks like your settings are fine.

Is anyone else experiencing this issue?

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/

Shockmaindave
Posts: 70
Joined: Thu Dec 29, 2005 4:20 am
AV Hardware: Windows Vista
2 Playstation 3's
1 Retired DSM-320
Location: Syracuse, NY
Contact:

Re: Connection to server breaks every 30 minutes

Post by Shockmaindave » Thu Oct 13, 2011 2:23 am

Coldblooded,
I've had some trouble with losing a connection on Win7-64, but I've got a couple question for you to see if our problems are similar.

First, if you are streaming media that's longer than a half hour, does it stay connected? (Mine would stay connected until the end of them movie, then die.)

Are you using a custom NavTree?
Are you serving over the Internet, using something like PlugPlayer? Have you changed any port configurations? (I had done both, and by making some changes to my setup, I somehow got it to work.)

I hope we can find this problem together.

Dave

Coldblooded
Posts: 3
Joined: Wed Oct 12, 2011 9:56 am
AV Hardware: LG PZ750S
TwonkyServer 6.0.37 on Windows 7 64

Re: Connection to server breaks every 30 minutes

Post by Coldblooded » Thu Oct 13, 2011 8:47 am

First, if you are streaming media that's longer than a half hour, does it stay connected? (Mine would stay connected until the end of them movie, then die.)

No, disconnection doesn't depend on playlist. For example I watch TV show, episode length 20 minutes, 1st episode - OK, 2nd - disconnection soon after beginning. Or I can put movie on a pause and have a disconnection after app. 30 minutes.


Are you using a custom NavTree?
Are you serving over the Internet, using something like PlugPlayer? Have you changed any port configurations? (I had done both, and by making some changes to my setup, I somehow got it to work.)

Not sure if I understand a question, but I only watch media files stored on my PC by TV built-in player.

Also I have a log made right after a moment of disconnection - maybe it can help?

Wires
Posts: 44
Joined: Mon Jan 25, 2010 2:16 am
AV Hardware: PS3

Re: Connection to server breaks every 30 minutes

Post by Wires » Sun Oct 16, 2011 12:11 am

When you click on the server status tab, is your cache ungodly huge? Only time I get stuttering/drops is when the cache is spiraling out of control so the PC is bogging down.

Clicking on the "server restart" button resets it and fixes the problem.

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Sun Nov 27, 2011 5:00 pm

i have the same problem
Device is plugged off, please check settings and try again
after 30 minutes of connection

i have uninstall after install and the same problem

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Sun Nov 27, 2011 5:45 pm

@methos

when that happens
Is it just the TV that is saying that?

Also,
is it accessable from a pc other than the one running twonky server
by going to the following url, when that happens

http://<twonky server ip>:9000
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Sun Nov 27, 2011 7:03 pm

i see the message with tv i use wd live plus
i dont use the http adress

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Sun Nov 27, 2011 7:14 pm

checking the url would help in figureing out
if twonky is or is not actually up and running
when that issue arises
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Sun Nov 27, 2011 8:31 pm

yes
the http work

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Sun Nov 27, 2011 9:15 pm

If you look at the media receivers from the config page

http://<twonky server ip>:9000/config

Is your WD TV Live Plus listed as a "WD TV Live Plus"?

If you click on the Server Staus from the config page
What version of twonky is shown?
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Mon Nov 28, 2011 12:02 am

on media recever is listed
Version: 6.0.38

i test on other dlna mezzmo i have the same problem

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Mon Nov 28, 2011 1:41 am

Knowing that helps to figure what might be happening

Is your PC running AntiVirus Firewall and or Windows Firewall software?

Is the WD TV Live Plus firmware up to date?

Have others on the WD forums made not of this problem?

It could also be a networking problem,
The port on the WD, or the Router, or a Switch, could be suspect.
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Mon Nov 28, 2011 2:49 am

i dessactivate windows firewall and i don't have antivirus on pc
my wd the is up to date
i have the same problem on my blue ray samsung.

i dont open the port on my routeur

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Mon Nov 28, 2011 3:33 am

Is your pc connected wired or wireless?
In either case, is it a built in device, or a usb attached one?

and for a way off the wall question,
is there an active screen saver set on you pc?
By any chance is it set to kick in after 30 minutes?

Also
Is the WD TV Live or Blue Ray player wired or wireless?
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Wed Nov 30, 2011 12:13 am

i'am wired for WD TV Live or Blue Ray player
i'am desactivate screen save and hibernate

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Wed Nov 30, 2011 1:03 am

what make and model is your router?
as each router has ther own quirks
and each version of firmware adds to this

Is there a network switch involved?
Are they connected through powerline networking?
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Thu Dec 01, 2011 2:36 am

dlink dir-825 Hardware Version: B1 Firmware Version: 2.06NA
no the cable in my wd tv live in my routeur and the same for blu ray player

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Thu Dec 01, 2011 3:40 am

Thanks for the info

I took a look on the dlink forums, and found a couple of similiar issues with dlna

http://forums.dlink.com/index.php?topic=42716.0
http://forums.dlink.com/index.php?topic=42423.0
http://forums.dlink.com/index.php?topic=41883.0

from the post http://forums.dlink.com/index.php?topic=42716.0
it mentions Enable Multicast Streams
I would try enabled and disabled
and see if either helps

here is the menu on the router where it is located, at the bottom

http://www.support.dlink.com/emulators/ ... twork.html
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

methos
Posts: 14
Joined: Tue Jun 28, 2011 6:12 pm
AV Hardware: s

Re: Connection to server breaks every 30 minutes

Post by methos » Sun Dec 04, 2011 3:04 pm

thanks you i'am activate the option Enable Multicast Streams
i work.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Connection to server breaks every 30 minutes

Post by phibertron » Mon Dec 05, 2011 3:55 am

I am glad to hear that it is now working
Your Welcome
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Post Reply