Playing files from Twonky Server on 2011 Samsung TV buffers

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
tomf
Posts: 1
Joined: Sat Dec 31, 2011 1:10 pm
AV Hardware: Twonkey Server on Windows 7 x64, files on NAS, Samsung UE40D6510 LED TV (2011), wired gigabit Ethernet between everything.

Playing files from Twonky Server on 2011 Samsung TV buffers

Post by tomf » Sat Dec 31, 2011 1:34 pm

Hi

I have just got Twonky Server up and running on a dedicated Windows 7 x64 machine to serve movies from my NAS to my Samsung TV (UE40D6510). It works so nearly perfectly, including playing back 1080p 3D MKVs flawlessly, apart from occasionally during playback (perhaps every 10 minutes or so, but irregularly) the TV pauses playback for between 0.5 and maybe 5 seconds, sometimes displaying a "Loading..." box in the corner of the screen. It always resumes - it's just very frustrating.

I have tried a variety of different types of movie files, all the same.

I don't think it's a bitrate/complexity thing, since playback doesn't pause at the same point every time.

Bandwidth is not at question - the NAS can pump out 60 megabytes/sec easily, and everything is wired gigabit Ethernet.

I also can't rewind or fast forward - TV says "Not Available" when you try. Pause/play works fine though.

So close to being a perfect solution - would really appreciate help on getting the last bit right.

User avatar
DaemonBeetle
Posts: 305
Joined: Mon Dec 28, 2009 11:05 am
AV Hardware: Plex Media Server, Samsung Smart TV (2009 and 2013)

Re: Playing files from Twonky Server on 2011 Samsung TV buff

Post by DaemonBeetle » Sat Dec 31, 2011 6:24 pm

It sounds like either a network problem or more likely a problem on the server. Monitor its load (CPU and I/O) and see if there are any patterns related to when you see the issue on the TV (Process Explorer is quite handy for that).
No longer running Twonky

User avatar
parnott
Posts: 326
Joined: Mon Sep 20, 2010 9:55 pm
AV Hardware: Twonky, WDTV Live, XBMC (Linux & Windows)

Re: Playing files from Twonky Server on 2011 Samsung TV buff

Post by parnott » Sat Dec 31, 2011 6:49 pm

You have a lot of failure points between your NAS and your TV. If I understand your post correctly, the path from your NAS to your TV is-
NAS->LAN->Router/Switch->LAN->Win7/Twonky->LAN->Router/Switch->LAN->TV

Try and remove some of these faillure points e.g. try as a test-
- streaming directly from your Win7 computer
- streaming directly from your NAS (there are many NAS builds of Twonky)

Post Reply