Problems with Twonky IP installed on Iomega NAS

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
fldbryan
Posts: 5
Joined: Sat Aug 25, 2012 6:58 pm
AV Hardware: IOMEGA Media Server

Problems with Twonky IP installed on Iomega NAS

Post by fldbryan » Sat Aug 25, 2012 7:26 pm

All,

I am running Twonky on an Iomega NAS Cloud Edition. the version was built into the machine apparently. I am also running under Verizon FIOS. The local IP address for my NAS is 192.168.1.4.

The server runs fine locally. However when I access it from another location it fails after the first two screens. As an example if my IP address to the world was 156.55.100.65 I would be entering http://156.55.100.65:50599 and the first screen shows up just fine. and even the second screen works. However, when I finally go to get a listing of videos it changes the address to http://192.168.1.4:50599. Obviously since this is a local IP address the system fails.

Is there something I can alter to fix this and how? I don't want to continue running IIS all day on a desktop just to access my videos.

Thank you,

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Problems with Twonky IP installed on Iomega NAS

Post by phibertron » Sat Aug 25, 2012 9:31 pm

If the version installed is 7.x then you could do this

http://www.twonkyforum.com/viewtopic.ph ... 627#p40577

On previous versions about the only way to do it, is write your own web service, to alter the responses from twonky

If 7.x interests you, I posted a pdf that someone put together
on how to upgrade the iomega connect to version 6.x
but what is important from that guide is how to get access to ssh
which is the starting point to be able to install 7.x

http://www.twonkyforum.com/viewtopic.ph ... ega#p41467
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

fldbryan
Posts: 5
Joined: Sat Aug 25, 2012 6:58 pm
AV Hardware: IOMEGA Media Server

Re: Problems with Twonky IP installed on Iomega NAS

Post by fldbryan » Mon Aug 27, 2012 1:31 pm

I appreciate the help. I definitely need to upgrade it. It's running 6.0.

The problem is I can't find support.html to turn the features on. Has it been renamed?

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Problems with Twonky IP installed on Iomega NAS

Post by phibertron » Mon Aug 27, 2012 5:20 pm

I dont have an iomega device of any flavor to verify the steps

But accorindg to the following thread, it might be possible to enable ssh on the device

Does diagnostics.html exist for you?

http://iomega.nas-central.org/wiki/Root ... _Media_CE)
Go to <IP ADDRESS OF NAS>/diagnostics.html
2. Tick checkbox to enable SSH.
3. Upon restart, login with username 'root' and password 'soho<admin password>'
(All one word. Example:'sohoabc123'. If no admin account is set- just 'soho')
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

fldbryan
Posts: 5
Joined: Sat Aug 25, 2012 6:58 pm
AV Hardware: IOMEGA Media Server

Re: Problems with Twonky IP installed on Iomega NAS

Post by fldbryan » Mon Aug 27, 2012 7:40 pm

Yes that worked. Diagnostics existed and I was able to se the NAS. Now of course comes the more delicate part. LOL

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Problems with Twonky IP installed on Iomega NAS

Post by phibertron » Mon Aug 27, 2012 9:13 pm

glad that it did, and I assume that it had the ability to enable ssh

yup, that is does

I would start by just takeing note of where everything is related to twonky, for example

what folder is it in
where is the appdata folder
where is the startup script

one you have that noted, it makes it a bit easier to keep track of changes
I reccomend making copies, just in case

Once you do actually get it running, then you can tweak from there
I wouldnt tweak it, till you get it running
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

fldbryan
Posts: 5
Joined: Sat Aug 25, 2012 6:58 pm
AV Hardware: IOMEGA Media Server

Re: Problems with Twonky IP installed on Iomega NAS

Post by fldbryan » Tue Aug 28, 2012 1:21 pm

I got the apps file extracted but can't decompress. CRAMFSCK keeps returning an error on magic block. Very frustrating. Too bad somebody (IOMEGA) just doesn't put out a new apps file that we could just load in.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Problems with Twonky IP installed on Iomega NAS

Post by phibertron » Tue Aug 28, 2012 6:49 pm

I hear ya

did some searching
this link may or may not help you
as it sounds plausible this is what is going on

http://www.linuxquestions.org/questions ... ux-779413/
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Problems with Twonky IP installed on Iomega NAS

Post by phibertron » Tue Aug 28, 2012 7:10 pm

Here is another thread on someone doing work on the iomega connect

http://gramlich.net/projects/iconnect/notes.txt
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

fldbryan
Posts: 5
Joined: Sat Aug 25, 2012 6:58 pm
AV Hardware: IOMEGA Media Server

Re: Problems with Twonky IP installed on Iomega NAS

Post by fldbryan » Tue Aug 28, 2012 7:36 pm

Thanks. I saw the first one and I'll give it a try. I swear if I find a way to fix this I'll build an APPS file and find someplace to store it so others can download it. LOL

Locked