upnp_cp_resubscribe CP received error

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

upnp_cp_resubscribe CP received error

Post by Stem » Wed Jul 16, 2014 11:11 pm

Why no dates in twonky log file? :shock: :x

Aside from that, anyone know what these two events are :-
08:38:57:548 [Error] - LOG_EVENTING: handleConnections : upnp_cp_resubscribe CP received error in resubscribe response 412 from http://192.168.1.88:9999
08:38:57:549 [Error] - LOG_EVENTING: Error: 115 Operation now in progress

Is there a detailed twonky manual somewhere?

Cheers.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Thu Jul 17, 2014 3:11 pm

Not sure about the dates at the moment

My guess on the error, is the _cp_ stands for Control Point
and that at some point the server was in touch with one
and that when it tried to communicate with it, it failed
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Thu Jul 17, 2014 10:16 pm

Thanks again phibertron; any ideas about the second error msg?

08:38:57:549 [Error] - LOG_EVENTING: Error: 115 Operation now in progress

What's a "115 Operation"? Is there a manual somewhere?

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Fri Jul 18, 2014 12:16 am

Your Welcome
Sadly there is no manual to decipher the error codes
In this scenario, they would mean more to the developers than us for the most part

Just a guess, but I think that since the Error: 115 Operation now in progress
comes right after the handleConnections : upnp_cp_resubscribe CP received error response 412
That it is most likely related to it

I know that the above is conjecture
Maybe emailing or contacting twonky support might help, maybe not...

outside of the errors in the log file
my guess is that you either looked at them to check them, like a good admin does =)
or you checked them because something isn't/wasn't working?
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Fri Jul 18, 2014 9:10 am

Really appreciate your help phibertron.

I did previously try to contact twonky support through their website but whenever I click the Support link "Ask us a question" I get "To post or comment please sign in" and then straight away "Error loading login options" this happens with both my browsers, IE11 and chrome. Also if I click "View known issues" on their website I get a 404.

As to why I'm interested in what these errors mean I see them in respect of my Samsung Smart TV. I'm trying to ascertain which side is at fault. Sometimes when I try to stream from WDMC to TV I can navigate through my WDMC folders but when I click on a programme the TV just hangs with a blank screen and the spinning circle timer icon. After about 30-60 seconds the TV times out this operation and reports that the WDMC connection has gone (can't remember exact message). If I try several more times it will eventually work but its a pain having to go through this torture for ten minutes before I can watch something. But the above errors were not coincident with me streaming - its probable that these errors are reported by twonky when the tv is switched into standby mode, but I need to get more evidence for this to be certain.

I think I did see an errorlevel setting in twonky config - any idea what the procedure is for me setting that on WDMC? Maybe if I got more detailed reporting out of twonky I could figure out whats going on.

Alternatively do you know if its possible to see any error logs on the samsung TV (UE37ES6300U)?

Cheers!

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Fri Jul 18, 2014 6:24 pm

Really appreciate your help phibertron.
Your Welcome
I did previously try to contact twonky support through their website but whenever I click the Support link "Ask us a question" I get "To post or comment please sign in" and then straight away "Error loading login options" this happens with both my browsers, IE11 and chrome. Also if I click "View known issues" on their website I get a 404.
That used to go to the other site, but since its not more, your see the errors
why they haven't fixed that yet it disturbing
As to why I'm interested in what these errors mean I see them in respect of my Samsung Smart TV. I'm trying to ascertain which side is at fault. Sometimes when I try to stream from WDMC to TV I can navigate through my WDMC folders but when I click on a programme the TV just hangs with a blank screen and the spinning circle timer icon. After about 30-60 seconds the TV times out this operation and reports that the WDMC connection has gone (can't remember exact message). If I try several more times it will eventually work but its a pain having to go through this torture for ten minutes before I can watch something.
I have a dim memory of reading about something like this in the past
but a lot of the info that could have been looked at is now no more since they took down the other site
just a guess, but what sounds like whats happening is this:

Either,
the TV is cacheing the list, and isn't really talking the server yet,
and when you attempt to play an item the waiting icon appears
because the NAS or Twonky is actually in a sleep state
but the TV doesn't know that, so its stuck waiting for a response
which could time out until the service is full woken
which is maybe why multiple attempts to play it make it work

Or,
Still related to "possible" caching on the TV
If your NAS is using DHCP, maybe the change of its IP when turned on or awoken
is different, but the TV doesn't know that yet
which is maybe why multiple attempts to play an item make it work
But the above errors were not coincident with me streaming - its probable that these errors are reported by twonky when the tv is switched into standby mode, but I need to get more evidence for this to be certain.
I think they "might" be related, but then again...
I think I did see an errorlevel setting in twonky config - any idea what the procedure is for me setting that on WDMC? Maybe if I got more detailed reporting out of twonky I could figure out whats going on.

Alternatively do you know if its possible to see any error logs on the samsung TV (UE37ES6300U)?
I used to have a great how to on the old site
this post eludes to the bitfield being used to tune the logging level

http://twonkyforum.com/viewtopic.php?f=2&t=4473

In 7.x by default, when you go the Twonky Web Inteface, yourNASIP:9000/#advanced
under advanced there is a section for logging
when one enables it, it is setting this variable in the twonkyserver.ini to 4095
which in binary is 111111111111
meaning that each 1 column is turning on specific event log entries
I used to have an exact list, but I think 8191 (1111111111111) is also a valid choice

when you click on the enable logging its actually using an rpc call to make the change

This would tell you what the value is in a browser window

Code: Select all

http://x.x.x.x:9000/rpc/get_option?v
This would set the value to what you want

Code: Select all

http://x.x.x.x:9000/rpc/set_option?v=4095
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Fri Jul 18, 2014 6:46 pm

I turned on logging to check a few things and noticed this

07/18/14 13:35:03:073 [Error] - LOG_EVENTING: handleConnections : Received error in resubscribe (4339) response 412 from http://192.168.1.22:2869/upnphost
07/18/14 13:35:03:073 [Error] - LOG_EVENTING:
07/18/14 13:35:03:136 [Error] - LOG_EVENTING: handleConnections : Received error in resubscribe (4341) response 412 from http://192.168.1.22:2869/upnphost
07/18/14 13:35:03:136 [Error] - LOG_EVENTING:

using IE to play a video, I let it launch using the HTML5 embedded in the page
and no event logs were generated

using Firefox to play a video, I told it to play the video in Windows Media Player
but for firefox to do this, it had to download the entire video before playing it
when looking at the event logs, I saw the above entries
and was able to repeat the cause and effect

It looks like its more informational about the pauses that were shown between the download and streaming scenarios
different than yours, but similar

Is your NAS using DHCP or a Static IP?
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Fri Jul 18, 2014 7:50 pm

Hi phibertron, I haven't finished digesting all the info above but just to give you a quick answer to your last question - both NAS and TV were initially DHCP, but due to these issues I changed both to static last weekend. I guess it could be the HDD sleep issue that I've seen mentioned on the WD forums. Maybe I'll try disabling the sleep; although as a long term solution I think spinning the hard drive 24/7 sucks.

Cheers.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Sat Jul 19, 2014 1:25 am

Do try disabling the sleep mode and see if it fairs any better
if doing that helps, there maybe other tactics we can use to wake up the nas when needed
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Sat Jul 19, 2014 5:24 pm

Spent another hour messing about with this today. Job for life maybe? :lol: I think you make a good point about the folders/directory being cached in the TV - I now think that is very likely what is going on. I dont think the issue is to do with the NAS HDD sleeping because Ive done a few trials where I make sure the HDD is spinning by streaming something to my PC and then stop the streaming, go to the TV and try to play something there but it hangs.

I've not had chance to mess with the twonky error log levels yet.

My current theory is that if I stream something on the TV and then exit/return from the Samsung AllShare App to another source (eg terrestial TV or PVR) then perhaps the TV doesn't tell twonky to stop streaming. Then I think it gets into a mess and next time I try to stream something on the TV it fails/hangs and it takes a manual restart of twonky and several TV restarts to get sync'd again. Today since getting it resync'd its been perfect every time I've gone back to it, perhaps because I've been making sure I press the stop button before exiting the Samsung TV AllShare App. Fingers crossed, I'll see how it goes.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Sat Jul 19, 2014 7:53 pm

good troubleshooting tactics =)

I think that in addition to this possible caching thing, I vaguely remember somewhere on the Samsungs TV
that the server itself becomes cached/sticky
in the past I kind of remember people having to go somewhere in the TV's menu tree
and delete the twonky server, for it to be found again
I know it not directly related, just figured I'd pas that nugget of info along
maybe removing the server and reading on the tv might help. maybe not

I took a look at the idea that maybe its also client profile related
just curious, In the Twonky Web interface is your tv detected as "Samsung Smart TV" or "Samsung TV" ?
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Sat Jul 19, 2014 11:32 pm

Twonky sees it as "Samsung Smart TV".

Thanks for the tip about deleting twonky server from TV, I'll investigate that, though I've looked on TV for relevant stuff without success.

Tonight btw I tried to stream something again and it hung. Suppose this time it might have been HDD sleep issue. :roll:

Starting to think about sending it back now tbh, it just cant do what its supposed to.

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Sun Jul 20, 2014 3:10 pm

I've been through all the options I can find on the TV phibertron and all I found was an allshare menu option but the sub page is empty - however next time it gets stuck I'll take another look in there.

What are the tactics you referred to earlier for waking up the NAS HDD - is it basically what I did, ie stream something from a PC are there smarter ways to do it?

Cheers.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Sun Jul 20, 2014 8:22 pm

they may have changed the interface and its options in the newer models

To do the below on the WDMC, you would need to create a cron job
or have something else on the network, do you what you would be doing manually to wake it up
but that would involve leaving something else on to so that
so the cron job would be the way to go, if you want to create a sleep wake schedule
the cron job could be as simple as doing a simple wget to the twonkyserver
or whatever it would take to wake up the disk and the server

Here is some food for thought
About 5 years ago, on my HP ex485 windows home server
I used to use a scheduled task for sleep and wake times
The household has crazy in and out schedules, so I stopped doing that a long time ago
the server has 4 drives in it, and it has been on 24/7/365 for the past 4 years
outside of patches and power outages, no drive issues in regards to running them all the time

The current theory is that things usually break on a change of state
in the case of a HD it is more likely to break on a spin up or spin down,
and less likely to break down if it is a constant state

The bigger question is how much power is saved or not saved, and what is the cost or cost difference
the server I use is fairly low power, and is worth my 24/7 current usage model, for now...
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Stem
Posts: 10
Joined: Mon Jul 14, 2014 6:46 pm
AV Hardware: WD MyCloud 3TB, Samsung TV (UE37ES6300U), Windows 7 & 8

Re: upnp_cp_resubscribe CP received error

Post by Stem » Sun Jul 20, 2014 11:43 pm

Ok thanks a lot for the info, thats an interesting shift in wisdom wrt keeping the HDD spinning. I'll certainly bear that in mind. There is an option now in WDMC dashboard to disable Drive Sleep, I guess this would have the same ultimate effect as a cron job that keeps nudging the disc. I guess one thing I could explore is a cron job to enable Drive Sleep during the night and disable it during day and evening.

I made a couple of small but useful breakthroughs today - when the samsung TV hangs when I ask it to stream something I noticed that the twonky dashboard status immediately went to "Streaming", so twonky *appears* to be doing the right thing, and the TV appears to not pick up and display the stream. It just keeps on saying "Loading".

The second thing I discovered is how to abort the stream from the TV which is a very useful breakthrough. After the TV times out from the "Loading" state enter SmartHub and select the AllShare icon - this seems to immediately send a reset to twonky because twonky's status changes from "Streaming" to "Not Streaming". So now at least I have a way of getting the two devices back in sync! AFter that I was able to sucessfully stream the next programme I selected from the Videos Folder.

So maybe I now at last have a usable workaround, lets see how it goes over the coming days.

Cheers.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: upnp_cp_resubscribe CP received error

Post by phibertron » Mon Jul 21, 2014 1:53 am

Good sleuthing
I have a hunch, that the above is a the crux of it all,
and not the sleep thing, basically a bad handshake
in that
its something to do with the way twonky is dealing with the Samsung
and possibly the media type being presented

the nas builds are different in some ways,
but I wonder if you had a test windows machine or a VM
you could see if version 7.2.8 acts any better than the one on the nas
you can run them 30 days in trial mode

TwonkyServer Revision History
http://twonkyforum.com/viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Locked