Twonky not generating thumbnails for large videos

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
midardoe
Posts: 3
Joined: Wed Aug 06, 2014 8:18 pm
AV Hardware: WDMyCloud

Twonky not generating thumbnails for large videos

Post by midardoe » Wed Aug 06, 2014 9:46 pm

Running Twonky Server 7.3 on Windows 7:-

For video files less than 2GB Twonky is generating thumbnails correctly from the metadata cover art.

However for video files larger than 2GB Twonky is not generating thumbnails.

Have tried all the obvious things like rebuilding databases, deleting and starting all over from scratch but no difference.

Metadata is fully populated for all the files and the album art appears correctly in Windows Explorer, Itunes etc just not for Twonky Server.

Looking into the twonky database folders the jpg files are there for the files less than 2GB but nothing for the files greater than 2GB.

Twonky Server is displaying "default" album art from the first file in the folder for all the files where it has not generated album art.

This happens regardless of the size of the actual album art file. i.e. For a 720p and a 1080p version of a video file with the exact same metadata only thre 720p has the correct thumbnail in Twonky.

Does Twonky have a cap on fiile size for which it will try to read and generate thumbnails to accelerate the time to generate the database maybe?

Any help or suggestions would be appreciated as I cannot find this same problem elsewhere in the forum.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Twonky not generating thumbnails for large videos

Post by phibertron » Thu Aug 07, 2014 5:18 am

There is not file size limit that I know of or have seen
All of my thumbnails are embedded
I'll take a look at it tomorrow
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Twonky not generating thumbnails for large videos

Post by phibertron » Thu Aug 07, 2014 6:15 pm

I did a test with a 5GB mp4 (avc video), and yup, it isn't generating a thumbnail
it is also happening on 7.2.8, probably all of 7.2.x and 7.3.x
as they are now using ttu.exe and ttu-video-thumb.desc in the cgi-bin, which is supplied by twonky
prior to that one had to use ffmpeg.exe and ffmpeg-video-thumb.desc, which you have to put into the cgi-bin

note: I never noticed the issue myself, as all of my thumbnails are embedded

If you place a copy of ffmpeg.exe into the cgi-bin, and clear the cache, and then restart the server
I was able to get thumbnails working on the greater than 2GB files
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Twonky not generating thumbnails for large videos

Post by phibertron » Thu Aug 07, 2014 6:37 pm

In addition

TwonkyServer Revision History
http://twonkyforum.com/viewtopic.php?f=2&t=9424

Twonky Server 7.2.7
================

- New ini-property disablealbumart_fallback to define album art behavior:

If a content item does not contain embedded album art,
Twonky Server can use album art from other media items within corresponding album.
Default value is 0,
i.e. album art fall-back enabled for music and videos.
disablealbumart_fallback=0

If set to 1, album art fall-back for music will be disabled
i.e. the embedded album art for one music title isn't used for all music items in the view.

If set to 2, album art fall-back for videos will be disabled
i.e. the embedded album art for one video item isn't used for all video items in the view.

If set to 3, album art fall-back for both music and videos will be disabled.
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

midardoe
Posts: 3
Joined: Wed Aug 06, 2014 8:18 pm
AV Hardware: WDMyCloud

Re: Twonky not generating thumbnails for large videos

Post by midardoe » Thu Aug 07, 2014 9:39 pm

Many thanks phibertron for looking at this so quickly and posting such a clear and effective response.

This worked to an extent.

For the smaller files it has again generated a thumbnail based on the metadata cover art. For the larger files it has generated a thumbnail based on a frame near the start of the video file. Better, but not exactly what I was hoping to achieve. I would really like all the thumbnails based on the album art I have tagged the files with. The frames fframe has selected are a bit hit and miss depending on the frame it has picked up. Presumably it looks a certain number of frames or a certain percentage into the video file to get a frame.

Based on what you have said I will look to see if I can get around this by embedding the album art from the metadata already in the video files.Is there some way you know to copy the album art in the metadata tag into the file?

I have tagged all the files using MetaX

As I have a lot of video files I am looking for some way to batch or automate this.

Or can fframe be configued to use the album art to generate the thumbnails?

Any other thoughts much appreciated.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Twonky not generating thumbnails for large videos

Post by phibertron » Thu Aug 07, 2014 11:12 pm

Your Welcome

Yeah, the ffmpeg route and the non working ttu are both doing it frame based based on the .desc file settings
ttu = twonky thumbnail utility

ffmpeg-video-thumb.desc

Code: Select all

exec: ffmpeg  -ss $videothumbtime -i $infile -vcodec mjpeg -vframes 1 -an -f image2 -y -ss 5 -s $targetgeometry -aspect 1:1 $outfile
ttu-video-thumb.desc

Code: Select all

exec: ttu  $infile  $outfile  $targetwidth  $targetheight  100  20  25  70
How its supposed to work is this, close to this order of precedence that I can tell
if there is an embedded thumbnail, it will use that
if there is no embedded thumbnail, it looks for a jpg with the same exact name as the video
if there is no filename jpg for a video it looks for folder.jpg
if there are none of the above, it generates one from ttu or ffmpeg if it exist
if there are none of the above, you get the generic thumbnail

A long time ago I used MetaX on windows, not a pleasant experience
I currently use Mp3tag for all my of my tagging on my mp4 videos, of which 99% are using

I think anything that will embed a thumbnail will work
as to whether you do a frame grab or download one from the net is up to you
I only use jpg files for embedding thumbnails, as yes other types will embed, the result might not
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

midardoe
Posts: 3
Joined: Wed Aug 06, 2014 8:18 pm
AV Hardware: WDMyCloud

Re: Twonky not generating thumbnails for large videos

Post by midardoe » Thu Aug 07, 2014 11:20 pm

Thanks again phibertron,

You got me thinking about how the tag data had been embedded in my files and I had a play around with MP3tag on the video files.

Basically it has a feature to "optimise mp4". This apparently "removes all free atoms and puts moov and tags before actual data to make the files "fast start streaming" compatible".

I suspect my files had the metadata added to the end of the files and I am guessing that Twonky is choosing to skip over large files if it cant find the metadata in the start of the file maybe to save time generating the database.

So I am using MP3tag to optimise all my files. It is a bit slow probably because of the large file sizes but for the large ones it has already optimised they are now showing correctly in Twonky after recreating the database.

Windows, itunes, etc all able to read the tags ok so it is a bit of a faff but if it works I will be happy.

Thanks

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Twonky not generating thumbnails for large videos

Post by phibertron » Fri Aug 08, 2014 12:08 am

Yeah, I too do the optimize of my mp4's with mp3tag
The large video I tested was optimized, which didn't seem to help with that issue

I use handbrake to encode, of which I could use it to do the optimize
but since I do the bulk of my tagging in mp3tag, I just do it all there

As I understand it, the main reason to optimize an mp4
is so that a client can get start playback sooner, and or not have to buffer the entire file
to get the metadata and track information etc.
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Post Reply