Vanishing Media

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
Alepsis
Posts: 10
Joined: Wed Jul 30, 2014 6:41 pm
AV Hardware: WD MyCloud

Vanishing Media

Post by Alepsis » Fri Aug 15, 2014 2:07 am

Setup: WD My Cloud 4TB, Twonky Server 7.2.8

By WD's default, Twonky is set to share All Content Types in the </Public> folder. The </Public> folder contains <Shared Music>, <Shared Pictures>, <Shared Videos> folders.

Problem: I wanted finer-grained control, so I went to Twonky's </webconfig#sharing> and I added 3 new folders, </Public/Shared Music>, etc, setting each content type appropriately. Then I selected the new folders, de-selected </Public> (the default one), saved changes, and restarted Twonky.

Twonky started scanning, and everything seemed to be going as it should. At one point, Twonky was indicating it had found >40,000 songs and it was still scanning. I checked again half an hour later --

Videos: 0, Songs: 0, Photos: 0

I checked the media files, they were fine, likewise the respective folders.

So I went back to Twonky's sharing setup, disabled the three new folders, enabled </Public>, saved, restarted Twonky. Twonky started scanning again; found all the files; and this time they stayed found.

So what's going on? Did I miss something obious? A known bug? What do I need to do?

Thanks.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Vanishing Media

Post by phibertron » Fri Aug 15, 2014 3:37 am

While yes what you did in the Twonky Web Interface would normally do what you would expect
The WD MyCloud and MyBook nas drives are geared towards doing this from the WD Web Interface

I think there might have been a disconnect between the two causing the 0 files issue

Did you upgrade Twonky on the nas, as it comes with 7.2.6-2 ?

Things to be aware of:
How to create a Public or Private Share on a WD My Cloud
http://wdc.custhelp.com/app/answers/det ... M0pTX2w%3D

One of the things that you can choose there is whether or not to enable "Media Sharing" for that share
You enable or disable "Media Sharing" for existing shares
Also, one can NOT add granularity to the media types that are to be shared
Also, one can NOT enable "Media Sharing" on folders in a Share

So whats going on is this,
what ever shares are defined as having "Media Sharing" enabled
are being sent to the twonky server on NAS startup and on Twonky startup
When you restarted Twonky from the Twonky Web Interface, it didn't lose what you did
But it would have on by a special WD script that is used for ""Media Sharing"

Not to worry, there are two solutions to the issue

Either create separate shares for you media types to be the way you want, outside of the Public Share
Or
stop the NAS from overriding what you do in the Twonky Web Interface
By doing the following

1. enable SSH by going to the ip of your nas with /UI/SSH
2. Connect to the IP of your nas using Putty, http://www.putty.org/
login : root
password : welc0me
3. Rename the script that is causing the issue, with these two commands, in the putty console
cd /usr/local/sbin
mv writeTwonkyContentDir.sh writeTwonkyContentDir.sh.old
4. Now you can set the shares in the Twonky Web Interface as needed/wanted

NOTE:
If you want to be able to have Twonky start to look for folders from the root of the NAS wich is /
it is currently set to start from /shares, you can do this with an RPC call
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Alepsis
Posts: 10
Joined: Wed Jul 30, 2014 6:41 pm
AV Hardware: WD MyCloud

Re: Vanishing Media

Post by Alepsis » Fri Aug 15, 2014 2:36 pm

Thanks for your reply.

[quote="phibertron"]Did you upgrade Twonky on the nas, as it comes with 7.2.6-2 ?[/quote]
No. I suspect it was upgraded when I upgraded the firmware to v04.00.00-607, which I did right away after installing.

[quote="phibertron"]what ever shares are defined as having "Media Sharing" enabled are being sent to the twonky server on NAS startup and on Twonky startup[/quote]
So, if I understand you correctly, on WD My Cloud, a directory has to be defined as a share before Twonky can use it appropriately -- or else I need to disable the writeTwonkyContentDir.sh script.

Well, I'll try the shares thing first (no danger of voiding the warranty).

Thanks again.

User avatar
phibertron
Posts: 1566
Joined: Sun Jan 30, 2011 5:52 pm
AV Hardware: Hardware
========
WHS - HP Ex495
PS3
XBOX 360
iTouch - Gen 2 and Gen 3
PSP - 3000

Encoders
========
Handbrake
x264
ffmpeg
mencoder

Tagging
======
mp3tag

Re: Vanishing Media

Post by phibertron » Fri Aug 15, 2014 4:49 pm

Your Welcome
No. I suspect it was upgraded when I upgraded the firmware to v04.00.00-607, which I did right away after installing.
Well that's a bonus, WD used to drag there feet on doing this in the past
So, if I understand you correctly, on WD My Cloud, a directory has to be defined as a share before Twonky can use it appropriately -- or else I need to disable the writeTwonkyContentDir.sh script
.

As a share with Media Sharing turned on, or disable the script and use twonky to point to folders
viewtopic.php?f=2&t=10627
viewtopic.php?f=2&t=9353
viewtopic.php?f=2&t=9408
viewtopic.php?f=2&t=9416
viewtopic.php?f=2&t=9424
viewtopic.php?f=2&t=9364
viewtopic.php?f=2&t=9497

Locked