Twonky 7.3 won't accept key - DNS-320L

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
Posts: 1
Joined: Wed Jan 21, 2015 2:15 am
AV Hardware: DNS-320L, Samsung UN55HU7000F

Twonky 7.3 won't accept key - DNS-320L

Post by bjr1 » Wed Jan 21, 2015 2:30 am

I have Twonky Server 7.3 installed on my DNS-320L. I installed using the install package found at I purchased a key last night after my trial expired and entered it. Got this message - "Your trial version has expired. If you have previously entered a license key, try restarting your device running Twonky Server." Restarted the NAS 2-3 times with no change. Uninstall the add-on and reinstall. Got a 30 trial restart and re-entered the key. Same result. Same message. Restarted NAS and no change.

Anyone experience this? Any help is greatly appreciated.

Posts: 1
Joined: Mon Feb 02, 2015 9:53 pm

Re: Twonky 7.3 won't accept key - DNS-320L

Post by rcasebere » Mon Feb 02, 2015 9:58 pm

Yes - I have the same issue.

My MYBOOKLIVE did not originally ship with Twonky.

A year or so ago, I downloaded Twonky trial version. The trial expired and i didn't revisit Twonky until a few days ago when I decided to purchase a license and install 8.0.2.

I installed 8.0.2 and tried to enter my license key. No worky.

I rebooted MBL several times - no worky, restarted Twonky - no worky and have emailed support about it - without response.

So as of now, I have no solution. If anyone does - please post it or send to me too !

Post Reply