4.4 Beta 1 with PS3 support released

General discussion about the media server. Feature requests. Hints, tips and tricks.
User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

4.4 Beta 1 with PS3 support released

Post by twonky-christian » Thu May 24, 2007 8:24 pm

Hi,

we have just released 4.4 Beta 1 with support for the PS3. 8)

There are also some minor fixes on sort problems and wrong client detection.

Please have a look here:
http://www.twonkyvision.com/Download/Tw ... x-4-4.html

This will give better support for PS3 - but Internet Radio is undoable as
the PS3 needs a content lenght and than downloads the songs :-( :-(

Also we did not manage to get WMV to work - but some of the MPEG4
codecs work fine :)

Thanks
Christian

bluheim
Posts: 10
Joined: Thu May 24, 2007 10:32 am

Post by bluheim » Thu May 24, 2007 9:05 pm

Thanks !!!

Will the MacOS version be released soon ?

starhubble
Posts: 57
Joined: Wed May 23, 2007 5:38 pm

Post by starhubble » Thu May 24, 2007 9:11 pm

Cool! When can we expect transcoding? Is it very far off?

komp
Posts: 11
Joined: Thu May 24, 2007 6:46 pm

Post by komp » Thu May 24, 2007 9:32 pm

Just noticed the Version numbers show : TwonkyMedia Version 4.3 using 4.4 version under linux. Is it a typo or ?

thanks

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Thu May 24, 2007 9:36 pm

Are there problems with the Linux build script, as it's still reporting 4.3 The Windows build correctly sayst 4.4 B1
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

komp
Posts: 11
Joined: Thu May 24, 2007 6:46 pm

Post by komp » Thu May 24, 2007 9:42 pm

the file is the same size also from 4.3 to 4.4.

atk
Posts: 20
Joined: Wed Jul 12, 2006 2:37 pm

Post by atk » Thu May 24, 2007 10:06 pm

YES, YEAH, YES, YEAH!

Now, the Buffallo Linktheater is recognized (as a symbian device.. not sure if this is from the past install of 4.3, but don´t care).

all files are here, and the sorting in videos is like ever (alphabetical).

also i have the feeling that he is a little bit faster right now..

are there a full changelog anywhere?

greetz & many many many thx in advance... good to see that you care fast if problems exist..
AtK

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Thu May 24, 2007 10:09 pm

What's new in Version 4.4
-------------------------
new Features:
+ PS3 support (MP3,JPG,MPEG1,MPEG2,some MPEG4), no Internet Radio possible

Changes:
o changed DSM-320 communication with the server as the device crashed from time to time

Bug fixes:
- sort criteria for playlists fixed
- artist removed from default sort criteria
- date removed from default sort criteria
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

xberserker
Posts: 7
Joined: Thu May 24, 2007 2:46 pm
Contact:

Post by xberserker » Thu May 24, 2007 10:10 pm

Ditto
bluheim wrote:Thanks !!!

Will the MacOS version be released soon ?

edlitmus
Posts: 3
Joined: Thu May 24, 2007 10:05 pm

Post by edlitmus » Thu May 24, 2007 10:15 pm

Will the 4.4 Mac build be a Universal Binary?

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Thu May 24, 2007 11:16 pm

MAC will be released tommorrow

Please keep us posted if there are Linux Versions with old 4.3 release numbers :-(

Christian

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Thu May 24, 2007 11:31 pm

I got some lovely AVC encoded 720p HD video streaming this evening... I re-encoded it using RedKawa PS3 Video 9, on the 720HD 3072KBps

http://www.bbcmotiongallery.com/Custome ... %20in%20HD

I used this as my test video. Looked great, and twonky streamed it without any problems to my PS3...
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

bluheim
Posts: 10
Joined: Thu May 24, 2007 10:32 am

Post by bluheim » Fri May 25, 2007 5:35 am

twonky-christian wrote:MAC will be released tommorrow
Great Can't wait ! :)

Someone already told you you are some incredibly fast guys ?

Daz_Genetic
Posts: 3
Joined: Fri May 25, 2007 1:32 am

Post by Daz_Genetic » Fri May 25, 2007 5:37 am

TwonkyVision doesn't seem to handle my WMA files correctly. They are served perfectly fine using both the WMP11 and Nero Home servers, but they show up as "Unsupported Data" using the Twonky server.

Coach Ota
Posts: 3
Joined: Wed Jan 04, 2006 10:59 am

Post by Coach Ota » Fri May 25, 2007 7:24 am

I tried out the 4.4b1 release tonight with good results for video. My H.264 and MPEG-4 videos are recognized and playing correctly. I tested out various 480p clips and 720p trailers and even the BBC Motion Gallery videos that mgillespie mentioned. Nature is beautiful indeed in HD. I tried streaming some 1080p content but my 11g network was barely up to the task.

Unfortunately, MPEG-4 AAC audio was still listed as "unsupported data". :(

Anyways, things are getting closer to it being fully workable for me.

One last comment: The version for Buffalo LinkStation PowerPC still lists version 4.3 in the startup message and on the config pages.

ogre_x
Posts: 75
Joined: Tue Sep 05, 2006 7:12 am
AV Hardware: ClearOS 5.1 Linux server (4.4.18)
ClearOS 5.1 Linux server (5.1.3)
PS3
HDX-HD1000
Location: Stockholm, Sweden
Contact:

Post by ogre_x » Fri May 25, 2007 7:42 am

twonky-christian wrote: Please keep us posted if there are Linux Versions with old 4.3 release numbers :-(

Christian
http://www.twonkyvision.com/Download/4. ... -2.2.5.zip

Has 4.3 written in the web config, so your build script might do with a little makeover..

I will try the new version tonignt with my DSM-320 to see if the crashes are gone.

3no
Posts: 4
Joined: Fri May 25, 2007 2:44 pm

Post by 3no » Fri May 25, 2007 2:48 pm

Is this available yet for Infrant ReadyNAS? That link from the download page is broken...

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Fri May 25, 2007 4:08 pm

We will sennd Infrant the Beta to build a package....

MAC version is online now

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Fri May 25, 2007 4:10 pm

What is the status of the Linux version? Is it actually 4.4b1? Is it some kind of hybrid? Bit concerned it still says 4.3 and I may only have some of the fixes...
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Fri May 25, 2007 5:32 pm

Noticed we now have 4.4 Beta 2 online.

Christian, do you have a changelog?

It looks like WMA Streaming to PS3 is now working... WooHoo... :-)

Still no joy on the unknown Artist problem with WMA tags :-(
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Fri May 25, 2007 7:23 pm

Hi,

WMA is the only bigger update - just a few fixes on socket leaks...

No - sorry - the WMA parser still needs to be re-done

Christian

starhubble
Posts: 57
Joined: Wed May 23, 2007 5:38 pm

Post by starhubble » Fri May 25, 2007 7:37 pm

I can't seem to navigate in streamed video files. I can hit L1 to go to the beginning, but that's it. The menu icons for FF/REW are greyed out. Should this be possible?

n-e-r-d
Posts: 6
Joined: Fri May 25, 2007 5:20 pm

Post by n-e-r-d » Fri May 25, 2007 7:49 pm

I am using a Mac Book Pro (Intel) and just downloaded the newest beta from TwonkyVision, I still have the following problem:

The server doesnt show up. If I scan for it, then it shows up (even though the PS3 says it didnt find anything). But as soon as I start browsing for instance Music Files, the server disappears and doesnt come back for a while..
Right now I wanted to start an MP3 - it played it for a split second and then the server simply disappeared again on the XMB.

Edit: Now it streamed a 4 Minute MP3 for like 30 seconds until it simply stopped playback and reverted back to the XMB.

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Fri May 25, 2007 8:10 pm

SOunds like a networking issue between your PS3 and Mac.. Have you disabled the firewall?

Is there any wireless connections or routers, dodgy cabling perhaps?>
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

starhubble
Posts: 57
Joined: Wed May 23, 2007 5:38 pm

Post by starhubble » Fri May 25, 2007 11:42 pm

starhubble wrote:I can't seem to navigate in streamed video files. I can hit L1 to go to the beginning, but that's it. The menu icons for FF/REW are greyed out. Should this be possible?
Is anyone else able to navigate in streamed video files?

Daz_Genetic
Posts: 3
Joined: Fri May 25, 2007 1:32 am

Post by Daz_Genetic » Sat May 26, 2007 2:34 am

WMA support now works. Thanks for the quick update. You guys rock! Songs don't show their album art but that's just a minor annoyance.

Next thing that appears to be weird is that some of my video podcasts don't appear to work (one's downloaded from iTunes). When I looked into the matter, I realised that they have a .m4v extension. Renamed to .mp4 and they work fine. Something appears to be corrupting the files as they are recognized correctly and playback fine via their original (.m4v) filename using other servers.

technocoy
Posts: 1
Joined: Sun May 27, 2007 5:45 am

Same issue

Post by technocoy » Sun May 27, 2007 5:55 am

as the user above who said that the server is cutting in and out on a mac.. it's really weird... even with the firewall turned completely off it still does it...

Any help would be appreciated, since when it works its awesome and I want to buy it immediately.

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Sun May 27, 2007 8:58 am

try to set the IP address of the server via the config files

theberk
Posts: 6
Joined: Mon May 28, 2007 4:41 am

Same problem

Post by theberk » Mon May 28, 2007 2:57 pm

starhubble wrote:
starhubble wrote:I can't seem to navigate in streamed video files. I can hit L1 to go to the beginning, but that's it. The menu icons for FF/REW are greyed out. Should this be possible?
Is anyone else able to navigate in streamed video files?
I have the same problem with mpeg-2 video only. It seems the PS3 is either not receiving or not understanding the information for the length of the file when sent from Twonky 4.4b2. Other files for which it is able to get the length information, it can navigate with all options, ff/rew etc. Most of my videos are in mpeg-2 so it is a bummer. I am hoping we will soon see a fix.

gine
Posts: 5
Joined: Sun May 27, 2007 9:27 am

Post by gine » Mon May 28, 2007 5:24 pm

Its the same here, i cant "search" in Videos. I hope for a fix soon.

cadams
Posts: 2
Joined: Mon May 28, 2007 10:30 pm

Post by cadams » Mon May 28, 2007 10:36 pm

Finally managed to get 4.4 beta 2 installed onto my Linkstation Pro. I can see the server in my PS3 mediashares and I can browse the directories but everything says unsupported like 4.3 did when I was using my PC as a server. I upgraded my PC to 4.4 and was able to play all my MP4's. Has anyone else been able to use 4.4 with a NAS and stream MP4's?

cadams
Posts: 2
Joined: Mon May 28, 2007 10:30 pm

Post by cadams » Tue May 29, 2007 2:41 am

cadams wrote:Finally managed to get 4.4 beta 2 installed onto my Linkstation Pro. I can see the server in my PS3 mediashares and I can browse the directories but everything says unsupported like 4.3 did when I was using my PC as a server. I upgraded my PC to 4.4 and was able to play all my MP4's. Has anyone else been able to use 4.4 with a NAS and stream MP4's?
NNevermind, this was an issue with my PS3 and Linksys WRK54G router, I disabled UPnP in the router and set the PS3 to be a staic IP in the DMZ and now everything is working great.

hamdammage
Posts: 2
Joined: Tue May 29, 2007 6:41 am

Post by hamdammage » Tue May 29, 2007 6:49 am

Tried this for the first time and seems to be working great. PS3 immediately recognized the server and I was browsing media in no time. Unfortunately, I noticed some problems when I added the rest of my music library, which consisted of about 2000 MP3 files. If I select Music->Album, after you see about 20 albums indexed, a "Could not establish connection with media server" message would come up on the PS3 and it never finishes the rest of the indexing. It seems to reach about the same point every time, which is about the first third of my music library. It's funny, because it seems to work perfectly otherwise.

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Tue May 29, 2007 8:21 am

try a rebuild database

gine
Posts: 5
Joined: Sun May 27, 2007 9:27 am

Post by gine » Tue May 29, 2007 1:55 pm

@twonky-christian

is there a fix for fast forward comming soon?

splee
Posts: 5
Joined: Tue May 29, 2007 2:58 pm

Post by splee » Tue May 29, 2007 3:16 pm

Have installed 4.4 Beta 2 on FC6 and the PS3 support has been working a charm. Points I have noticed so far include:

- Total film time for MPEG-2 and MPEG-4 streamed movies are zeroed resulting in no rewind/forward functionality working
- No DivX/Xvid support (this is critical) - PS3 lists these as Incompatible Data
- Relativly unstable - twonkymedia server often requires a server restart especially after streaming data that turns out to be Incompatible or after PS3 has been switched off for a while (can't see media server after scan)
- MUSIC, VIDEO and PHOTO under XMB displays all photos, music and video files/folders regardless of Twonky configuration (.i.e. filter video file only for VIDEO)

Christian - I'm considering purchasing Twonkymedia once the 30 day trial has expired as so far its turning out to be great media server for the PS3 and has the potential to service all my media streaming needs. However can I expect the above points to be fixed/addressed soon or are we looking at a substantial wait before we can expect full and stable PS3 compatibility?

I also read that TVersity is able to stream AVIs to the PS3 by spoofing the container it streams to something the PS3 will accept, can you shed any further light on this approach as I assumed on the fly transoding was the best and only way to do this properly? I must admit the temptation to hook up my AVI library to the PS3 is tempting however I would rather stick to a Linux based platform and therefore Twonky is preferred.

dworin
Posts: 4
Joined: Wed Jan 17, 2007 10:55 pm

Post by dworin » Tue May 29, 2007 4:53 pm

Does 4.4 Beta support cover art displayed on PS3? Thanks.

THE REVENGE
Posts: 33
Joined: Sat May 26, 2007 12:58 pm
Location: The Netherlands
Contact:

Post by THE REVENGE » Tue May 29, 2007 6:46 pm

and when will the mac osx version work straming mp4 movie files
because it still does not work.

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1123
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Post by twonky-christian » Tue May 29, 2007 8:02 pm

MAC version is the same as the others ?

But not all mp4 types work

THE REVENGE
Posts: 33
Joined: Sat May 26, 2007 12:58 pm
Location: The Netherlands
Contact:

Post by THE REVENGE » Tue May 29, 2007 9:52 pm

ah oke sorry did not know that
but do u think it can be fixed to stream mp4 files that where downloaded using the ps3 / files that do work when they are of a flash card directly inserted in the ps3 but won't play when the same fash card is seen trough twonky?

THE REVENGE
Posts: 33
Joined: Sat May 26, 2007 12:58 pm
Location: The Netherlands
Contact:

Post by THE REVENGE » Tue May 29, 2007 9:54 pm

I can't seem to stream any movie files
from my mac to ps3 using twonky !
(twonky media browser can see and play the files yet the ps3 says their incompettable yet the same files do play via usb drive / usb stick.
just not trough twonky !

twonkyvision
Posts: 1
Joined: Tue May 29, 2007 11:38 pm

Mac to PS3 user, slow streaming...

Post by twonkyvision » Wed May 30, 2007 12:02 am

I've tried making some tweaks as per some of the posts but I'm still having issues with slow streaming or buffering.

Pictures take some time to load up while audio and video have constant lag.

I'm using a Mac with a Netgear RangeMax WPNT834. I've tried adjusting settings on the cpu, router and Twonkyvision.

Does any one have any helpful info? any settings advice greatly appreciated. (even willing to purchase a new router if there's one available for Mac.)

Thanks

endo129
Posts: 3
Joined: Wed May 30, 2007 12:37 am
Contact:

Can't get it to work at all!

Post by endo129 » Wed May 30, 2007 12:47 am

Please help - I can't get twonkyvision to work PERIOD. I install it and restart and I get the error that security settings aren't right. i choose to fix, and it restarts and still nothing. The only difference I see after installing 4.4 beta is 1 new folder on my HD. PLEASE HELP!

THE REVENGE
Posts: 33
Joined: Sat May 26, 2007 12:58 pm
Location: The Netherlands
Contact:

Post by THE REVENGE » Wed May 30, 2007 12:58 am

after you installed twonky just run safari or firefox and go to

http://127.0.0.1:9000/


then start from the top left with first stemp and so on
brows to the files u what to share (stream)
like you music / pictures / movies

GOOD LUCK !!! :shock:

endo129
Posts: 3
Joined: Wed May 30, 2007 12:37 am
Contact:

choose my media location?

Post by endo129 » Wed May 30, 2007 12:59 am

ok, so somethings are showing up at the PS3 now. however, most things are corrupted/unsupported.

Is there anyway to point it at my media locations? everything I have is on an external Hd and right now all I see is a jumbled mess of files, none of which are on my external.

djkatsuo
Posts: 1
Joined: Wed May 30, 2007 1:15 am

Post by djkatsuo » Wed May 30, 2007 1:25 am

Ok...I want to place this as a sticky because there are many ongoing threads about mp4 streaming with a mac.

I am running the 4.4 beta 2 with a macbook pro intel running 10.4.9
I have been experimenting with mp4 support since the beta came out and
this is what i've come up with.

mpeg1 = supported
mpeg2 = supported
mpeg4 are very tricky because the ps3 is very picky about what level avc you use. I have used ffmpegx to make level 3 mp4 vids and they play fine on the local ps3 hard drive but came up as unsupported data via twonky.
I downloaded an osx app called visualhub. It also uses ffmpeg as the encoder but has a much easier GUI. after playing around with the settings,
you can make a steamable mp4 file by:
selecting the appletv format , check off h264 encoding,
and go to advanced, enter under the extra ffmpeg flags: "-level 40"
this basically makes it a level 4 avc mp4 file which twonky seems to understand as since then i've been abe to stream any vid using these settings. Also christian, please PM me if you have any further questions regarding this method...as I would love to buy this program as i think it has great potential..just want the mac-ps3 support ironed out a bit more, but im will to experiment to gain progress.

hopes this clears some confusion.

endo129
Posts: 3
Joined: Wed May 30, 2007 12:37 am
Contact:

<deep breath>

Post by endo129 » Wed May 30, 2007 1:38 am

Ok, I've settled down and gotten a lot to work thanks to help from THE REVENGE. Now some general questions if anyone woudl be so inclinded as to answer them.

All I am doing is streaming from my mac to PS3

Does "external Applications" "tab" help me at all - say pointing it to the iTuns folder? I'm looking to try and get some playlists.

Is there anyway to get rid of the "Music" Pictures" "Video" folders I see everytime I go inot the server? I figure they are redundant since I already choose to browse music.

Just some thoughts.

thanks!

hamdammage
Posts: 2
Joined: Tue May 29, 2007 6:41 am

Post by hamdammage » Wed May 30, 2007 5:49 am

twonky-christian wrote:try a rebuild database
This did not solve the "Could not establish connection" error that I described earlier. I did, however, track the problem to an mp3 file. If I removed this 1 file, then I never encountered the problem again. That's great news as I really liked how Twonky Vision worked. Sooooo much nicer than that bloated mess of Nero Home.

chasi
Posts: 4
Joined: Thu May 31, 2007 7:42 pm

HP Media Vault version

Post by chasi » Thu May 31, 2007 7:49 pm

Is there a version of the 4.4 beta that can be used on the HP Media Vault
(MIP Little Endian)?

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Re: <deep breath>

Post by mgillespie » Thu May 31, 2007 8:21 pm

endo129 wrote:
Is there anyway to get rid of the "Music" Pictures" "Video" folders I see everytime I go inot the server? I figure they are redundant since I already choose to browse music.

thanks!
That's already confirmed to be a problem at Sony's end..

Still for a 1.0 release of the feature from Sony, and a 1 week of beta support from Twonky team, I think we are doing pretty well.

I'm sure things will improve both ends quickly....
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

Post Reply