Twonky Server 8.0.3 licence key problem

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
Posts: 1
Joined: Sat Apr 11, 2015 7:45 pm
AV Hardware: Windows Server 2008

Twonky Server 8.0.3 licence key problem

Post by Rezillo » Sat Apr 11, 2015 8:05 pm

I installed Twonky Server 8.0.3 on Windows Server 2008 without a licence key. This gave me 30 days evaluation while I configured it and had all the menus to my liking. All went well, much quicker scan times than other media servers I have tried, so today I bought a licence key.

Received the key, so far so good. Entered it in the boxes in the Status part of the settings page. Pressed Enter, the boxes went away and my licence key appeared, in lower case (this may be significant), in the Detailed Status section below. This lasted about 15 seconds before the licence key boxes reappeared, blank, and the lower case key disappeared from Detailed Status. There was a message to say that the evaluation period had expired and, if I had entered a key, to restart the device. Rebooting the Windows Server or restarting Twonky changed nothing. I tried several licence key entries, both upper and lower case, but exactly the same sequence happened and the key was always lower case in Detailed Status.

To cut a long story short, the only way that registration worked was to do a clean install and enter the licence key during the setup process, not from the Settings page This lost me all the settings I had spent a long time sorting out but it now seems to be registered. Interestingly, my licence key is showing in upper case now in the Detailed Status section. I'm wondering if there is a case bug in the Settings page?

If i have to do this again with a new version, which files should I backup to keep my settings?

Posts: 2
Joined: Sun May 03, 2015 10:45 pm
AV Hardware: TX-NR609 Onkyo Amp
Bubble UPNP server on Windows 8.1 (client on tablet/phone)
Western Digital Sharespace

Re: Twonky Server 8.0.3 licence key problem

Post by Thomas » Sun May 03, 2015 11:25 pm

The exact opposite happens to me. It wont accept my key during install. The only way I can get it to accept it is to install as a trial, go back in and then enter it. Like you, I have experienced it erasing it (when entering it) several times in the setting as well. A reboot, relaunch and re-enter the key and it finally stuck. Now the systray icon shows grey (Twonky not running) yet it is running. The only way I can get to Twonky now is VIA IP:9000 in a browser.

Posts: 5
Joined: Sun Sep 11, 2011 12:42 am
AV Hardware: Playstation 3
Motorola XT1053 (Moto X)
Apple iPhone 4S
HP Touchpad
Roku PhotoBridge
Roku Soundbridge

Re: Twonky Server 8.0.3 licence key problem

Post by pa28pilot » Wed Jun 17, 2015 2:23 pm

I am running Twonky 8.0.3 on Mac OS X 10.10.3, and have been running Twonky on this same machine and media collection for years, through many versions.

For some reason, Twonky is refusing to recognize my license key as valid. The Status page is giving me the message "Your trial version has expired. If you have previously entered a license key, try restarting your device running Twonky Server."

I had been seeing a message indicating that there were multiple instances (there weren't, I checked my process table), and installed 8.0.3. Now I'm consistently receiving the trial key expired message.

Unfortunately, when I attempt to visit the one, true, support link referenced in the sticky post at the top of the forums by mgillespie, I'm receiving "Cannot GET /support/index.aspx"

If anyone has any ideas, I'd very much like to hear them. I get that TwonkyServer really isn't PV's primary focus, but the product has served me well, and I'd hate to migrate if I don't have to.


Post Reply