Twonky not sending MP4 header information? Not parsing it?

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
cbhwr
Posts: 57
Joined: Sun Jun 03, 2007 9:23 pm
Location: Belgium, DK

Twonky not sending MP4 header information? Not parsing it?

Post by cbhwr » Mon Jun 04, 2007 1:18 pm

Hi All,

I am using Twonky from an Iomega Storcenter 250GB and I am finding that it cannot stream MP4 files to my PS3.
I have created a pile of test-files with different configurations, but so far it looks like Twonky is simply not sending any of the Header-information to the PS3. Does Twonky support extracting iTunes-style tags from MP4 files, or at least extract things like run-time and codec?

I have tried with MGillespie's test-file (showreel), and this is suffering from the same problem.

I have also tried rebuilding database and tried restarting Twonky.

The files are playing OKI on the PS3, when copied via the Media-browser interface from Twonky (http://192.168.x.x:9000/webbrowse/)

Twonky: 4.4 B3 PowerPC GLibc 2.2.5
PS3: FW 1.8 (d'uh)
I can optionally provide a test-file or two of a couple of megs.

Best Regards,
Niels Chr. Ø

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Post by mgillespie » Mon Jun 04, 2007 3:48 pm

The showreel test file plays perfectly on my system, streaming from Windows and Linux i386 TwonkyMedia servers, to my PS3...

Could it be something else on your network causing problems? Can you try installing a copy on TwonkyMedia on a Windows machine, and streaming the same file, does than work?

you can email me your test file, and I can try it on my system if you want.... email below (obscured to stop me getting any more spam).

e m a i l @ m a r k g i ll e s p i e dot co dot uk
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

cbhwr
Posts: 57
Joined: Sun Jun 03, 2007 9:23 pm
Location: Belgium, DK

Post by cbhwr » Mon Jun 04, 2007 4:34 pm

I had the server and the PS3 both attached to the same router via cable, with no effect, so I've pretty much ruled out network as the cause.

I do not own a Windows machine, and there doesn't seem to be any 4.4 B3 release for OSX.

Finally, I emailed you my test-file. Right now I do not have a place to put on the web, sorry. It is encoded with X264 and FAAC, muxed with MP4BOX with hinting for streaming. It plays fine when copied to the PS3's harddrive. Interestingly, a 2.2gig file made with exact same tools and settings is failing misserably.

THE REVENGE
Posts: 33
Joined: Sat May 26, 2007 12:58 pm
Location: The Netherlands
Contact:

Post by THE REVENGE » Mon Jun 04, 2007 5:07 pm

OSX 4.4.3 beta will be ready in 1 or 2 days.

chasi
Posts: 4
Joined: Thu May 31, 2007 7:42 pm

Post by chasi » Mon Jun 04, 2007 5:30 pm

This is probably not completely unlike issues I'm seeing using Twonky on my HP MediaVault.

If I use Twonky on my windows PC, all is fine, mp4 files will stream wonderfully. However, from my HP MediaVault, the exact same mp4 files show up as unsupported data and will not play (ps3 complains about not having access).

I've tried pretty much everything I can from making sure all the various folders on the media vault are shared to directly connecting the mediavault to the ps3 to eliminate the wireless router and I always get the same results.

cbhwr
Posts: 57
Joined: Sun Jun 03, 2007 9:23 pm
Location: Belgium, DK

Post by cbhwr » Mon Jun 04, 2007 7:01 pm

The file I use for testing http://nc.thang.dk/VTS_04_0_PS3_YAMB_hinted.mp4
(Yeah, this one is gonna make me burn in MAFIAA hell)


I have been suspecting that it is being parsed incorrectly, but not sure where to look for the file-details in Twonky :(

Best Regards,
Nc.

Kingser
Posts: 1
Joined: Thu Mar 21, 2019 11:33 am
AV Hardware: none

Re:

Post by Kingser » Thu Mar 21, 2019 11:40 am

chasi wrote:
Mon Jun 04, 2007 5:30 pm
This is probably not completely unlike issues I'm seeing using Twonky on my HP MediaVault.

If I use Twonky on my windows PC, all is fine, mp4 files will stream wonderfully. v tight gel review However, from my HP MediaVault, the exact same mp4 files show up as unsupported data and will not play (ps3 complains about not having access).

I've tried pretty much everything I can from making sure all the various folders on the media vault are shared to directly connecting the mediavault to the ps3 to eliminate the wireless router and I always get the same results.
The file I use for testing http://nc.thang.dk/VTS_04_0_PS3_YAMB_hinted.mp4
(Yeah, this one is gonna make me burn in MAFIAA hell)

Post Reply