ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
elliotte08
Posts: 5
Joined: Fri Jun 06, 2008 8:29 pm
AV Hardware: d-link 520 , twonkymedia

ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

Post by elliotte08 » Wed Jun 11, 2008 11:24 pm

:shock:

I am have had problems with twonkyvision 4.2-4.4.5 recognizing my itunes playlist. They only one that works is twonkyvisiion 4.4.1 but it is crapy reading avi files.

I would like to understand why i cant get the twonkyvision 4.4.5 to recognize my itunes playlist. It seems to see all my songs i have going to the itunes folder where i keep the music. It recogninzes my other folder with music that is NOT itunes.

1) I have my config page pointing to the specfic folder where my itunes music is stored
2) I have the external apps config pointing to the itunes xml


Please help I love my twonky but can get the my music to itunes playlist to show up. I have tried RESTART, REBUILD, and RESCAN and none work any other or any suggestions. thanks

ktjensen
Posts: 11
Joined: Mon Jun 02, 2008 4:13 pm
AV Hardware: Sprint Mogul running Windows Mogul 6; and the uPnP client software LOBSTER.

Re: ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

Post by ktjensen » Thu Jun 12, 2008 2:02 pm

works fine for me. Worked right out of the box. Try upgrading your ITUNES version first, and then reinstall.

elliotte08
Posts: 5
Joined: Fri Jun 06, 2008 8:29 pm
AV Hardware: d-link 520 , twonkymedia

Re: ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

Post by elliotte08 » Thu Jun 12, 2008 10:37 pm

:oops: I have the latest version of itunes and I also have the latest with twonky. Does anyone have any more suggestions. I have always had it like this it was until twonky went to 4.2 and up that problems started happening. have tried uninstalling and installing again and again for some reason it shows all my songs ITUNES SONGS and OTHER FOLDER SONGS on the twonky config page but will not show itunes playlist

Heres my setup
1) I have my itunes music files, movies and other music on a NAS (s: drive)
2) I have the latest version of itunes 7.6.2
3) I am running twonky 4.4.5
4) I have my external app pointing to the C:\Documents and Settings\e dub\My Documents\My Music\iTunes\iTunes Music Library.xml
5) I have tried uninstalling and installing again and again for some reason it shows all my songs ITUNES SONGS and OTHER FOLDER SONGS on the twonky config page but will not show itunes playlist

I'm getting this error in my log...does anyone know what this means??? What is the error and how do I fix
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option musicnode1 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option musicnode2 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option musicnode3 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option musicnode4 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option musicnode5 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option picturenode1 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option picturenode2 has changed
10:42:20:312 [Error] - LOG_SYSTEM:restart needed because option videonode1 has changed
10:42:25:421 filescanner thread started
10:43:23:812 scanning
10:43:23:890 scanned S:\big itunes\3T\Unknown Album
10:43:23:890 scanned S:\big itunes\3T
10:43:23:921 scanned S:\big itunes\BG\Unknown Album
10:43:23:921 scanned S:\big itunes\BG
10:43:23:937 scanned S:\big itunes\AZ\DJ Kool Kid-Thristy Hip-Hop Classic (Hos
10:43:23:937 scanned S:\big itunes\AZ
10:43:23:953 scanned S:\big itunes\YZ\Thinking Of A Masterplan CD Single
10:43:23:953 scanned S:\big itunes\YZ
10:43:23:968 scanned S:\big itunes\112\Unknown Album
10:43:23:968 scanned S:\big itunes\112
10:43:23:984 scanned S:\big itunes\216\Hey Hey
10:43:23:984 scanned S:\big itunes\216
10:43:24:000 scanned S:\big itunes\B.G\Evil Empire-Be South 14
10:43:24:015 scanned S:\big itunes\B.G\Unknown Album
10:43:24:015 scanned S:\big itunes\B.G
10:43:24:031 scanned S:\big itunes\ATL\Unknown Album
10:43:24:031 scanned S:\big itunes\ATL



please help...thanks

ktjensen
Posts: 11
Joined: Mon Jun 02, 2008 4:13 pm
AV Hardware: Sprint Mogul running Windows Mogul 6; and the uPnP client software LOBSTER.

Re: ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

Post by ktjensen » Thu Jun 12, 2008 11:08 pm

Try the twonky 5.0.1 beta server, as I did not realize but I am using that. Also I NEVER have my playlists or my music showing on any of the CONFIGURATION pages for the server. The CONFIGURATION pages just show the settings for directory locations and for what needs to be selected for getting the server application to work the way you want.

The internet/intranet page for the uPnP client has to be setup and running on the server NETWORK page. I would suggest turning off all security until you are certain that uPnP is routing around your LAN.

What is the specific address that you are using to display your SONGS? The config page is "http://192.168.0.X:9000/config" but what are you using?

The config page has MUSIC TREE, and PHOTO TREE, etc. so I have no idea what you are seeing.

I admit as a user (no affiliation) that it does take some fine tuning to get it all running well, but it does work well.

elliotte08
Posts: 5
Joined: Fri Jun 06, 2008 8:29 pm
AV Hardware: d-link 520 , twonkymedia

Re: ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

Post by elliotte08 » Sat Jun 14, 2008 1:19 am

:) First of all I want to say thanks for replying. I have had my twonky set up the same way since I first 4.4.1. There has to be another issue. My dlink-520 is on my network and i can view all my movies and picutres and all the songs but not my specific itunes playlist

Since i have upgraded to 4.4.2-higher this has been a problem with scanning my itunes library. I just upgraded to 5.0.1 beta and the problem still presist. The main reason I bought twonky was because of the itunes intergration. I really need help to understand what changed from it working fine in 4.4.1 to Sometimes working on higher versions


1) is there a different way we need to config the library?
2) I have my folder pointing to the specific folder where my music lies ...itunes and other music folders?

I have always set up my twonky the same way.....If someone can walk me through how the "NEW" setup or what i need to make sure so that my ITUNES PLAYLIST show PLEASE LET ME KNOW

Thanks a bunch any help is accpeted

JakiChan
Posts: 2
Joined: Fri Jun 20, 2008 9:52 am
AV Hardware: Denon AVR-3808CI, PS3, Xbox 360, Powermac G4

Re: ITUNES PLAYLIST PROBLEMS w/ 4.4.5 twonkymedia

Post by JakiChan » Fri Jun 20, 2008 9:59 am

I am seeing the same problem. No iTunes playlists.

LOG_SYSTEM:parm: [/Users/john/Music/iTunes/iTunes Music Library.xml]
LOG_SYSTEM:parm: [/Applications/Mediaserver.app/MediaServer/twonkymedia.db]
LOG_SYSTEM:call plugin: [/Applications/Mediaserver.app/MediaServer/plugins/itunes-import] ["/Users/john/Music/iTunes/iTunes Music Library.xml" "/Applications/Mediaserver.app/MediaServer/twonkymedia.db" ""]
LOG_DB:adding file /Applications/Mediaserver.app/MediaServer/twonkymedia.db/itunes.import.items!

And there are files there showing the iTunes DB (and playlists), but they don't show up when I browse. Latest version of Twonky, MacOS 10.4.11, latest iTunes.

I'm trying Twonky because MediaLink won't send FLAC to my Denon 3808, but if I have to choose between FLAC support and iTunes playlists I'll take iTunes playlists...


EDIT: Never mind...I guess it was just slow. They show up now.

Locked