TwonkyVision 4.4 and WMP11 "Album Artist"

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
cuteboy911
Posts: 1
Joined: Tue Jun 17, 2008 10:38 am
AV Hardware: QNAP TS 109 II with Twonky 4.4
WMP 11 on XP SP3 and Vista Home Premium

TwonkyVision 4.4 and WMP11 "Album Artist"

Post by cuteboy911 » Tue Jun 17, 2008 10:58 am

Hi All,

I have a rather annoying problem when using TwonkyVision 4.4 serving WMP11 running on Vista Home Premium Edition. My music collection was originally created using WMP10 and WMP11. TwonkyVision 4.4 seems to be mapping "Contributing Artist" to "Album Artist". The result is that under WMP11 any compilation album, with multiple "Contributing Artist"s are split up.

For example all 16 tracks in the Album "Trance Nation Anthems Disc 1" have the same value:

Album Artist = "Various Artist"

but have completely different "Contributing Artist" values. If I read the track mp3 files directly into WMP11 they are all allocated to the same Album. If I stream using TwonkyVision 4.4 the Album is split into 16 different entries, with the "Contributing Artist" being listed as "Album Artist"! As most my collection is made up of compilation CDs, this is very annoying! I've tried editing the Music Tree, but to no avail. It seems that WMP11 uses the Album concatenated with Album Artist to make up unique Album entries.


Any ideas? Thanks in advance.
AMG

Bappe
Posts: 4
Joined: Mon Jun 23, 2008 7:44 pm
AV Hardware: HP Media Smart Server

Re: TwonkyVision 4.4 and WMP11 "Album Artist"

Post by Bappe » Mon Jun 23, 2008 7:59 pm

Bump!

This is a real issue, WMP11 sorts albums on their "album artist" and even if its the same (i.e various artists) PVConnect will not transfer that information via UPNP and it will end up with "unknown" and sort on the artist instead.

Because of this I have loads of "Full metal jacket" and other collections in my albums-view

Please respond!

Bappe
Posts: 4
Joined: Mon Jun 23, 2008 7:44 pm
AV Hardware: HP Media Smart Server

Re: TwonkyVision 4.4 and WMP11 "Album Artist"

Post by Bappe » Mon Jun 30, 2008 9:11 pm

After some investigation it seems that PVConnect only sends one artist-node in the soap response and that node doesn't use a role attribute. According to the DLNA-standard several nodes can be used and they can be separated by the role attribute.

Example
<artist>Abagail mead</artist>
<artist role="AlbumArtist">Various artist</artist>

Does this sound resonable? Please respond I have tried reinstalling, logging, tracing and even running Intels DLNA-tools for validation.

jop
Posts: 2
Joined: Sun Jul 13, 2008 4:34 pm
AV Hardware: QNAP TS101 with Twonky 4.4.2 Server, Noxon2 Client, WMP11 on Vista Client

Re: TwonkyVision 4.4 and WMP11 "Album Artist"

Post by jop » Sun Jul 13, 2008 4:47 pm

I have the same problem. My Music library (only MP3) was created with WMP11, Twonky served it so far correctly to a Noxon2 client.
Now I tried to access the same library with a WMP11 (Vista) client:

- All "Artist" tags are shown as "unknown"
- Most albums are split into multiple Album entries for every track

I noticed: Not all albums are affected. A few are displayed in WMP client as a single Album entry (but still with individual artist "unknown", only album artist is shown).
I tried to compare the MP3 tags of Albums which are splitted with those who are together: But I could not find any differences. Same tags are set, incl. TPE2 tag.
I tried to de-activate the Twonky compilation function - No change.

I give up now. Any help is appreciated.

Ytterbium
Posts: 1
Joined: Wed Jul 16, 2008 8:32 pm
AV Hardware: QNAP TS-409, XBox360, Vista PC

Re: TwonkyVision 4.4 and WMP11 "Album Artist"

Post by Ytterbium » Sat Jul 19, 2008 4:51 pm

I have this problem as well and if anyone finds a fix it would be great, the funny thing is it seem to work fine on my Xbox360 so maybe it's a WMP11 bug?

jop
Posts: 2
Joined: Sun Jul 13, 2008 4:34 pm
AV Hardware: QNAP TS101 with Twonky 4.4.2 Server, Noxon2 Client, WMP11 on Vista Client

Re: TwonkyVision 4.4 and WMP11 "Album Artist"

Post by jop » Sun Jul 20, 2008 1:10 pm

I just updated Twonky to Version 4.4.5 - No change - same error as described above.

Still the same result: My Noxon2 Client displays the structures correctly, only WMP11 on Vista is having the problem.

Any support is appreciated.

mbuzina
Posts: 2
Joined: Fri Oct 23, 2009 4:12 pm
AV Hardware: Buffalo LiveStation LS-CHL 1 TB
Windows Media Player 12
Windows Media Player 11

Re: TwonkyVision 4.4 and WMP11 "Album Artist"

Post by mbuzina » Fri Oct 23, 2009 4:36 pm

Bump!

It seems still an issue. 4.4.8 and WMP 12 provide the same. See my other post http://www.twonkyforum.com/viewtopic.php?f=2&t=6916, it seems 5.1 still has the issue!!! :( :( :(

Locked