no internetradio!

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
muhadib
Posts: 2
Joined: Mon Sep 15, 2008 10:36 am
AV Hardware: terratec noxon,
TwonkyVision UPnP AV Media Server
linksys wtrg 54

no internetradio!

Post by muhadib » Mon Sep 15, 2008 10:42 am

Hi there

I run the server on a xp os. the client is a terratec noxon audio. I am be able to hear all music locatet on the xp os via the noxon, but no internet radio anymore! on the configuation page I activate the shoutcast button and some genres but theres no internet radiostation on the noxon and also no station via web access on the same xp os.
so may you help me with troubleshooting?

tokon
Posts: 5
Joined: Mon Sep 15, 2008 5:06 pm
AV Hardware: LOEWE Connect

Re: no internetradio!

Post by tokon » Mon Sep 15, 2008 5:10 pm

I have the same problem since Saturday. Last week it worked fine. Tested with 4.4.4+4.4.7

k1200rs
Posts: 340
Joined: Wed Jul 27, 2005 9:24 pm
AV Hardware: Does no longer attend this forum.
Location: Somewhere in the French Alps

Re: no internetradio!

Post by k1200rs » Mon Sep 15, 2008 5:16 pm

It is not just Twonkymedia that is impacted but all media players, Shoutcast has apparently changed its API (they have done that couple of times in the past).
That's the reason why I am not going through Shoutcast anymore, I have UPNP devices that support direct radio streaming or vTuner (example: NP1100 or MusicPal).

See also: http://forum.freecompromo.com/viewtopic ... 8295#18295

muhadib
Posts: 2
Joined: Mon Sep 15, 2008 10:36 am
AV Hardware: terratec noxon,
TwonkyVision UPnP AV Media Server
linksys wtrg 54

Re: no internetradio!

Post by muhadib » Tue Sep 16, 2008 7:24 am

Thanx for answering.
So what would be a good alternativ? vtuner? I don't get it work yet. and am i possible to use another stream than shoutcast? If yes, how? I am not a specialist in these things...

greetz

Muhadib

tokon
Posts: 5
Joined: Mon Sep 15, 2008 5:06 pm
AV Hardware: LOEWE Connect

Re: no internetradio!

Post by tokon » Tue Sep 16, 2008 9:53 am

My workaround is to create a playlist with my favorite stations:

playlist.m3u

Code: Select all

#EXTM3U
#EXTINF:-1,Technobase.FM
http://www.shoutcast.com/sbin/shoutcast-playlist.pls?rn=524&file=filename.pls
#EXTINF:-1,Trancebase.FM
http://www.shoutcast.com/sbin/shoutcast-playlist.pls?rn=795816&file=filename.pls
#EXTINF:-1,Housetime.FM
http://www.shoutcast.com/sbin/shoutcast-playlist.pls?rn=8666&file=filename.pls
#EXTINF:-1,Hardbase.FM
http://www.shoutcast.com/sbin/shoutcast-playlist.pls?rn=5856&file=filename.pls


User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: no internetradio!

Post by Briain » Wed Sep 17, 2008 2:42 pm

Hi

I too am unable to find anything using the Twonky web interface; internet radio does still work fine on my SqueezeCentre (Logitech Duet) though. I wonder if this is a minor or major problem? I suppose that if it has impacted on all Twonky users (and indeed many other media players), it will be picked up quickly and thus solutions will hopefully be found quite swiftly too.

Incidentally, I tried creating a playlist from the above and it displays OK, but I can't get it to play anything using my UPnP control point (a web tablet with Linn GUI).

Bri

Highlander
Posts: 3
Joined: Wed Sep 17, 2008 5:40 pm
AV Hardware: ReadyNAS NV+ (4TB)
Linn Akurate DS

Re: no internetradio!

Post by Highlander » Wed Sep 17, 2008 5:44 pm

When will the new Shoutcast API be supported, please?

Chris

Cindercone
Posts: 1
Joined: Sun Sep 21, 2008 10:18 pm
AV Hardware: Squeezebox

Re: no internetradio!

Post by Cindercone » Sun Sep 21, 2008 10:38 pm

This can be fixed by patching the shoutcast-import file in the plugins directory.

Using a hex editor
1) replace the first occurence of http://www.shoutcast.com with http://207.200.98.25[nul][nul][nul][nul]

2) replace the occurence of http://www.shoutcast.com/directory/inde ... mresult=50 with http://207.200.98.25/directory/index.ph ... ][nul][nul]

[nul] is the character 0x00

Save the file in place of the original (should probably backup the original first), and rebuild the database

This forces the plugin to use http://classic.shoutcast.com to perform its shoutcast lookup, which is where the previous format shoutcast site now resides. Hopefully Twonky will release an updated plugin to support this change in the near future

talorin
Posts: 2
Joined: Mon Sep 22, 2008 2:51 pm
AV Hardware: NSLU2

Re: no internetradio!

Post by talorin » Mon Sep 22, 2008 2:56 pm

Can you upload the file?

tokon
Posts: 5
Joined: Mon Sep 15, 2008 5:06 pm
AV Hardware: LOEWE Connect

Re: no internetradio!

Post by tokon » Mon Sep 22, 2008 6:55 pm

talorin wrote:Can you upload the file?
http://www.file-upload.net/download-112 ... t.exe.html

talorin
Posts: 2
Joined: Mon Sep 22, 2008 2:51 pm
AV Hardware: NSLU2

Re: no internetradio!

Post by talorin » Tue Sep 23, 2008 7:41 am

Thanks, but it's for windows.

I need it for my NAS with Linux.

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: no internetradio!

Post by Briain » Wed Sep 24, 2008 1:48 pm

Me too; I'm happy with a hex editor but don't want to access my NAS root as it will invalidate the warranty; is anone working on a NAS patch or add-on (in my case for a Netgear ReadyNAS)?
Bri

maxxartemis
Posts: 1
Joined: Tue Sep 23, 2008 8:03 pm
AV Hardware: Linksys NSLU2
D-Link DSM-520
Roku SoundBridge M1001

Re: no internetradio!

Post by maxxartemis » Wed Sep 24, 2008 6:30 pm

talorin wrote:
I need it for my NAS with Linux.
For Linksys NSLU2:

http://www.file-upload.net/download-113 ... mport.html

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: no internetradio!

Post by Briain » Wed Sep 24, 2008 11:45 pm

Hi
Had a look to see what was there but the download link is currently broken
Bri

weich
Posts: 7
Joined: Tue Sep 05, 2006 7:36 am
Location: Germany

Re: no internetradio!

Post by weich » Thu Sep 25, 2008 6:59 am


alanrab
Posts: 61
Joined: Sun Sep 24, 2006 11:22 pm

Re: no internetradio!

Post by alanrab » Fri Sep 26, 2008 2:36 am

Thank you Cindercone and tokon. I downloaded the plug-in for my 4.4.7 on a Vista PC. My Internet Radio now works perfectly again. Would anyone happen to know if or how I could edit the list of radio stations which appears under each genre?

turls
Posts: 16
Joined: Tue Sep 12, 2006 8:00 pm

Re: no internetradio!

Post by turls » Wed Oct 01, 2008 2:47 pm

So what about ReadyNAS users?? For that matter where is the official response to this? To me you can't get any more basic than this on support for a paid product. At least make sure the stuff that is broken by 3rd parties is responded to in a timely manner?

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: no internetradio!

Post by Briain » Thu Oct 02, 2008 2:44 pm

Hi

As Turls asks in the post above this one, can anyone pass any comment on whether anything's being done for ReadyNAS users? It would be useful to at least know whether it's even being looked at or not!

Bri

turls
Posts: 16
Joined: Tue Sep 12, 2006 8:00 pm

Re: no internetradio!

Post by turls » Fri Oct 03, 2008 8:45 pm


flexi
Posts: 1
Joined: Wed Nov 05, 2008 8:22 pm
AV Hardware: TeraStation Live

Re: no internetradio!

Post by flexi » Thu Nov 06, 2008 10:12 am

Why do you edit an executable?
Just enter this line to your "host" file.
207.200.98.25 www.shoutcast.com

This file is intended for that kind of redirection.
Works perfectly in Windows and Unix without any need to patch the shoutcast_plugin.

JamboUK
Posts: 5
Joined: Fri Dec 15, 2006 8:52 pm

Re: no internetradio!

Post by JamboUK » Mon Nov 10, 2008 8:20 pm

Anyone got a fix for no radio stations for a Freecom FSG3?? NAS.

Your help greatly appreciated.

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: no internetradio!

Post by Briain » Tue Nov 11, 2008 9:24 am

flexi wrote:Why do you edit an executable?
Just enter this line to your "host" file.
207.200.98.25 http://www.shoutcast.com

This file is intended for that kind of redirection.
Works perfectly in Windows and Unix without any need to patch the shoutcast_plugin.
Hi
I've reverted to Twonky 4.4.6 as it performs better than 4.4.9; the playlist's work and somewhat oddly, I've also found that album art is better handled by 4.4.6 (I'm using Folder.jpg's located within FLAC directories). I used Vi to add the above redirection line to the hosts file on my ReadyNAS NV+ but nothing doing; still no catagories nor stations listed. Anyone have any ideas why it wouldn't work? I've probably done, or maybe not done something really obvious, but the line is definitely there and is exactly as above.
Bri

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: no internetradio!

Post by Briain » Tue Nov 11, 2008 11:55 am

Hi

I've discovered what might be causing me the problem. I editid the hosts file and rebooted the NAS. I see that when you reboot the NAS, it builds a new hosts file with the original entries (i.e. without the shoutcast line). I've tried adding the line to the hosts file and rebuilt the TM database (without first rebooting the NAS) but that didn't work either so I've just sorted by installung 4.4.9, copying the shoutcast file, removing it and installing 4.4.6, then using the 4.4.9 shoutcast file; radio is back on 4.4.6

Shame about the most of the stations being a load of c**p though :)

Bri

adambrower
Posts: 3
Joined: Sun Sep 14, 2008 6:46 am
AV Hardware: denon 4308ci

Re: no internetradio!

Post by adambrower » Thu Nov 27, 2008 6:03 am

Cindercone wrote:This can be fixed by patching the shoutcast-import file in the plugins directory.

Using a hex editor
1) replace the first occurence of http://www.shoutcast.com with http://207.200.98.25[nul][nul][nul][nul]

2) replace the occurence of http://www.shoutcast.com/directory/inde ... mresult=50 with http://207.200.98.25/directory/index.ph ... ][nul][nul]
thanks a million Ccone, it works a treat. a possible correction, though: there are two occurrences of the second string, and the hack failed until i replaced both. now i just hope they don't deprecate the "legacy" site :/

adam

--

internet-radio
Posts: 1
Joined: Thu Sep 17, 2009 12:00 pm
AV Hardware: AV hardware
Location: USA
Contact:

Re: no internetradio!

Post by internet-radio » Thu Sep 17, 2009 12:06 pm

you can contact hkgfm.net for all your problems related to internet radio
Online Radio Stream - Listen to latest hits online music.

Post Reply