Problems with Directories

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
mdntblu
Posts: 4
Joined: Mon Feb 09, 2009 10:42 pm
AV Hardware: xbox 360, Linksys Wireless-B Music System WMLS11B

Problems with Directories

Post by mdntblu » Mon Feb 09, 2009 10:56 pm

I have a Buffalo Linkstation LS-CHL and it has bulit-in TwonkyMedia server loaded.

I have 2 devices I use to access the media. One is the Linksys Wireless-B Music System WMLS11B and the other is an xbox360.

My biggest problem is the directory structure. It's too confusing.

I have a folder on my hard drive called media and in that folder I have music and video. In the video I have Children's and Movies.

But on my xbox360 to get to those folders is a lot of steps and I'm pretty sure there is a way to do it I just can't figure it out.

Here are the screens as follows:
First screen is fine. It just asks me which server to connect to.
Image

Then the second screen shows "All Videos" which it's almost impossible to find anything in there and then "Folder" which at this point I would love it if there was only 2 options -- Children's & Movies. When I click on Folder it takes me to the next screen.
Image

Then the third screen shows "All" again, "Music" and "Video".
Image

Then the fourth screen if I click on Video will finally show me "Children's" and "Movies".
Image

Is there anyway to fix this?

The other problem is on my Linksys Wireless-B Music System WMLS11B I can't figure out how to make it the default server and also can't figure out where to put playlists so I can pull them up on the device.

Thanks
Brad

mdntblu
Posts: 4
Joined: Mon Feb 09, 2009 10:42 pm
AV Hardware: xbox 360, Linksys Wireless-B Music System WMLS11B

Re: Problems with Directories

Post by mdntblu » Sat Feb 21, 2009 8:10 am

No one knows how to fix this problem? Or is it not fixable?

bripab007
Posts: 9
Joined: Mon Feb 16, 2009 4:05 pm
AV Hardware: DNS-323
Xbox 360
Xbox (XBMC)
Mac Mini (XBMC, Plex and Boxee)

Re: Problems with Directories

Post by bripab007 » Sat Feb 21, 2009 4:07 pm

Yes, you need to configure Twonky so that it looks for videos and broadcasts videos from a folder on the Linkstation that has only videos, and the same goes for music and photos.

In other words, if you have videos and music mixed together in a single folder on the Linkstation, then you will have a fundamental problem with UPnP sharing.

I've posted a shot of how my Twonky is configured. On my NAS (network attached storage), I have a Media folder in the root with subfolders each for Music, Videos and Pictures. And I have Twonky configured to look at each of these three directories and broadcast the homogeneous items in each.

With your videos folder, specifically, it sounds like you might need to just create more subfolders to make your own navigation easier, just as you might use a bookcase to organize and arrange books of varying content on different shelves (e.g. \\videos\childrens\sesame street\, \\videos\movies\, \\videos\tv shows\how it's made\, etc.)
Attachments
twonkydirectories.jpg
twonkydirectories.jpg (21.46 KiB) Viewed 4544 times

mdntblu
Posts: 4
Joined: Mon Feb 09, 2009 10:42 pm
AV Hardware: xbox 360, Linksys Wireless-B Music System WMLS11B

Re: Problems with Directories

Post by mdntblu » Sun Feb 22, 2009 2:56 am

I have all my videos organized as you stated. I have a videos folder and inside that is Children's and Movies, and inside Childrens is TV Shows and Movies, and inside TV Shows is dora the explorer, sonic the hedgehog, etc. and inside each of those folders is all the AVI files.

And it still always shows Folder at the beginning after I click my mediaserver on my xbox.

bripab007
Posts: 9
Joined: Mon Feb 16, 2009 4:05 pm
AV Hardware: DNS-323
Xbox 360
Xbox (XBMC)
Mac Mini (XBMC, Plex and Boxee)

Re: Problems with Directories

Post by bripab007 » Sun Feb 22, 2009 5:49 am

mdntblu wrote:I have all my videos organized as you stated. I have a videos folder and inside that is Children's and Movies, and inside Childrens is TV Shows and Movies, and inside TV Shows is dora the explorer, sonic the hedgehog, etc. and inside each of those folders is all the AVI files.
Then why, at your "third screen," does it show?:
-All Folder-
Music
Videos

It sounds like you've got something configured funkily in Twonky if, on the Xbox 360, you're seeing both music and videos in the video library section of the 360.
And it still always shows Folder at the beginning after I click my mediaserver on my xbox.
This part I don't understand. If you've not configured Twonky to use any extra nodes in the video tree, then Folder is the default. Going into Folder should then show you the folder structure you described to me in your previous post, that is to say, the physical folder structure that you created on the hard drive in the NAS. So what's the problem exactly?

mdntblu
Posts: 4
Joined: Mon Feb 09, 2009 10:42 pm
AV Hardware: xbox 360, Linksys Wireless-B Music System WMLS11B

Re: Problems with Directories

Post by mdntblu » Sun Feb 22, 2009 6:03 am

Well I have in my Buffalo NAS it asks me which directory I want to be shared or whatever and I select Media and in the Media folder I have Music and Video. Then when I go to the 9050 port of my mediaserver it takes me directly to the Twonky media setup.

I don't have the same setup as you have.

Image


So are you saying I should move my music to a different place and just have a Video folder and then a Music folder separate instead of having a Media folder with "Music" and "Video" inside there?

Can't I just tell twonky that my videos are in the video folder instead of the media folder? I think that's my problem. But I don't know how to specify that.

Ok I changed my settings like you said and then my Linksys Music player didn't see the music anymore because it only saw videos. This is so frustrating. I guess I'll just have to live with it.

bripab007
Posts: 9
Joined: Mon Feb 16, 2009 4:05 pm
AV Hardware: DNS-323
Xbox 360
Xbox (XBMC)
Mac Mini (XBMC, Plex and Boxee)

Re: Problems with Directories

Post by bripab007 » Sun Feb 22, 2009 3:42 pm

Yes, that's precisely what I'm saying. In the Twonky config, go to Sharing under Basic setup, and here, define your videos directory on the NAS as "Video-only" in the drop-down tab. Then define another media location for your music folder as "Music-only." You must have defined the top, parent folder for your media as having "All content types" in that basic setup section, and that's your problem.

Now, as far as the screenshot you posted, that's the Video Tree configuration tab, and with videos, there's not really a great way to display them via Twonky's UPnP nodes, except by Folder. You just have to name your folders logically on the NAS, and you'll be fine. And it sounds like you have: \\videos\childrens\sonic, etc.

Locked