EX487 and twonkymedia-server-default.ini

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
BeXenSol
Posts: 4
Joined: Sat May 16, 2009 4:07 am
AV Hardware: PC :)

EX487 and twonkymedia-server-default.ini

Post by BeXenSol » Sat May 16, 2009 5:24 am

I am looking to change the directory of where Twonky looks for it's music to build its database. I thought the C:\TwonkyMedia\twonkymedia-server-default.ini file on the HP server would be the logical place to change the directory, but it seems not to work.

Here are the steps I've taken:

1. Stop the Twonky server via the Windows Home Server Console.
2. Remote desktop into the HP Home Server.
3. Open up C:\TwonkyMedia\twonkymedia-server-default.ini file on the HP Home Server.
4. Change the line:
contentdir=+M|D:\shares\Music,+A|D:\shares\Photos,+V|D:\shares\Videos

To:
contentdir=+M|D:\shares\Public\muzak,+A|D:\shares\Photos,+V|D:\shares\Videos

D:\shares\Public\muzak being where I have the music I want Twonky to pick up.

5. Save C:\TwonkyMedia\twonkymedia-server-default.ini.
6. Rebuild the Twonky database via the Windows Home Server Console.
7. Restart the Twony server via the Windows Home Server Console.

There is no change to the number of music files that Twonky finds (just the 1 mp3 I have for testing in D:\shares\Music).

I feel I am probably either changing the wrong .ini file, or doing something else incorrectly. I cannot find any other .ini files under the C:\TwonkyMedia dir that would suggest they need to be tweaked.

Additionally, when I go to http://server:9000/config while Remote Desktopped in, I basically get the Twonky logo, and a bunch of not much else, text wise.

Something doesn't feel right...!

BeXenSol
Posts: 4
Joined: Sat May 16, 2009 4:07 am
AV Hardware: PC :)

Re: EX487 and twonkymedia-server-default.ini

Post by BeXenSol » Thu May 28, 2009 8:20 pm

Maybe I need to ask the question in a different way?

I have the EX487 and I wish for Twonky to use an alternative directory on the Home Server to populate its database of tracks.

How do I change the directory that Twonky refers to to build its database on the EX487?

Thank you.

RG1
Posts: 73
Joined: Sat May 02, 2009 1:42 am
AV Hardware: Philips Streamium WAC 7500
Philips Streamium WAS 7500
Philips Streamium WAC 6050
Philips Streamium NP 2900

Re: EX487 and twonkymedia-server-default.ini

Post by RG1 » Fri May 29, 2009 12:12 am

Hi,
the correct .ini-file is twonkymedia-server.ini located at c:\documents and setting\All Users\aplication data\TwonkyMedia. What do you get if you try http://server:9000 without /config and not using remote desktop?

BeXenSol
Posts: 4
Joined: Sat May 16, 2009 4:07 am
AV Hardware: PC :)

Re: EX487 and twonkymedia-server-default.ini

Post by BeXenSol » Sat May 30, 2009 7:43 pm

RG1 wrote:Hi,
the correct .ini-file is twonkymedia-server.ini located at c:\documents and setting\All Users\aplication data\TwonkyMedia. What do you get if you try http://server:9000 without /config and not using remote desktop?
Issue resolved! Thank you! I've now managed to change the music directory, and Twonky is now letting me access all my music in the different dir.

I still have the issue while remote desktoped in to the EX487, when I use the browser to configure Twonky, I get the following screen:

Attachments
Twonky.jpg
Screenshot of Twonky Browser Config
Twonky.jpg (67.54 KiB) Viewed 4271 times

RG1
Posts: 73
Joined: Sat May 02, 2009 1:42 am
AV Hardware: Philips Streamium WAC 7500
Philips Streamium WAS 7500
Philips Streamium WAC 6050
Philips Streamium NP 2900

Re: EX487 and twonkymedia-server-default.ini

Post by RG1 » Sun May 31, 2009 12:47 am

Hi,
looks like java script is blocked/not activ in your browser. Might be that the security level in your browser is set on "high". Try to set the level "middle high" in internet options - security to make shure java script is enabled.

BeXenSol
Posts: 4
Joined: Sat May 16, 2009 4:07 am
AV Hardware: PC :)

Re: EX487 and twonkymedia-server-default.ini

Post by BeXenSol » Sun May 31, 2009 3:08 am

RG1 wrote:Hi,
looks like java script is blocked/not activ in your browser. Might be that the security level in your browser is set on "high". Try to set the level "middle high" in internet options - security to make shure java script is enabled.
There we go! Thanks again! I think that solves all my current Twonky related issues for now. :)

Post Reply