Status of TwonkyMedia Server on various NAS

General discussion about the media server. Feature requests. Hints, tips and tricks.
Post Reply
john.glasson
Posts: 71
Joined: Sun Aug 03, 2008 9:29 am
AV Hardware: Server: Western Digital My Book World Edition White Light
Clients: Zyxel DMA1000, Philips Streamium 1100, Netgear MP101, Pocket Player on WM5 PDA
Location: near London, UK

Status of TwonkyMedia Server on various NAS

Post by john.glasson » Wed Nov 18, 2009 1:13 pm

It might be useful for forum members if our experience in installing the various TwonkyMedia Server releases on different NAS servers was documented. I envisage this as being in the form of a simple table which lists the main NAS and shows whether the main Twonky releases are known to install and run ok or not. It might save a good deal of wasted time trying to install a version which is known not to run.

I would be happy to edit such a document, if members are willing to send me their experiences with their NAS. Since I don't have access to any web space on this forum, I've set up a web page on a free server at:

http://www.glasson.hostecs.net


If you think that this feature would be useful, do please send me information. To keep matters simple, I suggest that each entry is confined to Yes, No, MS (Manufacturer Supported) and SP (runs, but with some problems). Problems should be specific to this NAS, not generic problems with the release. MS refers to NAS such as QNAP's where TwonkyMedia Server is supported by them, not PV.

John Glasson
Last edited by john.glasson on Wed Nov 18, 2009 6:32 pm, edited 2 times in total.

san
Posts: 65
Joined: Fri Sep 25, 2009 1:57 pm
AV Hardware: WD My Worldbook (WhiteLight Edition)
Location: Center Italy

Re: Status of TwonkyMedia Server of various NAS

Post by san » Wed Nov 18, 2009 2:05 pm

Hi John
if possible I suggest you to add this two nas

WD My Worldbook Blue Ring Edition (Linux ARM little endian uclibc 0.9.28 )
WD My Worldbook White Lite Edition (Maxtor Shared Storage 2)

so also Western Digital nas users can support this feedback
Sante

PeeBee
Posts: 392
Joined: Sat Jun 13, 2009 12:16 pm
AV Hardware: Buffalo LS Pro; PS3; Samsung LE37B650

Re: Status of TwonkyMedia Server on various NAS

Post by PeeBee » Wed Nov 18, 2009 9:08 pm

Hi John

Here are the results for my Buffalo LS Pro (v2):

(4.4.6 - yes)
(4.4.9 and 4.4.11 - no)
4.4.17 - no
4.4.18 - yes
5.0.68 - no (LS Live owners can get this version running by keeping PCast alive on their NAS but LS Pro owners don't have this option)
5.1.1 RC2 - not tried (other users have reported this as a no but 5.1 Beta versions were sp)

Good idea, BTW.

What about adding extra info such as alink to where install instructions can be found?

Thanks

PB
Samsung LE37B650T2WXXU; Liteon 5055GDL+ HDD/DVD Recorder; Playstation 3; Iomega Screenplay HD 500GB; Buffalo Linkstation Pro LS-320GL (running Twonky 6.0.30, SqueezeBox Server 7.6 and acting as a Print Server)

san
Posts: 65
Joined: Fri Sep 25, 2009 1:57 pm
AV Hardware: WD My Worldbook (WhiteLight Edition)
Location: Center Italy

Re: Status of TwonkyMedia Server on various NAS

Post by san » Wed Nov 18, 2009 10:36 pm

Thanks John

Here are the results for My Worldbook White Lite Edition (Maxtor Shared Storage 2)

(4.4.9 - ms)
4.4.17 - ms
4.4.18 - ms
5.0.68 - sp (problems to build correctly the media database, sometime freeze, lost functionality on media player from 4.4.18)
5.1 - sp (same issue founded in 5.0.68)
5.1.1 RC2 - sp (same issue founded in 5.0.68)
(5.1.1 RC3) - yes (performance really improved from 4.4.18)

Sante

JokerZero
Posts: 1
Joined: Thu Dec 03, 2009 11:22 am
AV Hardware: PS3, 360, WII, PC *3,DSI, currently Tversity - thinking of moving to twonkey.

Re: Status of TwonkyMedia Server on various NAS

Post by JokerZero » Thu Dec 03, 2009 11:27 am

Jon,
Can I just say as someone about to buy thier first NAS and considering a shift to Twonkey from the other one

THANKS! :D

I really appreciate finding this kind of thread on a forum - thanks and well done.

Trev

john.glasson
Posts: 71
Joined: Sun Aug 03, 2008 9:29 am
AV Hardware: Server: Western Digital My Book World Edition White Light
Clients: Zyxel DMA1000, Philips Streamium 1100, Netgear MP101, Pocket Player on WM5 PDA
Location: near London, UK

Re: Status of TwonkyMedia Server on various NAS

Post by john.glasson » Sun Dec 06, 2009 5:25 pm

More feedback needed, please. For example, would be good to know whether the special version for Synology PPC, as released in 5.1.1 RC3 is working ok?

John Glasson

joergnapp
Posts: 16
Joined: Mon Nov 30, 2009 8:44 am
AV Hardware: NSLU2
Soundbridge Home
IPdio mini pro

Re: Status of TwonkyMedia Server on various NAS

Post by joergnapp » Thu Dec 10, 2009 11:40 am

NSLU:
4.4.18: works like a charm
5.0.68: Ressource hogs with alternate navigation trees, no playlists are picked up, scanning the mp3 files takes a very long time --> unusable
5.1.1: Requires libstdc++.so.6, which isn't available via uNSLUng, so it's unusable

foxesden
Posts: 5
Joined: Fri Nov 27, 2009 1:05 am
AV Hardware: linkstation live
roberts w201
roku soundbridge m1000
xbox 360

Re: Status of TwonkyMedia Server on various NAS

Post by foxesden » Tue Dec 15, 2009 9:24 pm

Linkstation Live
I have been using the linkstation pro installs as they seem more reliable

4.4.18 - Stable and fast. No transcoding
5.0.68 - scanning problems couldn't see music
5.1.1 - tried all the release candidates, final release is working intitial scan takes ages. I have got transcoding working for flac to wav, but had to hack about quite a lot to get this going.

PeeBee
Posts: 392
Joined: Sat Jun 13, 2009 12:16 pm
AV Hardware: Buffalo LS Pro; PS3; Samsung LE37B650

Re: Status of TwonkyMedia Server on various NAS

Post by PeeBee » Tue Dec 15, 2009 9:52 pm

foxesden wrote:Linkstation Live
I have been using the linkstation pro installs as they seem more reliable
Could you please post which version of LS Live; HS-DHGL or the newer LS-CHL?

Thanks

PB
Samsung LE37B650T2WXXU; Liteon 5055GDL+ HDD/DVD Recorder; Playstation 3; Iomega Screenplay HD 500GB; Buffalo Linkstation Pro LS-320GL (running Twonky 6.0.30, SqueezeBox Server 7.6 and acting as a Print Server)

Georg
Posts: 105
Joined: Sat Feb 17, 2007 11:13 pm
AV Hardware: Server: Linkstation Pro (production) with Twonky 6.0.1 +
Linkstation Pro (developer) with Twonky 6.0.23
Clients:
Kathrein UFS 822 (pvr sat receiver, upnp-client?)
Philips TV PFL9604
WD TV Live
Roku Linkstation
Philips WLAN photo frame

Re: Status of TwonkyMedia Server on various NAS

Post by Georg » Tue Dec 15, 2009 11:36 pm

My status for the Buffalo Linkstation Pro (LS-GL):
4.4.6, 4.4.18 fully working
5.0.x no
5.1.1-RC3, 5.1.1 "fully working", though I had *occasional* problems like a movie that stopped in the middle, then TMS was visible, but without any nodes (music, photo, video). Sometimes the entries in the "receivers list" are duplicated, then my TV usually doesn't see the TMS anymore. Might be connected to the first problem.

--> 5.1.1 is made a huge step in the right direction, but for a really stable environment without surprises I stick with 4.4.18.

Garry
Posts: 4
Joined: Tue Dec 15, 2009 12:28 am
AV Hardware: WL-HDD 2.5 and XBOX 360

Re: Status of TwonkyMedia Server on various NAS

Post by Garry » Thu Dec 17, 2009 11:42 am

ASUS WL-HDD 2.5

4.4.18: Works perfectly. Required a small change to the install.nas file, as user guides for installing Oleg's firmware on the WLHDD tend to recommend mounting the harddrive on /opt rather than the /tmp/harddisk that the Twonky install script looks for.

5.1.1: Initially problematic. Requires the same adjustment as above. In addition, the default configuration puts settings and the database on /var/twonkymedia. This is a temporary folder on the internal flash that is limited in space and that gets deleted upon reboot.
I solved this by creating a symbolic link to a folder on the harddrive, which I namesd /var/twonkymedia. I've set this link to be created in the post-boot script.
Also, my media is located in /opt/share. Setting the content base as /opt or /opt/share results in all media folders being black-listed. This means that no media is scanned. Again, a symbolic link to this folder created at boot, and entered as the contentbase parameter will solve this issue.

john.glasson
Posts: 71
Joined: Sun Aug 03, 2008 9:29 am
AV Hardware: Server: Western Digital My Book World Edition White Light
Clients: Zyxel DMA1000, Philips Streamium 1100, Netgear MP101, Pocket Player on WM5 PDA
Location: near London, UK

Re: Status of TwonkyMedia Server on various NAS

Post by john.glasson » Mon Dec 21, 2009 8:18 pm

I have now added release 5.1.2 to the "Status of Twonkymedia on NAS" web page at http://www.glasson.hostecs.net/

If forum members can give more feedback I can make this list more up-to-date.

John Glasson

joergnapp
Posts: 16
Joined: Mon Nov 30, 2009 8:44 am
AV Hardware: NSLU2
Soundbridge Home
IPdio mini pro

Re: Status of TwonkyMedia Server on various NAS

Post by joergnapp » Tue Dec 22, 2009 10:56 am

You could add "yes" for 4.4.18 / NSLU.

5.1.x is "no" as it requires libraries not available on NSLU and is unusable.

san
Posts: 65
Joined: Fri Sep 25, 2009 1:57 pm
AV Hardware: WD My Worldbook (WhiteLight Edition)
Location: Center Italy

Re: Status of TwonkyMedia Server on various NAS

Post by san » Tue Dec 22, 2009 2:31 pm

john.glasson wrote:I have now added release 5.1.2 to the "Status of Twonkymedia on NAS" web page at http://www.glasson.hostecs.net/

If forum members can give more feedback I can make this list more up-to-date.

John Glasson
Hi John,
my tests for 5.1.2 on Western Digital My World Book II (white LIght) not convince me. The Twonky server on WD products
present a know problem of stability. With previous version sometimes the NAS esclude the ethernet port and need a restart,
i think the problem was related to the scanning database TMM auto function, but this event appears rarely.
with 5.1.2 the problem is presented more frequently, also with samsung client and WD HDTV Live Player.
I'll try to store some log file to discover what is the cause, but at this moment the release 5.1.2 for me it's not stable on WD nas.

i've found this error on twonky log file (some port /socket not opened??)

13:49:35:355 socket connect failed ip=127.0.0.1:9030 errno=111

13:49:35:355 [Error] - LOG_HTTP: HTTP_open: Failed to connect to ip=127.0.0.1 on port=9030

*UPDATE*
i try an hard reset according to these:

I/4 Hard reset (soft reset while powering up): Shutdown the NAS. Unplug the ethernet and the power cable. Plug in the power cable. While the NAS is powering up hold the reset button at the back for at least 40 sec. Plug the ethernet cable back. Start the NAS.

the scenario seems to be solved but 'im waiting to confirm you

***

merry christmas
Sante

yDdraigGoch
Posts: 2
Joined: Wed Feb 03, 2010 2:36 pm
AV Hardware: MBWE 1TB Blue Ring
TMS v6.0.39
Linux ARM little endian uclibc 0.9.28

Netgear DG834GT
x4 Win7 MPv12
PS3

Re: Status of TwonkyMedia Server on various NAS

Post by yDdraigGoch » Wed Feb 03, 2010 2:57 pm

san wrote:i've found this error on twonky log file (some port /socket not opened??)

13:49:35:355 socket connect failed ip=127.0.0.1:9030 errno=111

13:49:35:355 [Error] - LOG_HTTP: HTTP_open: Failed to connect to ip=127.0.0.1 on port=9030
Me too! That's why I'm here.

23:51:23:008 LOG_EVENTING:upnp_eventing_set_system_changed( 1 )
23:51:23:011 [Error] - LOG_HTTP: HTTP_open: Failed to connect to ip=127.0.0.1 on port=9030


Relatively new MBWE hacker - 48hrs or so - I've already upgraded from 4.4.11 which I found a couple of days ago on the wikidot pages.
Became paid-up registered license holder almost immediately and progressed onto 4.4.18, 5.0.68 same day.
All ran well & played to all PC's and thru PS3 to TV, so I am happy ( confused why the table says NO against these )
I now have TMS v5.1.2 & Web Interface is fully operational, enhanced now I am running 'christmas' Trees AlbumsArtists

Only problem ( getting back to opening statement ) is that I only have 30% of mp3's listed by WIndows Media Player in 'Other Libraries' :(
Checking log I have thousands of entries for - LOG_EVENTING:upnp_eventing_set_system_changed( 1 )

Not finding any info in offline searches so registered to ask for help/advice/assistance and add feedback here too!
regards

FHSalute
Posts: 16
Joined: Fri Dec 21, 2007 7:05 am

Re: Status of TwonkyMedia Server on various NAS

Post by FHSalute » Thu Feb 04, 2010 2:45 pm

Hi John,
here are the results for my TeraStation:
4.4.17 - yes, works fine
4.4.18 - yes, works fine
5.0.68 - yes, but nut used because of higher cpu loading and crapping navigation tree
5.1. - not tested

Ciao FHSalute
Server: Twonky v4.4 @ Buffalo TeraStation 0.6 HD-HTGL (with patched fw 2.14) and @ WHS
Clients: Ziova CS505 and muvid IR715
Network: static IP for all client (DHCP disabled because of requirements of Ziova device)
PCs: running WinXP Pro SP3

john.glasson
Posts: 71
Joined: Sun Aug 03, 2008 9:29 am
AV Hardware: Server: Western Digital My Book World Edition White Light
Clients: Zyxel DMA1000, Philips Streamium 1100, Netgear MP101, Pocket Player on WM5 PDA
Location: near London, UK

Re: Status of TwonkyMedia Server on various NAS

Post by john.glasson » Sun Feb 07, 2010 2:21 pm

Table showing TwonkyMedia status on various NAS updated - see http://www.glasson.hostecs.net/

Do please keep results coming in - that way I can add more useful information!

John Glasson

john.glasson
Posts: 71
Joined: Sun Aug 03, 2008 9:29 am
AV Hardware: Server: Western Digital My Book World Edition White Light
Clients: Zyxel DMA1000, Philips Streamium 1100, Netgear MP101, Pocket Player on WM5 PDA
Location: near London, UK

Discontinuation of Web Listing

Post by john.glasson » Wed Mar 17, 2010 1:37 pm

The service provider I've been using for the 'Status of Twonkymedia on various NAS' listing is unfortunately giving up on free web hosting. So as from the end of March this listing will no longer be available.

John Glasson

prmusic
Posts: 45
Joined: Wed Aug 08, 2007 5:58 am

Re: Status of TwonkyMedia Server on various NAS

Post by prmusic » Fri Mar 19, 2010 10:34 am

Hi,

my Maxtor Shared Storrage II (MSS II) works fine with 4.4.17 and 4.4.18.
It is stable.
5.xx I haven't tested so far.

prmusic

MartinS
Posts: 24
Joined: Thu Mar 25, 2010 10:08 pm
AV Hardware: Buffalo LinkStation Pro (V2, 3TB [2TB], TMS 6.0.38)
Buffalo LinkStation Pro (V2, 1TB, TMS 6.0.38)
Buffalo LinkStation Live (2TB, TMS 6.0.38)
Cisco Linksys WRT610N (DD-WRT build 18024)
Philips 52PFL9704H
WD HD TV Live (1.6.15)
Philips NP2900
Noxon iRadio
HTC Sensation (CoreDroid 2.7 [Android 2.3.4], TM 2.1.2)
HTC Desire HD (Stock ROM [Android 2.3.3], TM 2.1.2)
Apple iPad2 (64GB, 3G, iOS 5.0.1, TM 2.1.2)

Re: Status of TwonkyMedia Server on various NAS

Post by MartinS » Thu Mar 25, 2010 10:18 pm

Hi,

I was running 4.4.6 perfectly on my Buffalo LinkStation Pro (V2, 1TB) for some time, just upgraded to 5.1.3-dev, which is also up, but not 100% OK - eg. DB rebuild every time the system restarts. Although 5.1.5 is running better than 5.1.3-dev, it is missing all MKV files and also rebuilding its database every time it starts; version 5.1.6 is missing ALL files.

Versions 6.0.0 and RC prior to this are OK but missing MKVs again - just tried 6.0.1 - runs perfectly, streams even 8GB MKVs.

Cheers,

Martin
Last edited by MartinS on Mon Aug 02, 2010 9:18 pm, edited 2 times in total.

Morse
Posts: 1
Joined: Sun Mar 28, 2010 8:36 pm
AV Hardware: Philips SLA5500, Philips SLA5520, Philips WAK300

Re: Status of TwonkyMedia Server on various NAS

Post by Morse » Sun Mar 28, 2010 8:41 pm

I have version 4.4.1.18 running smoothly on Xtreamer eTrayz. Very easy to install!
Version 5 not available there.

Details on the Xtreamer forum: http://forum.xtreamer.net/viewtopic.php?f=179&t=13598

23646266
Posts: 12
Joined: Wed Dec 20, 2006 10:43 pm
AV Hardware: Mac Pro, Macbook Pro: 10.6.3, ATV 3.0.1, Soundbridge, Noxon2,
Apple iPhone, iPad, Sony Bravia, FritzBox, Fritz!Media,
debianized LS-GL2, debianized TS-219P, XBMC, Boxee, SimplifyMedia

Re: Status of TwonkyMedia Server on various NAS

Post by 23646266 » Mon Mar 29, 2010 7:38 pm

up and running:
Buffalo LS-GL 2, debianized ( lenny )
(Linux LS-GL2D3 2.6.12.6-arm1 #33 Tue Aug 8 17:16:04 JST 2006 armv5tejl GNU/Linux)

twonkymediaserver 5.1.3-dev

greetz

=:-)f

TheOmen
Posts: 62
Joined: Wed Jul 05, 2006 11:33 am
AV Hardware: Zyxel DMA-2500
Philips SLA-5500
Terratec Noxon
Location: Utrecht, the Netherlands
Contact:

Re: Discontinuation of Web Listing

Post by TheOmen » Tue Mar 30, 2010 8:46 am

john.glasson wrote:The service provider I've been using for the 'Status of Twonkymedia on various NAS' listing is unfortunately giving up on free web hosting. So as from the end of March this listing will no longer be available.

John Glasson
Couldn't you just move the data to Google Documents? That way, everyone can still view your usefull list.

Jeroen

john.glasson
Posts: 71
Joined: Sun Aug 03, 2008 9:29 am
AV Hardware: Server: Western Digital My Book World Edition White Light
Clients: Zyxel DMA1000, Philips Streamium 1100, Netgear MP101, Pocket Player on WM5 PDA
Location: near London, UK

New URL for Status List

Post by john.glasson » Tue Mar 30, 2010 10:01 pm

Only just picked up Jeroen's excellent suggestion about using Google Docs. I'll try this (have not used it before). List is now avaiable at:

http://docs.google.com/Doc?docid=0AXh6t ... M&hl=en_GB

I have not updated the list recently; but I have made it editable by anyone, so hopefully forum users will help to keep it up to date.

Maybe the URL needs to be made more readily available (rather than hidden within this thread)? If anyone knows how best to do this on the Twonky Forum do please go ahead.

John Glasson

TheOmen
Posts: 62
Joined: Wed Jul 05, 2006 11:33 am
AV Hardware: Zyxel DMA-2500
Philips SLA-5500
Terratec Noxon
Location: Utrecht, the Netherlands
Contact:

Re: Status of TwonkyMedia Server on various NAS

Post by TheOmen » Wed Mar 31, 2010 8:25 am

Hi John,

Great to be of help!
Updated the list for Synology DS-108J.

Jeroen

greeny122229
Posts: 4
Joined: Tue Mar 30, 2010 10:17 pm
AV Hardware: na - integrated windows 7

Re: Status of TwonkyMedia Server on various NAS

Post by greeny122229 » Thu Apr 01, 2010 12:05 am

raidsonic icybox IB-NAS4220-B
4.4 stable fast
4.4.4.18 - stable fast
5.12 - works but not well - reccomend avoiding
5.13 - works however seems to have scanning issues and loss of data on restarts

Ta

Post Reply