5.1.3 on NSLU2 UnSlung 6.x does not starts

General discussion about the media server. Feature requests. Hints, tips and tricks.
Locked
oniji
Posts: 2
Joined: Fri Feb 26, 2010 8:49 pm
AV Hardware: NSLU2

5.1.3 on NSLU2 UnSlung 6.x does not starts

Post by oniji » Fri Feb 26, 2010 9:17 pm

Hallo everyone,
i'm new here and try to run 5.1.3 on my nslu2.

Have installed manually at /usr/local/twonky
Have modified twonkymedia2.sh to comment out :
#alias rc_exit=exit
#rc_exit

When i want to start the server it seems that it is running, but 30 sec later the process does not exists anymore.

My First START .. with status

# ./twonkymedia2.sh start
Starting /usr/local/twonky/twonkymedia ... Daemonizing...

# ./twonkymedia2.sh status
TwonkyMedia server IS running.
# ./twonkymedia2.sh status
TwonkyMedia server IS running.
# ./twonkymedia2.sh status
TwonkyMedia server IS running.
# ./twonkymedia2.sh status
TwonkyMedia server IS running.
# ./twonkymedia2.sh status
No TwonkyMedia server is running
# ./twonkymedia2.sh status
No TwonkyMedia server is running

My Second START .. with ps

# ./twonkymedia2.sh start
Starting /usr/local/twonky/twonkymedia ... Daemonizing...

# ps -eaf |grep twonk
2485 root 476 S /usr/local/twonky/twonkymedia -D
2486 root Z [twonkymediaserv]
2488 root 424 S grep twonk
# ps -eaf |grep twonk
2490 root 424 S grep twonk
#

What does the "Z" mean ? Does someone have an idea ?
I also tried nassetup.exe but nothing works.
What can i do ?

Thanks for any reply. :D
Oniji

joergnapp
Posts: 16
Joined: Mon Nov 30, 2009 8:44 am
AV Hardware: NSLU2
Soundbridge Home
IPdio mini pro

Re: 5.1.3 on NSLU2 UnSlung 6.x does not starts

Post by joergnapp » Tue Mar 02, 2010 6:15 pm

How do you get it to start anyway? It's still dependant on libstdc++.so.6, which isn't available on my NSLU.
What firmware are you using?

oniji
Posts: 2
Joined: Fri Feb 26, 2010 8:49 pm
AV Hardware: NSLU2

Re: 5.1.3 on NSLU2 UnSlung 6.x does not starts

Post by oniji » Wed Mar 03, 2010 1:34 pm

a friend of mine helped me, now i use twonky 4.x, he says, that unslung 6.x has an older kernel und twonky 5.1.3 does not work with this kernel.
Now i'm happy.
thx
oniji

Locked