LG Smart TV's vs Twonky

Post Reply
Barrell529
Posts: 3
Joined: Tue Jan 22, 2019 1:51 pm
AV Hardware: NAS: D-Link DNS-323-A1 (Alt-F 1.0 + Twonky 8)
Clients: LG Smart TVs (WebOS and Netcast models), PS-3, mobile VLC player on Android/IOS devices

LG Smart TV's vs Twonky

Post by Barrell529 » Mon Feb 04, 2019 9:56 am

Good day!

I'm using Twonky server for a various clients.
Including two different LG Smart TV's (the newer one is using WebOS, the older one - Netcast). The "mediaplayer type" is detected correcly by Twonky and set as "LG TV" for both of them.
But with this "Mediaplayer type" i can not get a a photo previews (thumbnails) - only generic icons displayed and the name of the photo. But if i open one of the photo it loads correctly.
I tried to swith the "Mediaplayer type" and set it to "Generic DLNA". In this case - i can see the photo previews/thumbnails but if i play the video file i miss fastforward(FF)/rewind/skip functions.

So for now, if i what to watch photo gallery - i need to log in to Twonky admin web interface and change "Mediaplayer type" to "Generic DLNA" to see the thumbnails/previews.
If i'm going to watch a movie - i have to switch to "LG_TV" so i'm able to navigate in a movie playback
And it's annoying and inconvinient.
Please share your ideas and thoughts of what kind of setup to test and what to try?
Maybe this TVs require some kind of custom xml device description? I checked both xml files correspoding to "Generic DLNA" and "LG_TV" types but i don't have enough knowlendge to customize them.

PauleSmith
Posts: 5
Joined: Sun Nov 10, 2019 4:02 pm
AV Hardware: ASUS DSL-N55U ADSL Modem Route, AVM FRITZ!Box, d-link, Linksys, Raspberry Pi 2 and 3 UPnP Media server based on ReadyMedia with EasyMPD, PCEngine Alix and APU UPnP Media server based on ReadyMedia with EasyMPD, Naim HDX ripping UPnP server, SFR Neuf Cegetel NeufBox 5, DSL/GPON Gateways

Re: LG Smart TV's vs Twonky

Post by PauleSmith » Thu Nov 21, 2019 5:55 pm

This is a very interesting question, I would also like to know the answer to it, I need to make a blue abstract background, but because of this question I can’t.

Post Reply