Twonkymedia server doesn't show all the vob files on Bravia

Post Reply
vkolli
Posts: 9
Joined: Thu Dec 10, 2009 9:36 pm
AV Hardware: WHS on Scaleo Home Server
Sony Bravia 46W5100

Twonkymedia server doesn't show all the vob files on Bravia

Post by vkolli » Mon Dec 14, 2009 2:21 am

<Reposting this from TMS forum as I suspect the problem might be with Bravia TV config rather than MTS config>

My Config:
Sony Bravia 46W5100 connected with Wifi bridge
Twonky Media Server 5.1.1
Windows Home Server PP3 running on Intel NAS server

I am using Twonkymedia server running from my WHS server, streaming to Sony Bravia internet W series TV. I am able to see all my photos and mp3s OK. However when i look at videos, only one vob file in each folder shows up. I have my movies and home videos ripped with DVD shrink and I end up with 5 vob files in the video_TS folder in the WHS mediaserver. However only the first vob file in each video_TS folder shows up in the TV. Its always the VTS_01_1.vob file. The rest of the files don't appear. It plays the one visible file OK and then stops.

I tested with a XP client running Twonky Media manager and it can see all the files OK. TMS servers also lists all the files in the Web browser config pages. So I am thinking the problem lies with Bravia receiver configuration. The other thing is if its an episode DVD and contains multiple files for each episode, it lists just the first file of each episode, usually titled vts_01_1, vts_02_1, vts_03_1 ...... For some strange reason it seems to be just capturing vts_xx_1.vob in each folder. It does not happen with mp3s or jpegs.

Does anyone else have TMS 5.1.1 working with Bravia internet TVs and are able to stream vob files OK?

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: Twonkymedia server doesn't show all the vob files on Bravia

Post by Twonky_Rick » Wed Dec 16, 2009 2:05 am

This is not a TwonkyServer-related issue. Sony TVs only play MPEG-2 and AVCHD format video. You might want to experiment and see if it works if you rename these files with an .MPG extension. It could, because most DVDs are encoded using an MPEG-2 codec.

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/

vkolli
Posts: 9
Joined: Thu Dec 10, 2009 9:36 pm
AV Hardware: WHS on Scaleo Home Server
Sony Bravia 46W5100

Re: Twonkymedia server doesn't show all the vob files on Bravia

Post by vkolli » Wed Dec 16, 2009 2:07 am

Well, it is listing that one file in each folder and plays that file OK. So, i am not sure if it is related to the video format.

Thanks,

VK

oschelde
Posts: 3
Joined: Sun Oct 18, 2009 9:54 am
AV Hardware: Twonky Media Server 5.1, Mac Mini, Sony KDL32V5500

Re: Twonkymedia server doesn't show all the vob files on Bravia

Post by oschelde » Fri Dec 25, 2009 11:01 pm

I works for me without problems with TwonkyMedia Server version 5.1 on a Mac to a Sony Bravia 32V5500.
Today I tried to upgrade to version 5.1.2 and after that I couldn't play my vob-files anymore. Neither the new ones I created or those that played before the upgrade with TwonkyMedia Server 5.1.

So I think the problem is with TwonkyMedia Server that does not recognize vob-files.
As a result I have downgraded again to version 5.1.

User avatar
Fozzie Bear
Posts: 15
Joined: Tue Sep 01, 2009 3:11 pm
AV Hardware: Dell Poweredge 830 server running Windows Home Server PP2
1 PC with Vista Media Centre Edition
2 PCs with XP 2005 MCE

Re: Twonkymedia server doesn't show all the vob files on Bravia

Post by Fozzie Bear » Sat Jan 23, 2010 8:41 pm

[quote="vkolli
I am using Twonkymedia server running from my WHS server, streaming to Sony Bravia internet W series TV. I am able to see all my photos and mp3s OK. However when i look at videos, only one vob file in each folder shows up. I have my movies and home videos ripped with DVD shrink and I end up with 5 vob files in the video_TS folder in the WHS mediaserver. However only the first vob file in each video_TS folder shows up in the TV. Its always the VTS_01_1.vob file. The rest of the files don't appear. It plays the one visible file OK and then stops.

I tested with a XP client running Twonky Media manager and it can see all the files OK. TMS servers also lists all the files in the Web browser config pages. So I am thinking the problem lies with Bravia receiver configuration. The other thing is if its an episode DVD and contains multiple files for each episode, it lists just the first file of each episode, usually titled vts_01_1, vts_02_1, vts_03_1 ...... For some strange reason it seems to be just capturing vts_xx_1.vob in each folder. It does not happen with mp3s or jpegs.

Does anyone else have TMS 5.1.1 working with Bravia internet TVs and are able to stream vob files OK?[/quote]

I had a similar issue to you with my Bravia KDL-W5500 and was advised by another person on this forum to do one of two things.
When you rip your DVD with DVD Shrink change the setting in the output files which says break up files into 1gb chunks. DVD shrink will then produce a single Vob file.
Alternatively you can join all the Vob files using JoinVobFile Tool which is freeware. Afterwards you can even change the file extension from .vob to mpg and TMS will play it just fine.
Fozzy

vkolli
Posts: 9
Joined: Thu Dec 10, 2009 9:36 pm
AV Hardware: WHS on Scaleo Home Server
Sony Bravia 46W5100

Re: Twonkymedia server doesn't show all the vob files on Bravia

Post by vkolli » Sun Jan 24, 2010 3:30 am

Fozzy,

Thanks for the note. I did not want to make changes to all my videos, as I have quite a few of them.

When i upgraded to TMS 5.1.2, I am able to see&play all files including videos. But this is the strange thing. I had to change the media receiver profile from 'Sony Bravia' to 'Generic DLNA' server. If I use Sony Bravia profile, music files are listed under the video section. The problem with Generic DLNA profile is that you have to navigate to one more tree selection to get to your files. This is what Twonky claims to have fixed with 5.1.2 under Sony Bravia profile. But it looks like they haven't quite done it right.

User avatar
Fozzie Bear
Posts: 15
Joined: Tue Sep 01, 2009 3:11 pm
AV Hardware: Dell Poweredge 830 server running Windows Home Server PP2
1 PC with Vista Media Centre Edition
2 PCs with XP 2005 MCE

Re: Twonkymedia server doesn't show all the vob files on Bravia

Post by Fozzie Bear » Sun Jan 24, 2010 3:26 pm

Hi vkolli,
I may be wrong (and I am sure that others will put me right if so), but I dont think you can play a DVD right through unless you have a single vob file. I still have a number of films which I have not joined as one file and they play the first vob file in the folder and then stop. You can then choose the next file in the folder and that will then play until it comes to the end.

I have about 200 films either ripped from my DVD collection or recorded on Sky+ and then transferred to DVD to be ripped to my WHS box using DVD shrink. Its time consuming but at least they play properly. I also rename the vob file from VTS_01_00 etc to the name of the actual film e.g. Silence of the Lambs.They then appear in the Crossbar file tree in name order.
That said there is a problem with TMS 5.1.2 as someone else has posted on this forum. Somewhere the tree has been broken. If you choose the option in the Bravia to sort aphabetically a>z then the content under the Videos tab appears as Photos. By changing the sort order back to z>a it resolves it. There is obviously still some work to do here to resolve this bug.

Fozzie

Post Reply