MP101 and Ubuntu Gusty

Everything about the Netgear support, problems, hints...
Post Reply
Posts: 3
Joined: Sun Jan 20, 2008 2:00 pm

MP101 and Ubuntu Gusty

Post by umrkzappa » Sun Jan 20, 2008 2:31 pm

Can anyone help. I have two MP101's connected over wireless to a linux machine (Ubuntu Gusty) running TwonkyMedia (latest version 4.4.3). I cannot get the devices to work without locking up in some way.

- If I run clients as "Netgear MP101" then after part of a song the MP101 will stop and skip to the next song.
- If I run as Netgear MP101 RTP then after two songs the TwonkyMedia server runs at 100% CPU and then the MP101 stops.
- The wireless signal is excellent for both devices yet if I run a dedicated wire to the boxes then they work better but I need to run them wirelessly for layout reasons.

Note: this used to work more reliably when I ran Ubuntu dapper and TwonkyMusic 2.x but this did not support my XBox for photos and video, hence the upgrade and problems...

I have tried:
- different routers and wireless access points (linksys, netgear, BT HomeHub)
- opening up multicast ports
- opening iptables to allow MP101's to send to any port
- upgrading to the latest MP101 firmware including the unofficial beta off the yahoo netgear support form
- done the MP101 hardware modifications (soldering extra capacitors into the device)

Has anyone any extra ideas.

Many thanks in anticipation of a solution.... :D

Posts: 51
Joined: Sun Jul 10, 2005 7:40 pm

Re: MP101 and Ubuntu Gusty

Post by warti » Sun Mar 02, 2008 7:51 pm


I had similar symptoms:
- "Netgear MP101" after part of a song the MP101 stops, pauses and skips to the next song.
- "Netgear MP101 RTP" starts immediately stuttering

I'm using linux <debian etch> as a server. MP101 is connected hard wired via two ordinary switches.

It seems that I get it fixed for me (at least one CD runs through w/o problems *touch wood*)
I added the following line to the /etc/init.d/twonkyserver start script:

Code: Select all

/sbin/route add -net netmask dev eth0
I took this line from my former NSLU installation.


PS: Can You send me the newest MP101 beta firmware 1.4.7 via pm

Posts: 3
Joined: Sun Jan 20, 2008 2:00 pm

Re: MP101 and Ubuntu Gusty

Post by umrkzappa » Mon Apr 07, 2008 3:28 pm

Thanks for the suggestion but I tried the fix and it has not changed the situation.

Post Reply