Twonky server is multiplying itself

Everything about the Netgear support, problems, hints...
Post Reply
Joined:Thu Jun 10, 2010 8:07 pm
AV Hardware:ReadyNas Duo
Twonky server is multiplying itself

Post by Maynard » Thu Jun 10, 2010 8:24 pm

I'm using Twonky server 5.1.5 on ReadyNas Duo. The server is multiplying itself for some reason. Arter install i have .9000, but after a few days .9001 show up and then after that .9002 and so on. The problem was there also with 5.1.3. Anyone seen this before and possible solution?


Joined:Fri Jun 17, 2011 8:11 pm
AV Hardware:Netgear Ultra 2 Plus

Re: Twonky server is multiplying itself

Post by darren_h » Fri Jun 17, 2011 8:13 pm


Yes I am getting this - all the more frustrating as I have Squeezebox running on port 9002.

Can we force through a RPC call or something Twonky to run on 9001 so ideally I can run Squeezebox on 9000?

This would be good. I have Twonky 6.0.32.

I've uninstalled Twonky until I know a solution...

Joined:Wed Nov 19, 2008 1:59 am
AV Hardware:Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location:San Diego

Re: Twonky server is multiplying itself

Post by Twonky_Rick » Sat Jun 18, 2011 12:09 am

Here is some info which may be useful. I've tried this on the PC, but I'm not sure if this works on all NAS.

- If you leave the “httpport” setting blank it will default to port 9000
- If port 9000 is taken, the server will automatically scan for the next free port
- You can override the default HTTP port setting with your own setting. Typical values are in the range of 8000 to 9999
- After TwonkyServer is installed, it no longer reads the default INI file -- except when the user selects a ‘reset to defaults’ command.
- Normally the server will use the twonkymedia-server.ini file, which is stored under the Applications/user folder. This is the same location where the server database is stored.
- Make sure to put the change in the twonkymedia-server.ini file (and not the twonkymedia-server-default.ini file)
- Make sure to restart TwonkyServer after making a change in the .ini file
- If TwonkyServer server is running you can also try this from your browser:

Follow me on Twitter! mostlytech1
Checkout my blog:

Post Reply