Twonky4.4.11 on Linksys Router WRTSL54GS on Tomato Firmware

LinkSys wireless Music Player and LinkSys Media Adapter
Post Reply
Joined:Sat Mar 28, 2009 6:49 am
AV Hardware:Western Digital MyBook World Edtion , 1 Terabyte NAS Device.

Twonkyvision for emedded NAS Linux ARM little endian uclibc 0.9.28 ver 4.4.11

PS3 connected via Wired 100Mbps LAN Swtich as DLNA renderer/player.

Samsung 32" LCD LAR32.

Yamaha YHT-185 Surround Sound Amplifier with Speakers/Subwoofers.
Twonky4.4.11 on Linksys Router WRTSL54GS on Tomato Firmware

Post by AlterEgo » Wed Apr 01, 2009 3:04 pm

Hi All,

A little background :

I have flashed Linksys WRTSL54GS with Tomato 1.23 ND USB + FTP/Samba Mod by teddy_bear.

After installation i tried to install Optware packages via the guide provided at Since the internal formatted JFFS2 flash was around 3.7MB, probably it ran out of space and gave me errors and didnt complete the installation.

So I added a USB flash disk formatted with Ext3 to a USB Hub attached to Linksys WRTSL54GS . Mounted it internally as a disk to
then since the optware packages are installed to router's internal /opt directory , I mounted the USB flash disk as binded to the router's internal /opt folder. In this way I was able to install uclibc-opt_0.9.28 and Ipkg as the optware packages successfully.


After installation of optware my natural choice was to make and use the Linksys WRTSL54GS as a standalone DLNA/Upnp server so it can share and stream the media from any attached USB hardisk (this is the reason I got it for in the first place).

Since I have done a similar experiment with Western Digital 1TB World Edition NAS device, i thought it would work on Linksys router along the same lines. I downloaded the embedded NAS version of TwonkyMedia for Linux ARM little endian uclibc 0.9.28 from

Now this version (hopefully) should run on Linksys WRTSL54GS as well, however it has some predefined folder locations from which it runs correctly in the Western Digital NAS device. In WD first I need to define a new folder 'TwonkyVision' in '/usr/local' . Then the zip file from twonky site is unzipped (ipkg-unzip) in
folder . Then there is a shell script which starts the and runs the twonky server. Once it is started the shared media is shown on the PS3/Mobile Phone or any other DLNA complaint media renderer.

The problem with Linksys WRTSL54GS is that when i try to define a new folder 'TwonkyVision' in the folder /usr/local it gives me an error message that filesystem is Read-Only. I am logged in via 'root' user however. Any clues how it can be done ?

Then since the Twonkymedia directory and media database can grow considerably (as your media collection grows) due to its indexing and caching of the images, i thought that having Twonkymedia in router's internal folder is not a workable solution anyways.

So i created a new folder 'TwonkyVision' in the space provided by attached USB flash (mount bind as /opt). As usual i unzipped all files in this folder and when i tried to run , it gave me an error that folder /usr/local/ does not exists. It is true since I am not running it from /usr/local/TwonkyVision folder.

I tried to edit the file and replaced the entry '/usr/local/TwonkyVision' with the entry "/tmp/mnt/disc0_1/TwonkyVision". Tried running the again (it calls a file twonkymedia in the same folder) and now it shows another error like "word expected not " ) " ) ". After that I am stuck till now.

If someone else has done a similar experiment, then the most help i need is that can someone guide me how to run the TwonkyVision Linux ARM little endian uclibc 0.9.28 from any other user defined location instead of the hardcoded "/usr/local/TwonkyVision" folder. How to edit the file and do anyother adjustments if necessary. It maybe equally true that linksys with tomato and optware is even not capable of running Twonkymedia.

I have tried other DLNA server in the NSLUG2 optware package library at, but none is as flexible and easily configurable as twonky.

I am using puTTy for the terminal SSH access to Linksys WRTSL54GS and WinSCP for folder browsing/file management.

Thanks for reading and for help.


Joined:Wed Nov 19, 2008 1:59 am
AV Hardware:Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location:San Diego

Re: Twonky4.4.11 on Linksys Router WRTSL54GS on Tomato Firmware

Post by Twonky_Rick » Mon Apr 06, 2009 9:28 pm

In principle TwonkyMedia can be installed in any location. It just should be started using the absolute path to the twonkymedia binary.

I forwarded your notes to an engineer who said what you tried look fine. He thinks your problem might be related to one of these things:

- He just broke the shell script while editing it... (To test this he can just call the twonkymedia binary directly...)
- The device does no allow running programs from the USB drive

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog:

Post Reply