Page 1 of 1

VLC does not ever get a Response from Twonky

Posted: Sun Mar 13, 2016 4:48 am
by nosmadar2016
Background information:

QNAP NAS Model: TS-412
QNAP Firmware: 4.1.1 Build 20141101
[~] # uname -a
Linux Mnemosyne 3.4.6 #1 Sat Nov 1 09:34:56 CST 2014 armv5tel unknown

TwonkyServer v7.2.7
Twonky Detailed Status
Cached Memory 7804KB
Last Database Update 2016-03-06 14:13
Server Uptime 40 days, 23 hours, 47 minutes, 52 seconds
Server Restart Pending No
Windows Media DRM Status
Network Interfaces 00:08:9B:CD:63:04
(I tried to get the log file but I ran into a snag trying to use the instructions on the forum, so I would need a bit of assistance with that.)

Twonky thinks there are 11974 'songs' in the database. plus there are 3443 pictures and a handful of videos.
(The NAS thinks that there are 12000+ songs, but that's an issue for another day. :-)

UPnP client: VLC media player 2.0.8 Twoflower
Running on Linux (Ubuntu 12.04)

The router (from AT&T)
Manufacturer Pace Plc
Model 5031NV-030

I'm trying to play .FLAC audio files from Twonky using VLC, I know the files are OK because I can play them on my tablet (Android) using the QNAP Android App. I am trying to use the VLC media player as a DLNA/UPnP client to access the files via UPnP but it's not working. I was able to do a trace using Wireshark (on the PC running VLC) and what I see is that VLC does start an M-SEARCH on port 1900. And the Router does broadcast that to the entire network. But TwonkyServer does not respond. I know that Twonky UPnP is working because I also have a PS3 device which automatically finds Twonky and can display the Photos I have stored on the NAS. What I noticed about TwonkyServer is that it does not have the VLC media player in it's list of known clients. I tried setting the Media Receiver type to "Generic DLNA 1.0" in the Sharing part of the twonky settings page for the PC that VLC is running on., but that didn't seem to work either.

NOTE: this is not the "VLC takes a long time to load the playlist" issue []
I have let VLC sit for over 1/2 hour and there is never any response from TowonkyServer to the initial request on port 1900 from VLC.

Any suggestions would be appreciated.

Re: VLC does not ever get a Response from Twonky

Posted: Mon Mar 14, 2016 2:32 am
by nosmadar2016
Correction: The QNAP app on the tablet does not use Twonky. But I've been able to browse the music folders in the twonky http client and play a .FLAC file, so I know the files work.