Impossible to port to a new server

Linux and UNIX specific discussions
Post Reply
Posts: 2
Joined: Sun Dec 11, 2016 7:16 pm
AV Hardware: Twonky Server 8.3 on openSUSE Linux

Impossible to port to a new server

Post by Schwedenbitter » Fri Feb 10, 2017 8:20 am


I'm using Twonky for almost 10 years on Linux systems (openSUSE) and startet with 4.4.5. Meanwhile I had 3 different machines and never problems in porting Twonky to a new server.
Last December I had the stupid idea to buy a new version 8.3 for no reason, having nothing but trouble since then:
  • Twonky doesn't sort the titles by their filename/No. tag, even -> solved by editing /resources/views/folder.view.xml
  • Twonky spreads it's data all over the system. I don't like it, if there is some stuff on root "/", on "/var/twonky/twonkyserver", on "/tmp/twonkyserver-log.txt" instead of the default log-directory. If on ist looking for something, one has to search first.
  • Twonky is unable to handle cover pictures any more: I see covers, where no covers are - neither in the directory nor included in mp3-tag - or Twonky shows the wrong covers -> I already tried to change "/var/twonky/twonkyserver/twonkyserver.ini" the way, it saves the "thumbnail_cache_storage_type" on disc instead of memory. But without success
  • Even if the new feature "server aggregation" is disabled by default, it does aggregate. If I use the URL http://[server]:9000/rpc/stream_info I get the following messages:
    2017-02-10T07:46:13 192.168.X.Y Windows 7/8 /.../mp3/Pop/Adele/2015 - »25«/10.mp3
    2017-02-10T07:47:35 192.168.X.Z Twonky Aggregation Server /.../mp3/Kinder/Hoerspiele/Bibi Blocksberg/03 Die Zauberlimonade/05.mp3
  • Main Problem: My current hardware is going to die. So I already installed a new system on a different machine. Everything worked fine (beside my problems) on the old system. But my Webradios (Noxon, Android BubbleuPnP, Marantz) doesn't "see" the new server - even if I tear down the firewall. This makes me really angry.
  • I've tried to download a fresh system several times. Right now I got a new problem, since lynxtechnology made an upgrade to version 8.4. I can't use this, because I don't have a passwort for it.
If somebody here could help me with advise or at least confirm to suffer from the same problems, I'd appreciate that a lot.

Thanks, Alex

Posts: 2
Joined: Thu Dec 07, 2017 3:53 am
AV Hardware: UPnP servers

Re: Impossible to port to a new server

Post by RaLax001 » Thu Dec 07, 2017 3:56 am

henry richard
Posts: 1
Joined: Mon Feb 24, 2020 10:03 am
AV Hardware: fsghraghvdcsgbdgdsvbsdGBaEGdagSDVGDSGHsdgsdgsdgdsgsghrthb

henry richard

Post by henry richard » Mon Feb 24, 2020 10:05 am

Thanks for this wonderful information ... Apps-02-22

Post Reply