Xbox doesn't see twonky when started at boot time (Ubuntu)

Linux and UNIX specific discussions
Post Reply
botbanky
Posts: 7
Joined: Tue May 27, 2008 7:49 pm
AV Hardware: Dell Inspiron 6000 running Ubuntu linux, Hardy Heron 8.04 edition
XBox 360 client
DLink DI-624 wireless router

Xbox doesn't see twonky when started at boot time (Ubuntu)

Post by botbanky » Tue May 27, 2008 8:10 pm

I'm running Ubuntu Linux version Hardy Heron 8.04 with the latest patches, use a Dell Inspiron 6000 laptop, have a DLink DI-624 router with the latest firmware, an XBox 360, and downloaded the latest version of Twonky Media. TwonkyMedia on my laptop streams music to my Xbox, which the XBox recognizes just fine.

So I want to startup up the Twonky server every time I boot up my laptop. I followed the online instructions (http://www.twonkyvision.de/Support/FAQ/ ... inux&n=1:8), and played around with various things. I settled on dumping a script (TwonkyStart.sh, contents below) in my /etc/init.d folder and running the usual 'sudo update-rc.d TwonkyStart.sh defaults' command. Now when I reboot my machine I see there is a process running (pidof twonkymedia returns an id), however the 360 can't see the server. If I kill that existing process and then execute the exact same script I run at startup then the 360 instantly recognizes it. Can anyone explain this?

TwonkyStart.sh script version 1 (no luck):

Code: Select all

#!/bin/sh

/usr/local/TwonkyVision/./twonkymedia -xD 

# EOF.	
TwonkyStart.sh script version 2 (no luck):

Code: Select all

#!/bin/sh

/usr/local/TwonkyVision/./twonkymedia -D 

# EOF.	
TwonkyStart.sh script version 3 (no luck):

Code: Select all

#!/bin/sh

/usr/local/TwonkyVision/./twonkymedia -x 

# EOF.

SteveBloke
Posts: 2
Joined: Wed May 28, 2008 10:52 am
AV Hardware: Xbox 360, Nokia N95

Re: Xbox doesn't see twonky when started at boot time (Ubuntu)

Post by SteveBloke » Wed May 28, 2008 10:56 am

Hi,

I see the same behaviour, it seems that at system startup the server is running as localhost 127.0.0.1, and when I restart it, it gets a "correct" ip address assigned to it, and can then be "found" by my xbox/n95.

I'm afraid I haven't worked out how to fix it yet, but this is the reason why your xbox doesn't see the server.

Cheers,

SteveBloke.

SteveBloke
Posts: 2
Joined: Wed May 28, 2008 10:52 am
AV Hardware: Xbox 360, Nokia N95

Re: Xbox doesn't see twonky when started at boot time (Ubuntu)

Post by SteveBloke » Wed May 28, 2008 10:58 am

This thread looks like it has the answer in it.

http://www.twonkyforum.com/viewtopic.php?f=6&t=4772

Cheers,

SteveBloke

HornedBeast
Posts: 33
Joined: Mon Apr 21, 2008 3:17 pm
AV Hardware: XBOX 360
Linksys Router
Linux, Ubuntu Server 8.04.

Re: Xbox doesn't see twonky when started at boot time (Ubuntu)

Post by HornedBeast » Wed May 28, 2008 3:34 pm

Or try here for a complete guide:

http://www.twonkyforum.com/viewtopic.php?f=6&t=5065

botbanky
Posts: 7
Joined: Tue May 27, 2008 7:49 pm
AV Hardware: Dell Inspiron 6000 running Ubuntu linux, Hardy Heron 8.04 edition
XBox 360 client
DLink DI-624 wireless router

Re: Xbox doesn't see twonky when started at boot time (Ubuntu)

Post by botbanky » Thu May 29, 2008 3:11 am

Yep, that was it. I needed to add the -ip switch with the appropriate IP for my machine in the /etc/init.d/twonkyserver file at this section:

Code: Select all

echo -n "Starting $TWONKYSRV ... "
$TWONKYSRV -D -ip 192.168.0.2 -inifile "${INIFILE}"
Thanks SteveBloke.

Post Reply