Segmentation fault

Linux and UNIX specific discussions
Post Reply
howe222
Posts: 2
Joined: Tue Sep 09, 2008 6:23 am
AV Hardware: PS 3 , linux etch

Segmentation fault

Post by howe222 » Mon Sep 22, 2008 10:07 pm

Good evening,

after starting /usr/local/TwonkyVision/twonkymediaserver - I get within seconds

Segmentation fault

I'm running twonkyserver under Linux debain Etch Kernel 2.6.18-6-486

any ideas ?

nofear-tn
Posts: 11
Joined: Fri Mar 21, 2008 8:45 pm
AV Hardware: PS3
running Twonky media server on my Debian 4 server

Re: Segmentation fault

Post by nofear-tn » Tue Sep 23, 2008 6:11 pm

same thing here
and no one knows whats wrong or how to fix it .
this is bad for Twonky

protrecho
Posts: 2
Joined: Wed Oct 08, 2008 10:49 pm
AV Hardware: PC running Linux

Re: Segmentation fault

Post by protrecho » Wed Oct 08, 2008 11:13 pm

Same for me running on the rPath Kernel issued for OpenFiler. It worked for a few days and now crashes out all the time. I'm running on 4.4.6 as well - has anything else been found out about the root cause yet?

heroldem
Posts: 1
Joined: Sun Feb 01, 2009 11:16 am
AV Hardware: xbox360

Re: Segmentation fault

Post by heroldem » Sun Feb 01, 2009 11:19 am

Still the same for me here today:

It happens when having a renamed (to wmv) MKV-Movie inside my Movie-Folders observed by Twonky.

Moving those out of the directories twonky is starting.

Anyone got it fixed? My package is twonkymedia-i386-glibc-2.2.5-5.0.46-20090114

I would like to buy it if this is working, guys.

bonix
Posts: 3
Joined: Tue Jun 27, 2006 8:47 pm
AV Hardware: Ubuntu 8.10 XEN domU with kernel 2.6.27-11-server, Allnet AudioMate WKAN radio

Re: Segmentation fault

Post by bonix » Mon Mar 30, 2009 10:30 pm

hi folks,

same problem here: fresh ubuntu 8.10 x64 kernel 2.6.27-11-server with lib32 installed and twonkymedia-i386-glibc-2.2.5-5.0.46-20090114.sh
results in
twonkymedia[3602]: segfault at 1 ip 0000000000000001 sp 00000000ffdcab90 error 14 in twonkymedia[8048000+1000]
:shock:

Has anyone a clue?
If any other info is needed - let ne know...

best regards
Ralf

Hanssing
Posts: 1
Joined: Sun May 31, 2009 12:34 pm
AV Hardware: Windows + Twonky
Linux Ubuntu + Twonky
Panasonic Vierra
etc.

Re: Segmentation fault

Post by Hanssing » Sun May 31, 2009 12:54 pm

As new twonky user, I downloaded the linux-install, unzipped it, and followed instructions contained.
I can get sporadic connection to the server, but it keep segmeting, and then gettign restarted I think?

Starting only the server I get (within 7 secs):
---------------------------------------------------------------------
/usr/local/twonkymedia/twonkymediaserver -D
TwonkyMedia Version 5.0.61
using logfile /tmp/TwonkyMediaServer-log.txt

For image conversion and scaling the TMS utilizes ImageMagick. For details on the license please see /usr/local/twonkymedia/cgi-bin/convert-readme.txt
Segmentation fault
-------------------------------------------------------------------
System: Ubuntu Server v8.10, i386 32bit.

Update:
I can get the server to run, by only using JPG-files :x

So it seems that its some of the content, that gets scanned, and then causes the server to crash - not good!

Anyone have any idea whats causing this?

Nicolai

vonedaddy
Posts: 22
Joined: Fri Feb 27, 2009 4:20 pm
AV Hardware: PS3

Re: Segmentation fault

Post by vonedaddy » Mon Jun 01, 2009 10:43 pm

I am having this same problem still, any word on a fix?


Jun 1 17:34:20 localhost kernel: twonkymediaserv[2079]: segfault at 621f56e0 ip 0804f17f sp b79fe3f0 error 4 in twonkymediaserver[8048000+9c000]

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Re: Segmentation fault

Post by mgillespie » Sat Jul 04, 2009 12:37 pm

It's unlikely you will see a fix, given the zero information that's been provided on this.

None of the basic information has been given, nor any of the first line troubleshooting steps. (see stickies for details).

Most importantly, does it segfault when it's got no media in it's library? (ie. is it a specific media file thats making it segafult?).

If you really want this fixing, then you need to at least do a small amount of legwork yourself. I run the Linux build myself and don't have any issues, so it's clearly configuration or media specific, and thus the engineers at PV need to know how your setup is different to mine..
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Re: Segmentation fault

Post by mgillespie » Fri Aug 07, 2009 10:04 pm

I had some problems with v5.0.x builds segfaulting on a SheevaPlug. (the v4.x builds work and the 5.1 betas work). Anyhow, after a bit of troubleshooting, I have discovered that if I rename convert.exe in the cgi-bin directory to something else, the server stays up without failing.

So I have narrowed the segfaulting down to the ImageMagick Convert.exe causing the problems. If you are having problems, it might be worth trying this out.

Obviously without the convert, the server is going to have trouble sending scaled album art and such, but i feel i'm on the road to solving the problem. Perhaps I am missing an external library that ImageMagick needs..
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

Post Reply