Twonky Server does not start after reboot - ubuntu 9.10

Linux and UNIX specific discussions
Post Reply
Selti
Posts: 2
Joined: Mon Jan 18, 2010 1:40 pm
AV Hardware: PS3, WD TV Live HD, XBMC, Windows Vista Media Center

Twonky Server does not start after reboot - ubuntu 9.10

Post by Selti » Mon Jan 18, 2010 2:19 pm

Hi together,
first of all I have to admit that I'm an aboslute Linux newbie, so please don't laugh too loud...

And of course I already spent several hours googling for answers, but did not succed.

Ok, here's my problem:

This weekend I started my new NAS project. I use an Intel Atom board and installed Ubuntu 9.10 from scratch via a bootable CD.

Everthing worked fine, now I have a nice Gnome desktop, an account, an IP-connection etc.

Then I downloaded the Twonky Server for Linux (SH file) into my download directory. I tried to install it by double clicking the icon in the Download directory, but that did not work. So I opened a console session, navigated to the download directory and typed: sudo sh twonkyblabla-i368-blabla.sh

After entering my sudo password several messages appeared, the end was a message saying something about deamonizing and tadaaa... the twonky server was running fine, I went to the HTTP configuration, added some media paths, tried to access the content from my WD TV live... everything perfect, less trouble than I expected.

But after rebooting Ubuntu the Twonky server was not running anymore. I also did not find any icon or control button to start it manually (like in the Windows version) or any setting that says 'autostart after boot' or something like that.
As I did not know how to start it manually I simply ran the installation again and after the installation it was running again (of course).

So here are my questions:
1. Is there an easy way to start the Twonky server manually?
2. What must I do to make the Twonky Server autostart?

BTW, during my google actvities found out that autostarting demons must have something to do with entries in the /etc/init.d directory and in fact I found a Twoymedia entry there... so why does it not work?

Looking forward to Your answers...

Kind regards
Selti




.

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Re: Twonky Server does not start after reboot - ubuntu 9.10

Post by mgillespie » Mon Jan 18, 2010 11:34 pm

Try this: (as root)

Code: Select all

cd /etc/rc2.d
ln -s ../init.d/mediaserver S99mediaserver
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

User avatar
DaemonBeetle
Posts: 305
Joined: Mon Dec 28, 2009 11:05 am
AV Hardware: Plex Media Server, Samsung Smart TV (2009 and 2013)

Re: Twonky Server does not start after reboot - ubuntu 9.10

Post by DaemonBeetle » Tue Jan 19, 2010 2:13 pm

In init.d are the master scripts, they need to be linked to the right locations for them to be called during startup and shutdown. The command that manages these links is "update-rc.d" and it's man page will tell you everything you need to know. If the script in /etc/init.d is called "mediaserver" then running "update-rc.d mediaserver defaults" will add the links correctly.

mgillespie's solution will work, but it means that Twonky will be shut down hard when you reboot or shut your system down. By using update-rc.d it will also be shut down cleanly, at the right time.
No longer running Twonky

Post Reply