Upgrade failed from 6.01 -> 6.0.28

Linux and UNIX specific discussions
Post Reply
BenF
Posts: 5
Joined: Mon Nov 22, 2010 1:46 am
AV Hardware: Phillips Streamium; Sony KDL37W5500

Upgrade failed from 6.01 -> 6.0.28

Post by BenF » Mon Nov 22, 2010 1:54 am

Just have been trying to upgrade to the current 6.0.28 installation, but without succes onto my Centos5.5 based DIY NAS box.

First - I tried just running the normal install .sh script, but that failed, leaving 6.01 running.

Searching here I found a recommendation based around a remove / reinstall ( no big deal for me )

Stopping the service, and then :

rm -Rf /var/twonkymedia
rm -Rf /usr/local/twonkymedia

Followed by

./twonkymedia-i386-glibc-2.2.5-6.0.28.sh

gives the below output - any idea what's wrong :

Installing TwonkyMedia server into directory /usr/local/twonkymedia
./
./twonkymedia
./cgi-bin/
./cgi-bin/ffmpeg-mov-flv.desc
./cgi-bin/convert-readme.txt
./cgi-bin/ffmpeg-flv-mpg.desc
./cgi-bin/convert
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers

gunzip: stdin: invalid compressed data--crc error

gunzip: stdin: invalid compressed data--length error
tar: Error exit delayed from previous errors
chmod: cannot access `/usr/local/twonkymedia/twonkymedia.sh': No such file or directory
chmod: cannot access `/usr/local/twonkymedia/twonkymediaserver': No such file or directory
sed: can't read /usr/local/twonkymedia/twonkymedia.sh: No such file or directory
cp: cannot stat `/usr/local/twonkymedia/twonkymedia.sh': No such file or directory
Starting server ...
./twonkymedia-i386-glibc-2.2.5-6.0.28.sh: line 123: /usr/local/twonkymedia/twonkymedia.sh: No such file or directory
Installation finished

Thuemmi
Posts: 3
Joined: Sun Nov 21, 2010 2:09 pm
AV Hardware: own Linuxserver, LE46C650

Re: Upgrade failed from 6.01 -> 6.0.28

Post by Thuemmi » Mon Nov 22, 2010 9:02 am

Hi,

yesterday i have the same problem. After an new (first i have upload the installfile with sftp) wget http://www.twonky.com/upfiles/twonkymed ... -6.0.28.sh it works. Why? I don't know.

BenF
Posts: 5
Joined: Mon Nov 22, 2010 1:46 am
AV Hardware: Phillips Streamium; Sony KDL37W5500

Re: Upgrade failed from 6.01 -> 6.0.28

Post by BenF » Fri Nov 26, 2010 1:14 am

Bizarre - now got it working by wget'ing it directly as you suggested and then just running the shell script.

I previously had downloaded to a PC, and then SFTP'd it onto the Centos box, but comparing the filesizes the two were different. Looks like it was damaged somehow going via PC.

I'm just pleased to have it all back working once again.

Post Reply