Twonky Media Server Won't Startup after Installation

everything about MacOS
Post Reply
shanepark
Posts: 5
Joined: Sun Sep 03, 2006 12:16 pm

Twonky Media Server Won't Startup after Installation

Post by shanepark » Fri May 21, 2010 5:00 pm

I have an iMac running Snow Leopard 10.6.3 and juts installed Twonky Media Server (TMS), but it refuses to start. I turned on logging in the INI file v=511 and it appears to start, as can be seen from the log lines below. There are then a number of SSDP HTTP message but then, there is a bind error on port 1900. I have run netstat and the network utilitie to see what else is listening on or connect to port 1900, but I can find no application or reference to this port in the details returned.

I have be able to run EyeConnect and Azueus (Vuze) ans stream media to my PS3 which also uses UPNP, but these are not running when I start TMS. Even when they are, A port scan still doesn't show that port 1900 is used.
This iMac also runs VMware fusion and has two addtional IP addresses listed as part of VMWare. ONce it fails to bind on the primary IP at port 1900, it then tries to bind to the VMNET IP addresses on port 1900 with the same unable to bind errors

Even more confusing is that I had a clean build iMac SnowLeopard so I thought I'd give the install a try on this machine. Works perfectly, the only different, it doesn't report and error with binding to port 1900

I hoping some Network Mac genius out there who know more about this then me can give me an idea on how to find out why TMS is unable to bind to port 1900. Of and the Mac firewall is off!

Really appreciate any insights anyone can provide, maybe a TMS developer in the MAC OS X space may have a few idea's as I've run completely out!

Code: Select all

23:16:29:886 LOG_SYSTEM:upnp_server_start IP init: 127.0.0.1
23:16:30:093 LOG_SYSTEM:upnp_server_start server interface 127.0.0.1
23:16:30:093 LOG_SYSTEM:upnp_server_start HTTP Server starting at 127.0.0.1:9000
23:16:30:093 LOG_HTTP:HTTP_accept HTTP server started at http://127.0.0.1:9000/
23:16:30:094 LOG_SYSTEM:upnp_server_start remote access port 9000
23:16:30:094 LOG_SYSTEM:upnp_server_start IP init: 192.168.1.18
23:16:30:094 LOG_SSDP:### starting SSDP listen thread
23:16:30:094 LOG_SYSTEM:upnp_server_start server interface 192.168.1.18
23:16:30:094 LOG_SSDP:### joining SSDP multicast group 239.255.255.250 on if 127.0.0.1 
23:16:30:094 LOG_SSDP:SSDP_heartbeat SSDP heartbeat started for 127.0.0.1:1900
23:16:30:094 LOG_SYSTEM:upnp_server_start HTTP Server starting at 192.168.1.18:9000
23:16:30:094 LOG_HTTP:HTTP_accept HTTP server started at http://192.168.1.18:9000/
23:16:30:094 LOG_SYSTEM: Using interface address: 00:23:DF:95:B7:84
23:16:30:094 LOG_SSDP:SSDP_byebye_packet ### SSDP sending:
NOTIFY * HTTP/1.1
HOST: 239.255.255.250:1900
NT: uuid:7076436f-6e65-1063-8074-0023df95b784
NTS: ssdp:byebye
USN: uuid:7076436f-6e65-1063-8074-0023df95b784

Code: Select all

23:16:30:480 LOG_SYSTEM:upnp_server_start remote access port 9000
23:16:30:483 LOG_SSDP:SSDP_heartbeat could not bind to 192.168.1.18:1900

Post Reply