TwonkyServer 6.0.38 occasionally stutters when streaming

Other OS or NAS discussions
Post Reply
balders
Posts: 1
Joined: Sat Dec 31, 2011 1:19 am
AV Hardware: ReadyNAS Ultra 4 Plus

TwonkyServer 6.0.38 occasionally stutters when streaming

Post by balders » Sat Dec 31, 2011 1:30 am

Hi All

I have installed TwonkyServer 6.0.38 on a Netgear ReadyNAS Ultra 4 Plus and I stream content to an Xbox 360 over ethernet.

Nearly all divx/xvid content streams fine to the Xbox 360 however some of this content suffers from extreme stuttering and when monitoring my NAS I see that the CPU usage hovers between 7%-10% when this occurs. When content streams without any stuttering the CPU usage is at 0% which is interesting because the NAS is not transcoding. I have used GSpot to confirm that these media files have been encoded with the same codec.

I tried doubling the streambuffer size from 16384 to 32768 in twonkymedia-server.ini however it didn't make any difference to the avi files that stuttered.

Has anyone else got this problem? It's interesting that the CPU usage spikes whenever this problem occurs - perhaps it's a bug with TwonkyServer?

Any suggestions would be greatly appreciated!

Cheers

Sam

Twonky_Rick
Posts: 3816
Joined: Wed Nov 19, 2008 1:59 am
AV Hardware: Samsung 650 Series TV (2010), 4.5TB HP MediaSmart server with 100,000 songs, 5) AT&T U-Verse STB, CE form-factor Media Center PC and 6 other networked PCs running TwonkyManager, 2 Sonos ZP80, Sonos S5 speaker, Apple TV (running XBMC), Roku Soundbridge, X-Box 360, Sony PS3, Kodak 10" Wireless Photo Frame, iPhone with PlugPlayer software, Sonos CR-100.
Location: San Diego
Contact:

Re: TwonkyServer 6.0.38 occasionally stutters when streaming

Post by Twonky_Rick » Tue Jan 03, 2012 9:09 pm

Make sure your NAS isn't encrypted. Also make sure nothing is running in the background like Antivirus software.

- Rick
Follow me on Twitter! mostlytech1
Checkout my blog: http://mostly-tech.com/

Post Reply