Page 1 of 1

Qnap. Strange filenames and no streaming subtitles

Posted: Sat Dec 31, 2011 6:45 pm
by papars
New to this area, so don't flame me if this is asked before.
A quick search did not reveal anything.

My Qnap NAS runs twonky 6.0.34
I'm trying to understand why I can't play .srt subtitles.
There is no problem when I play the media files through file browser, but when I try to play the file through the twonky browser in my XP PC the .srt file is not requested.

I notice that when I click on a file to be played (in the twonky browser) I'm presented with a strange file name, instead for example "this is a movie file.avi" VLC media player is asked to play something like "O0$328I11599.avi"

The fact that the file name is irrelevant to the original file prevents me from having the subtitles locally thus bypassing the inability of the server to stream them.

I'm having the same behavior on my android device when I use Bubbleupnp as client and MX video player as rendering application. Again the MX player is asked to play a "strange" filename instead of the original filename and no subtitles are shown.

Before you ask, there is no newer version for twonky on this NAS.

Any help to understand this issue with subtitles is appreciated.

Re: Qnap. Strange filenames and no streaming subtitles

Posted: Sat Dec 31, 2011 11:34 pm
by parnott
There is no way in the UPNP/DLNA standard to play subtitles. Twonky have tried to implement the Samsung proprieitory method of playing subtitles, but it seems to break with each new revision of Samsung hardware. So the chnaces are that you won't get subtitles working unless you embed them with the media file.

Those 'strange file names' are not file names, they are the resource identifiers that Twonky has assigned to the file. They do not persist across restarts of Twonky server.

In the UPNP/DLNA standard, a client asks (browses) the server to provide a list of resources in a folder, the server responds with the resources and their identifiers. The resource identifiers (which can be folders or files) have no meaning outside the particular session between the UPNP/DLNA client and the server.

Re: Qnap. Strange filenames and no streaming subtitles

Posted: Sun Jan 01, 2012 8:23 pm
by papars
Happy New Year.

Thank you for clearing this up.
In light of this I wonder why you "twonky" did not yet create your own addition to the standard to support external subtitles. I'm sure the client applications will eventually follow it. It seems that many people would love to see such addition.

Based on your explanation I decided that DLNA is not suited for me as is not practical for me to embed the subtitles into the movie. Therefore for the sake of completeness in my question I have solved the problem by bypassing (i.e. not use at all) DLNA. I have used an application called cifsManager to mount my remote media directories as local. That way the media player on my tablet plays just fine the movie and its accompanied external srt file.