Page 1 of 1

File not found when attempting to stream

Posted: Wed Mar 10, 2021 11:34 am
by o771
Twonky Server version 8.5.2-3 on a Western Digital ‘My Cloud Mirror’ NAS running firmware version 5.10.122.

I’ve been using Twonky with three different DLNA clients to stream music from my WD NAS ‘forever’ and it has worked faultlessly — until recently… Now, although I can navigate my music repository without problem, when I select a track to play, the client tells me it failed. I turned on some logging and here’s what I see.

When I use a DLNA client to browse my music on the NAS, Twonky returns details of the individual tracks in XML format and specifies file names of the form:


(The pathname for this file on the NAS is actually /Public/Shared Music/Al Stewart/Past, Present And Future/01.Old Admirals.mp3)

When I tell my DLNA client to play this particular track, the client requests the filename that Twonky gave it, but Twonky logs a "File not found" error and appears to return an HTTP 404 to the DLNA client.

AFAICT Twonky is giving the client a handle for an MP3 file, but when it is subsequently asked to stream that file, Twonky cannot resolve the handle.

FWIW, I have tried uninstalling/reinstalling Twonky on the NAS, which should have caused it to rebuild its index of music files, so I don't think the problem is that Twonky's index is out-of-sync with the NAS content.

Does anyone have any ideas why I might be seeing File not found errors? Is the file name encoding /disk/DLNA-PNMP3-OP01-FLAGS01700000/O0$1$8I9729.mp3 a Twonky-internal representation? If so, what could cause Twonky to fail to map that to the file’s actual path name on the NAS?

I can’t be certain when this issue first started, though I suspect it was after a WD firmware update that got applied automatically. I certainly didn’t change anything myself. I have a case open with WD support, but although Twonky is supplied by WD as an optional app for the NAS, they (not unreasonably) don’t have the expertise to analyse Twonky logs.


Re: File not found when attempting to stream

Posted: Mon Apr 12, 2021 7:48 pm
by dereedy
I believe I am having the same problem. I am on the same server version on a WD MyCloud NAS. I hadn't been using Twonky for long, because I had just purchased a new Denon receiver that allowed me to make use of it, but I was using it for a week or two successfully before it started failing. I can use the internal Twonky web interface, or the HEOS app on my phone to navigate music in Twonky, but when I try to play anything I get a message on my receiver that says "Unable to play" or a web interface message that says "Cannot beam to the device." The link that tries to open from the web interface is:


The actual link on my NAS is:
\\NASNAME\Public\Shared Music\U2\War\10_40.mp3

Re: File not found when attempting to stream

Posted: Mon Apr 12, 2021 7:55 pm
by dereedy
I just noticed that when you look through their download directory for the newest version of the server software specifically built for v5.0 of the WD MyCloud NAS operating system. I wonder if that could be part of the problem.

Re: File not found when attempting to stream

Posted: Tue Apr 13, 2021 9:47 am
by o771
I installed Plex instead.

Cong Ty C? Ph?n Thuong M?i D?u Tu Va Phat Tri?n Cong Ngh? Sctt

Posted: Thu May 26, 2022 5:34 am
by clippingimageexpert1