Page 1 of 1

"Out of memory" on WL-HDD

Posted: Sun Sep 02, 2007 9:44 am
by plitzi
I'm using TwonkyMedia 4.4 installed on a Asus WL-HDD with Oleg-firmware version and have enabled the smb to see the WL-HDD as network-drive (share$). Everything works fine, only when I copy files via smb from or to the WL-HDD, the twonky-threats were killed because of "out of memory". This only happens, when I copy a "lot of files", for single files or maybe 10s or 20s there is no problem. I've allready tried to use a newer firmware for the WL-HDD, but the newer versions fails to sync the time-server and when I remember correct, there was the same problem by using smb-share. I know, that is not a problem only of the current version of twonky, because all the versions I know (from 3.1 I started last year) works the same way in this case.

Dose anybody have the same problems? Any suggestions for me, to try alternative firmware, settings?

Or maybe better hardware (LAN, low power consumtion (thats wy I prefer a 2,5"-HDD)) for it?


Re: "Out of memory" on WL-HDD

Posted: Fri Sep 28, 2007 5:49 am
by moree001
your swappartition seems to small

Posted: Fri Sep 28, 2007 5:07 pm
by plitzi
Thank you very much, but I think I solved the problem already.

You are right with your hint to a nessesary swappartition. I found some post in other forums about this and also a realy good guide to create a swapfile (no extra partition needed!) on the WL-HDD (

So I can say, that it works all right for me with a swapfile of 512Mbyte and there where no crashes after I made the modification. The only thing I didn't get running is the autostart of using swapfile, but my WL-HDD runs 24houres and you can activate the swapfile also via telnet or commandline in the web-interface of the WL-HDD.

Maybe this statemant can help other users with the same problem.