Twonky 4.4.9 keeps spawning new processes then crashes

Other OS or NAS discussions
Post Reply
aland
Posts: 2
Joined: Thu Nov 06, 2008 12:05 pm
AV Hardware: TeraStation Pro (PPC) running Twonky. Clients: Roku Soundbridge M1001 & Soundbridge Radio, Xbox with XBMC, Xbox 360, Roberts WM201.

Twonky 4.4.9 keeps spawning new processes then crashes

Post by aland » Thu Nov 06, 2008 12:19 pm

Hello,

I've been running Twonky for years (since version 3.0) on my TeraStation Pro PPC. In the past it has been stable, however since upgrading to version 4.4.9 a month ago it crashes every few days.
After a system restart there are 9 twonky processes, however every day more are spawned until after 2 are 3 days my clients cannot find the server, and I need to reboot the NAS to fix it again.

Last restart yesterday, process list now:

root@STORE:~# ps -ef | grep twonky
root 692 1 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymedia
root 693 692 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 697 693 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 698 697 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 699 697 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 700 697 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 701 697 0 Nov05 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 702 697 0 Nov05 ? 00:00:04 /mnt/array1/share/twonky/twonkymediaserver
root 703 697 0 Nov05 ? 00:08:50 /mnt/array1/share/twonky/twonkymediaserver
root 8913 697 0 08:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 8944 697 0 08:22 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 8985 697 0 08:25 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 9016 697 0 08:29 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 9047 697 0 08:32 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 9078 697 0 08:35 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 9119 697 0 08:39 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 10674 10524 0 11:13 pts/0 00:00:00 grep twonky

So for some reason a load more processes were launched between 08:19 and 08:39 today. No clients were in use then.

Reboot, process list:

root@STORE:~# ps -ef | grep twonky
root 691 1 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymedia
root 692 691 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 697 692 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 698 697 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 699 697 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 700 697 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 701 697 0 11:19 ? 00:00:00 /mnt/array1/share/twonky/twonkymediaserver
root 702 697 2 11:19 ? 00:00:01 /mnt/array1/share/twonky/twonkymediaserver
root 703 697 73 11:19 ? 00:00:57 /mnt/array1/share/twonky/twonkymediaserver
root 730 726 0 11:20 pts/0 00:00:00 grep twonky

Should there really be this many instances of 'twonkymediaserver' running? Why are more getting spawned each day? How do I fix it!?

The TeraStation is running the latest firmware, version 112.

Any help apprieciated.

Alan.

jockamo
Posts: 8
Joined: Mon Oct 13, 2008 10:26 pm
AV Hardware: Buffalo Home Server, Roku Soundbridge

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by jockamo » Tue Nov 11, 2008 9:55 pm

I've no answer for you I'm afraid but I'm experiencing the exact same issue with version 4.4.9 on a Buffalo Terastation HS. 4.4.9 is the first version I've installed so I had assumed it was something I was doing wrong. Symptoms are same - after reboot I get 9 twonkym processes and everything works ok. After a period of time twonky stops responding to browser and Roku Soundbridge client access and when I look there are many more twonkym processes present.

root 11435 861 0 19:33 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 11548 861 0 19:35 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 11653 861 0 19:36 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 11751 861 0 19:37 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 11864 861 0 19:38 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 11972 861 0 19:40 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 12077 861 0 19:41 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 12190 861 0 19:42 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 12295 861 0 19:44 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 12400 861 0 19:45 ? 00:00:00 /mnt/array1/share/twonky/twonkym
root 13372 861 0 19:56 ? 00:00:00 /mnt/array1/share/twonky/twonkym
and so on and on and on...

I've tried various things including setting rescan to 0. No change.

Reboot seems to be the only recovery.

Please post if you find a resolution!

pele
Posts: 2
Joined: Wed Oct 29, 2008 11:21 am
AV Hardware: lspro 500

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by pele » Wed Nov 12, 2008 3:33 am

see the bottom of this thread: http://www.twonkyforum.com/viewtopic.php?f=8&t=5556
i had the same problem and many others with my linkstation nas. problem was resolved by installing a previous version

aland
Posts: 2
Joined: Thu Nov 06, 2008 12:05 pm
AV Hardware: TeraStation Pro (PPC) running Twonky. Clients: Roku Soundbridge M1001 & Soundbridge Radio, Xbox with XBMC, Xbox 360, Roberts WM201.

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by aland » Wed Nov 12, 2008 1:41 pm

Pete - thanks for suggestion. I have version 4.4.6 available so will install that and see if things improve.

Alan.

jockamo
Posts: 8
Joined: Mon Oct 13, 2008 10:26 pm
AV Hardware: Buffalo Home Server, Roku Soundbridge

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by jockamo » Wed Nov 12, 2008 9:44 pm

I went back to 4.4.6 last night but am still getting the same behaviour. I rebooted the Buffalo HS at about 8.30 pm last night and everything looks to have been ok to about 5.30 pm today when new processes start spawning every 1-2 minutes. The only activity at that time would have been my son coming home and turning on his pC (plus Windows Media Player) and an Xbox.

jockamo
Posts: 8
Joined: Mon Oct 13, 2008 10:26 pm
AV Hardware: Buffalo Home Server, Roku Soundbridge

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by jockamo » Thu Nov 13, 2008 10:50 pm

I think I've solved this by setting client security to prevent all devices other than my Roku Soundbridge from connecting. It looks like WMP on my son's PC was somehow triggering twonky child processes from spawning every 60 seconds or so. Just a theory. Now have to decide whether to go back to 4.4.9 or leave well alone on the basis that it's working.

phattooth
Posts: 5
Joined: Sun Nov 16, 2008 9:46 pm
AV Hardware: Server - Buffalo TeraStation / Twonky Ver-4.4.9

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by phattooth » Sun Nov 16, 2008 9:52 pm

jockamo wrote:I think I've solved this by setting client security to prevent all devices other than my Roku Soundbridge from connecting. It looks like WMP on my son's PC was somehow triggering twonky child processes from spawning every 60 seconds or so. Just a theory. Now have to decide whether to go back to 4.4.9 or leave well alone on the basis that it's working.
jockamo, i have a terastation with 4.4.9 installed and am having the same issue... i'll try setting security to prevent all but my PS3 (i know it's different than the Roku, but it will still be excluding all WMP's on my network) and post back with the findings to see if WMP is the culprit.

jockamo
Posts: 8
Joined: Mon Oct 13, 2008 10:26 pm
AV Hardware: Buffalo Home Server, Roku Soundbridge

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by jockamo » Mon Nov 17, 2008 6:41 pm

I was mistaken unfortunately. The problem occurred again last night and I'm pretty sure now that the culprit is the Xbox and not WMP. I had set client security as described and everything worked grand for days and then the minute my son turned on his Xbox I see twonky processes start to spawn every minute or so and it stops responding to browser connections and my Roku soundbridge. I'm still running 4.4.6 but symptoms were exactly same with 4.4.9.

phattooth
Posts: 5
Joined: Sun Nov 16, 2008 9:46 pm
AV Hardware: Server - Buffalo TeraStation / Twonky Ver-4.4.9

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by phattooth » Thu Nov 20, 2008 9:26 pm

Didn't work with the PS3 either... locked all down but it, still crashing.

So i don't think it's the xbox specifically, as i get it here with just the PS3 as well.

Any other thoughts? I'm kinda at a loss now...

paw123
Posts: 4
Joined: Fri Nov 24, 2006 6:36 pm

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by paw123 » Wed Dec 17, 2008 4:02 pm

After upgrading to 4.4.9 I had the same issues. Tried everything that was suggested here and it did not help. Twonky would crash erratically.

I am not a network expert but I solved the problem for me: It seems like this only happens if you connect computers to your network that are in a different workgroups. I do not have any issues if all computer on my home network are in the same workgroup. The moment though I connect my work laptop (or some other machine with a different wokrgroup ID), the symptoms described all over the forum occur.

My old Terastation has been running Twonky now for 2 weeks without a crash :-)

Still a solution to this would help. Also I-phones connecting to our wireless bring it down... sigh.

jockamo
Posts: 8
Joined: Mon Oct 13, 2008 10:26 pm
AV Hardware: Buffalo Home Server, Roku Soundbridge

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by jockamo » Wed Dec 17, 2008 11:09 pm

OK I've fixed my problem. Hopefully this will help you too. To recap, every time my son turned on his Xbox, Twonky would stop responding to all clients on the network. On the Terastation I could see twonkymediaserver processes spawning every few minutes.

The problem appears to be that Twonky tries to ping back to the client that is trying to connect. If that ping hangs for some reason then Twonky is hung too. I could see the a further child process spawned from the twonkymediaserver process that started up when the Xbox was turned on:

/bin/ping -c 1 192.168.0.2

Running the same command from the command also hangs.

So I moved ping to ping.orig and created a shell script called ping in /bin containing just one line:

exit 0

Made that executable with chmod +x /bin/ping. And now it's working. The Xbox now shows the TS as a music server (for the first time).

Hope this is of some benefit to you. if you see a hung ping process then try the above; or maybe fix why the ping back is hanging.

orosz
Posts: 1
Joined: Sun Jan 04, 2009 5:24 am
AV Hardware: Xbox360 - Buffalo Terastation 1GB - TwonkyMedia 4.9.9 - DViCO TViX PVR-4000

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by orosz » Sun Jan 04, 2009 5:27 am

You are a legend. I was almost poised to discard TwonkyMedia Server off my Terastation. Months of anguish, many a firmware reset of my terastation to no avail. Your "ping fix" is the answer to my prayers. Now I'm off to isten to my music on my Xbox 360!

MikeIsotech
Posts: 21
Joined: Thu Jan 03, 2008 8:44 pm

Re: Twonky 4.4.9 keeps spawning new processes then crashes

Post by MikeIsotech » Wed Jan 14, 2009 10:24 pm

I've just tried the ping trick with 4.4.11 and haven't had much luck so far. I left the box running and eventually the media server did run but it hasn't since I changed some of the config options (paths etc) and restarted the server.

For information my NAS box is a Buffalo Linkstaion Live. I'm using a PS3 and a Philips SLA5520 as media clients.

Post Reply